aboutsummaryrefslogtreecommitdiff
path: root/print/perlftlib
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>1999-01-01 22:18:54 +0000
committerSADA Kenji <sada@FreeBSD.org>1999-01-01 22:18:54 +0000
commit6854484cd32be3b74c42ea0eceb35265cdaaa050 (patch)
treed606264e703490c17a4557dac5174e7c42c26f41 /print/perlftlib
parent8b10be26ac9941c369869cbe43be6f4b56e5fe14 (diff)
downloadports-6854484cd32be3b74c42ea0eceb35265cdaaa050.tar.gz
ports-6854484cd32be3b74c42ea0eceb35265cdaaa050.zip
This is a package of libraries to use the FreeType library from the
perl language. It contains following pieces. <FreeType.xs> This is a simple caller of the FreeType library. It has same API as the FreeType library, so please read a manual of that to understand how to use this. <FreeTypeWrapper.pm> This is a simple wrapper of FreeType.xs to use the FreeType library from perl with easy, perl-like API. <ftinfo.pl> This is a dumper of a lot of information in each TrueType fonts. This convert them as human readable strings. <mkttfdir.pl> This is a maker of fonts.dir by parsing TTF and TTC fils. It has special handler for DynaLab fonts, so it make good fonts.dir automatically. And it detects what language's fonts are contained in it by looking at code_page_range field in os2 table, so it makes right entries. See also <http://www.io.com/~kazushi/xtt/#perlftlib> Note that ftinfo core-dumps with a signal 11 in case using perl5.00502. :-) Submitted by: Satoshi TAOKA <taoka@infonets.hiroshima-u.ac.jp>
Notes
Notes: svn path=/head/; revision=15761
Diffstat (limited to 'print/perlftlib')
-rw-r--r--print/perlftlib/Makefile40
-rw-r--r--print/perlftlib/distinfo1
-rw-r--r--print/perlftlib/files/patch-aa35
-rw-r--r--print/perlftlib/pkg-comment1
-rw-r--r--print/perlftlib/pkg-descr23
-rw-r--r--print/perlftlib/pkg-plist11
6 files changed, 111 insertions, 0 deletions
diff --git a/print/perlftlib/Makefile b/print/perlftlib/Makefile
new file mode 100644
index 000000000000..93065f592acc
--- /dev/null
+++ b/print/perlftlib/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: perlftlib
+# Version required: 1.2
+# Date created: 98/12/22
+# Whom: Satoshi TAOKA <taoka@infonets.hiroshima-u.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= perlftlib-1.2
+CATEGORIES= print perl5
+MASTER_SITES= ftp://ftp.big.or.jp/pub/usr2/jam/ft/ \
+ http://WWW.FreeBSD.ORG/~sada/distfiles/ \
+ http://WWW.jp.FreeBSD.ORG/~sada/distfiles/
+
+MAINTAINER= taoka@infonets.hiroshima-u.ac.jp
+
+LIB_DEPENDS= ttf.3:${PORTSDIR}/print/freetype
+RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/jcode.pl:${PORTSDIR}/japanese/p5-jcode.pl
+
+USE_PERL5= yes
+NOMANCOMPRESS= yes
+MAN1= mkttfdir.1 ftinfo.1
+
+MAKE_ENV= PERL_VER=${PERL_VER} PERL5=${PERL5}
+
+pre-patch:
+ ${MV} ${WRKSRC}/FreeType/Makefile.PL ${WRKSRC}/FreeType/Makefile.PL.bak
+ ${SED} 's,/usr/local/X11R6.3,${PREFIX},' \
+ ${WRKSRC}/FreeType/Makefile.PL.bak \
+ > ${WRKSRC}/FreeType/Makefile.PL
+
+post-build:
+ cd ${WRKSRC}; \
+ for DIST in ftinfo mkttfdir; do \
+ ${MV} $${DIST} $${DIST}.bak; \
+ ${SED} -e 's;^#! */usr/local/bin/perl *;#!${PERL5};' \
+ $${DIST}.bak > $${DIST}; \
+ done
+
+.include <bsd.port.mk>
diff --git a/print/perlftlib/distinfo b/print/perlftlib/distinfo
new file mode 100644
index 000000000000..b1cf3a73cf8f
--- /dev/null
+++ b/print/perlftlib/distinfo
@@ -0,0 +1 @@
+MD5 (perlftlib-1.2.tar.gz) = b8b520dd355181b572a465bebf822d02
diff --git a/print/perlftlib/files/patch-aa b/print/perlftlib/files/patch-aa
new file mode 100644
index 000000000000..239c351c40db
--- /dev/null
+++ b/print/perlftlib/files/patch-aa
@@ -0,0 +1,35 @@
+--- ./Makefile.orig Mon Dec 14 14:13:26 1998
++++ ./Makefile Tue Dec 22 16:14:46 1998
+@@ -1,8 +1,8 @@
+
+-BINDIR = /usr/local/bin
+-MANDIR = /usr/local/man/man1
+-PERL = perl
+-PERLLIBDIR = /usr/local/lib/perl5/site_perl
++BINDIR = ${PREFIX}/bin
++MANDIR = ${PREFIX}/man/man1
++PERL = ${PERL5}
++PERLLIBDIR = ${PREFIX}/lib/perl5/site_perl
+
+ VERSION = 1.2
+
+@@ -12,7 +12,9 @@
+ all: $(FREETYPELIB) $(PROGRAMS) $(MANFILES)
+
+ install: installlib $(PROGRAMS)
+- cp $(PROGRAMS) $(BINDIR)
++ for file in $(PROGRAMS); do \
++ ${BSD_INSTALL_SCRIPT} $${file} $(BINDIR); \
++ done
+ rm -f $(MANDIR)/ftinfo.1
+ ln -s $(BINDIR)/ftinfo $(MANDIR)/ftinfo.1
+ rm -f $(MANDIR)/mkttfdir.1
+@@ -43,7 +45,7 @@
+
+ installlib: $(FREETYPELIB)
+ cd FreeType; $(MAKE) $(MFLAGS) install
+- cp FreeTypeWrapper.pm $(PERLLIBDIR)
++ cp FreeTypeWrapper.pm $(PERLLIBDIR)/${PERL_VER}
+
+ $(FREETYPELIB): FreeType/Makefile
+ cd FreeType; $(MAKE) $(MFLAGS)
diff --git a/print/perlftlib/pkg-comment b/print/perlftlib/pkg-comment
new file mode 100644
index 000000000000..cac0e5120614
--- /dev/null
+++ b/print/perlftlib/pkg-comment
@@ -0,0 +1 @@
+libraries to use the FreeType library from the perl language
diff --git a/print/perlftlib/pkg-descr b/print/perlftlib/pkg-descr
new file mode 100644
index 000000000000..37676088187c
--- /dev/null
+++ b/print/perlftlib/pkg-descr
@@ -0,0 +1,23 @@
+This is a package of libraries to use the FreeType library from the
+perl language. It contains following pieces.
+
+<FreeType.xs> This is a simple caller of the FreeType library. It has
+same API as the FreeType library, so please read a manual of that to
+understand how to use this.
+
+<FreeTypeWrapper.pm> This is a simple wrapper of FreeType.xs to use
+the FreeType library from perl with easy, perl-like API.
+
+<ftinfo.pl> This is a dumper of a lot of information in each TrueType
+fonts. This convert them as human readable strings.
+
+<mkttfdir.pl> This is a maker of fonts.dir by parsing TTF and TTC
+fils. It has special handler for DynaLab fonts, so it make good
+fonts.dir automatically. And it detects what language's fonts are
+contained in it by looking at code_page_range field in os2 table, so
+it makes right entries.
+
+See also <http://www.io.com/~kazushi/xtt/#perlftlib>
+
+Note that ftinfo core-dumps with a signal 11 in case using
+perl5.00502. :-)
diff --git a/print/perlftlib/pkg-plist b/print/perlftlib/pkg-plist
new file mode 100644
index 000000000000..39cbcb3d6dd3
--- /dev/null
+++ b/print/perlftlib/pkg-plist
@@ -0,0 +1,11 @@
+bin/mkttfdir
+bin/ftinfo
+lib/perl5/site_perl/%%PERL_VER%%/FreeTypeWrapper.pm
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/FreeType/FreeType.so
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/FreeType/FreeType.bs
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/FreeType/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/FreeType/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/FreeType.pm
+@comment I do not know how to treat the next files
+@comment lib/perl5/%%PERL_VERSION%%/i386-freebsd/perllocal.pod
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/FreeType