aboutsummaryrefslogtreecommitdiff
path: root/print/pic2fig
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-02-10 00:56:57 +0000
committerPatrick Li <pat@FreeBSD.org>2002-02-10 00:56:57 +0000
commit5eb1bd5f81a1a4aa36a7f8d8f1c800ab7bda85df (patch)
treecde8366c2eb0c3e74f1fc657a29a551ea95fba91 /print/pic2fig
parent02b233041b2fd4e9b4362f4e761806c5145ca971 (diff)
downloadports-5eb1bd5f81a1a4aa36a7f8d8f1c800ab7bda85df.tar.gz
ports-5eb1bd5f81a1a4aa36a7f8d8f1c800ab7bda85df.zip
- Fix translation of dashed or dotted lines
- Bump PORTREVISION PR: 34678 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=54461
Diffstat (limited to 'print/pic2fig')
-rw-r--r--print/pic2fig/Makefile1
-rw-r--r--print/pic2fig/files/patch-ab15
2 files changed, 8 insertions, 8 deletions
diff --git a/print/pic2fig/Makefile b/print/pic2fig/Makefile
index 0b109aa7d62e..9aeb7e5026d4 100644
--- a/print/pic2fig/Makefile
+++ b/print/pic2fig/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pic2fig
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= utilities
diff --git a/print/pic2fig/files/patch-ab b/print/pic2fig/files/patch-ab
index 1d39eacfdd04..d363624bd82b 100644
--- a/print/pic2fig/files/patch-ab
+++ b/print/pic2fig/files/patch-ab
@@ -1,5 +1,5 @@
--- figd.c.orig Sat Aug 6 19:52:43 1988
-+++ figd.c Tue Jan 16 08:26:38 2001
++++ figd.c Wed Feb 6 15:54:17 2002
@@ -6,13 +6,16 @@
*
* Modified by Micah Beck to produce Fig code
@@ -232,7 +232,7 @@
}
pathsent = TRUE;
-@@ -234,17 +346,22 @@
+@@ -234,17 +346,23 @@
{
register int i;
@@ -255,10 +255,11 @@
- fprintf(TEXFILE, "9999 9999\n");
+ }
+ /* fprintf(TEXFILE, "9999 9999\n"); */
++ fprintf(TEXFILE, "\n");
}
pathsent = TRUE;
-@@ -294,7 +411,7 @@
+@@ -294,7 +412,7 @@
fig_arc(xcenter, ycenter, xradius, yradius, start, stop)
float xcenter, ycenter, xradius, yradius, start, stop;
{
@@ -267,7 +268,7 @@
extern double cos(), sin();
map(xcenter, ycenter, &X0, &Y0, FALSE);
-@@ -304,18 +421,85 @@
+@@ -304,18 +422,85 @@
if (is_onarc(PI/2, start, stop)) ckbounds(X0, Y0+yrad);
if (is_onarc(PI, start, stop)) ckbounds(X0-xrad, Y0);
if (is_onarc(1.5*PI, start, stop)) ckbounds(X0, Y0-yrad);
@@ -356,7 +357,7 @@
}
-@@ -347,14 +531,56 @@
+@@ -347,14 +532,56 @@
*/
fig_begin_drawing()
{
@@ -415,7 +416,7 @@
}
-@@ -392,15 +618,67 @@
+@@ -392,15 +619,67 @@
clearpath();
}
@@ -486,5 +487,3 @@
+ }
+ fprintf(TEXFILE, " 0.0\n");
}
-
-