aboutsummaryrefslogtreecommitdiff
path: root/print/pkipplib/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-01-19 13:52:42 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-01-19 13:52:42 +0000
commitd897e29fb692a828cbc0a513104a73dd7949cb17 (patch)
tree61edc42cf433cf1bf10f6b63f68a37889f3c4167 /print/pkipplib/Makefile
parentcf0754b8b82e03578fb052bfd53e737269c1cfe4 (diff)
downloadports-d897e29fb692a828cbc0a513104a73dd7949cb17.tar.gz
ports-d897e29fb692a828cbc0a513104a73dd7949cb17.zip
Add pkipplib which is a prerequisite of pykota.
pkipplib is a Python library which can prepare IPP requests with the help of a somewhat high level API. These requests can then be sent to an IPP printer or print server (e.g. CUPS). This library can also parse IPP answers received, and create high level Python objects from them. WWW: http://www.pykota.com/software/pkipplib/
Notes
Notes: svn path=/head/; revision=226427
Diffstat (limited to 'print/pkipplib/Makefile')
-rw-r--r--print/pkipplib/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/print/pkipplib/Makefile b/print/pkipplib/Makefile
new file mode 100644
index 000000000000..bd70cf509aa9
--- /dev/null
+++ b/print/pkipplib/Makefile
@@ -0,0 +1,19 @@
+# Ports collection Makefile for: pkipplib
+# Date created: Jan 19 2009
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkipplib
+PORTVERSION= 0.07
+CATEGORIES= print python
+MASTER_SITES= http://www.pykota.com/software/pkipplib/download/tarballs/
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Create and parse IPP requests
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>