aboutsummaryrefslogtreecommitdiff
path: root/print/pnm2ppa
diff options
context:
space:
mode:
authorScott Mace <smace@FreeBSD.org>1998-11-18 15:50:24 +0000
committerScott Mace <smace@FreeBSD.org>1998-11-18 15:50:24 +0000
commitd90522ca358e4c1a2315ef3c149c3638849546ce (patch)
tree5ff76ea8ad3225fe018e7c9aa367eae525bca6e1 /print/pnm2ppa
parent1d6cf605455b94adab3912b5fb1e5ffc986ed5d8 (diff)
downloadports-d90522ca358e4c1a2315ef3c149c3638849546ce.tar.gz
ports-d90522ca358e4c1a2315ef3c149c3638849546ce.zip
Initial import of pbm2ppa.
Submitted by: smace@freebsd.org
Notes
Notes: svn path=/head/; revision=14646
Diffstat (limited to 'print/pnm2ppa')
-rw-r--r--print/pnm2ppa/Makefile76
-rw-r--r--print/pnm2ppa/distinfo1
-rw-r--r--print/pnm2ppa/files/asciippafilter.SH5
-rw-r--r--print/pnm2ppa/files/patch-aa9
-rw-r--r--print/pnm2ppa/files/patch-ab11
-rw-r--r--print/pnm2ppa/files/ppafilter.SH4
-rw-r--r--print/pnm2ppa/pkg-comment1
-rw-r--r--print/pnm2ppa/pkg-descr5
-rw-r--r--print/pnm2ppa/pkg-plist5
9 files changed, 117 insertions, 0 deletions
diff --git a/print/pnm2ppa/Makefile b/print/pnm2ppa/Makefile
new file mode 100644
index 000000000000..bfb9d6e78584
--- /dev/null
+++ b/print/pnm2ppa/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: pbm2ppa
+# Version required: 0.8.6
+# Date created: 18 November 1998
+# Whom: smace@freebsd.org
+#
+# $Id: Makefile,v 1.1 1998/09/17 00:32:53 smace Exp $
+#
+
+PKGNAME= pbm2ppa-0.8.6
+DISTNAME= ppa-0.8.6
+CATEGORIES= print
+MASTER_SITES= http://www.rpi.edu/~normat/technical/ppa/files/
+
+WRKSRC= ${WRKDIR}/pbm2ppa-0.8.6
+USE_GMAKE= yes
+
+MAINTAINER= smace@freebsd.org
+
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5 \
+ enscript:${PORTSDIR}/print/enscript
+
+HPMODEL?= 720
+ALL_TARGET= ${HPMODEL}
+
+pre-configure:
+.if ${HPMODEL} != 720 && ${HPMODEL} != 820 && ${HPMODEL} != 1000
+ @${ECHO} "HPMODEL is invalid: ${HPMODEL}."
+ @${ECHO} "You must specify the model of your printer:"
+ @${ECHO} "720 -- HP720 family (HP 722C, etc.)"
+ @${ECHO} "820 -- HP820 family"
+ @${ECHO} "1000 -- HP820 family"
+ @false
+.endif
+.if !defined(PAPERSIZE)
+ @${ECHO}
+ @${ECHO} "No PAPERSIZE environment variable found, will default to enscript-A4"
+ @${ECHO}
+.endif
+
+do-install:
+ sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/ppafilter.SH > ${WRKSRC}/ppafilter
+ sed s#CHANGETHIS#${PREFIX}# < ${FILESDIR}/asciippafilter.SH > ${WRKSRC}/asciippafilter
+ cd ${WRKSRC} && \
+ (${INSTALL_PROGRAM} pbm2ppa pbmtpg \
+ ${PREFIX}/bin; \
+ ${INSTALL_DATA} pbm2ppa.conf.hp${HPMODEL} \
+ ${PREFIX}/etc/pbm2ppa.conf; \
+ ${INSTALL_SCRIPT} ppafilter asciippafilter \
+ ${PREFIX}/bin )
+
+post-install:
+ @${ECHO}
+ @${ECHO} "To configure your printcap to print either ascii"
+ @${ECHO} "or Postscript files, add the following lines to your"
+ @${ECHO} "/etc/printcap file"
+ @${ECHO}
+ @${ECHO} " lp|ascii|unix:\\"
+ @${ECHO} " :lp=/dev/lpt0:\\"
+ @${ECHO} " :sd=/var/spool/lpd:\\"
+ @${ECHO} " :if=/usr/local/bin/asciippafilter:\\"
+ @${ECHO} " :mx#0:\\"
+ @${ECHO} " :sh:"
+ @${ECHO}
+ @${ECHO} " ps:\\"
+ @${ECHO} " :lp=/dev/lpt0:\\"
+ @${ECHO} " :sd=/var/spool/ps:\\"
+ @${ECHO} " :if=/usr/local/bin/ppafilter:\\"
+ @${ECHO} " :mx#0:\\"
+ @${ECHO} " :sh:"
+ @${ECHO}
+ @${ECHO} "Please be sure that you install the proper flavor of"
+ @${ECHO} "enscript, either A4 or Letter, by setting the PAPERSIZE"
+ @${ECHO} "environment variable."
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/print/pnm2ppa/distinfo b/print/pnm2ppa/distinfo
new file mode 100644
index 000000000000..d67eb8c1ab87
--- /dev/null
+++ b/print/pnm2ppa/distinfo
@@ -0,0 +1 @@
+MD5 (ppa-0.8.6.tar.gz) = fb40576435d5979db64fbea305ec224b
diff --git a/print/pnm2ppa/files/asciippafilter.SH b/print/pnm2ppa/files/asciippafilter.SH
new file mode 100644
index 000000000000..3b40c90e8c71
--- /dev/null
+++ b/print/pnm2ppa/files/asciippafilter.SH
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+CHANGETHIS/bin/enscript -B -q -p - | \
+CHANGETHIS/bin/gs -sDEVICE=pbm -q -dNOPAUSE -r600 -sOutputFile=- - | \
+CHANGETHIS/bin/pbm2ppa - -
diff --git a/print/pnm2ppa/files/patch-aa b/print/pnm2ppa/files/patch-aa
new file mode 100644
index 000000000000..0b90a5ca90ef
--- /dev/null
+++ b/print/pnm2ppa/files/patch-aa
@@ -0,0 +1,9 @@
+--- Makefile.orig Tue Sep 22 22:47:02 1998
++++ Makefile Tue Sep 22 22:47:23 1998
+@@ -1,5 +1,5 @@
+ CC=gcc
+-CFLAGS=-Wall -O2
++CFLAGS=-Wall -O2 -DPPA_CONF=\"${PREFIX}/etc/pbm2ppa.conf\"
+ LDFLAGS=
+
+ default:
diff --git a/print/pnm2ppa/files/patch-ab b/print/pnm2ppa/files/patch-ab
new file mode 100644
index 000000000000..46fba083a417
--- /dev/null
+++ b/print/pnm2ppa/files/patch-ab
@@ -0,0 +1,11 @@
+--- pbm2ppa.c.orig Mon Apr 6 23:20:07 1998
++++ pbm2ppa.c Tue Sep 22 22:37:45 1998
+@@ -268,7 +268,7 @@
+ exit(1);
+ }
+
+-char* defaultcfgfile="/etc/pbm2ppa.conf";
++char* defaultcfgfile=PPA_CONF;
+ int main (int argc, char *argv[])
+ {
+ int argn;
diff --git a/print/pnm2ppa/files/ppafilter.SH b/print/pnm2ppa/files/ppafilter.SH
new file mode 100644
index 000000000000..0b27e4c44c17
--- /dev/null
+++ b/print/pnm2ppa/files/ppafilter.SH
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+CHANGETHIS/bin/gs -sDEVICE=pbm -q -dNOPAUSE -r600 -sOutputFile=- - | \
+CHANGETHIS/bin/pbm2ppa - -
diff --git a/print/pnm2ppa/pkg-comment b/print/pnm2ppa/pkg-comment
new file mode 100644
index 000000000000..37ca750a6560
--- /dev/null
+++ b/print/pnm2ppa/pkg-comment
@@ -0,0 +1 @@
+Convert PBM images to PPA for some HP printers
diff --git a/print/pnm2ppa/pkg-descr b/print/pnm2ppa/pkg-descr
new file mode 100644
index 000000000000..0fb5313b00b2
--- /dev/null
+++ b/print/pnm2ppa/pkg-descr
@@ -0,0 +1,5 @@
+This software creates output using the PPA (printer performance
+architecture) protocol. This protocol is used by some HP "Windows-only"
+printers, including the HP Deskjet 820C series, the HP DeskJet 720 series,
+and the HP DeskJet 1000 series. It has been tested on all three printers,
+but your personal experience (positive or negative) is very much appreciated!
diff --git a/print/pnm2ppa/pkg-plist b/print/pnm2ppa/pkg-plist
new file mode 100644
index 000000000000..cefab9ff6810
--- /dev/null
+++ b/print/pnm2ppa/pkg-plist
@@ -0,0 +1,5 @@
+bin/pbm2ppa
+bin/pbmtpg
+bin/ppafilter
+bin/asciippafilter
+etc/pbm2ppa.conf