aboutsummaryrefslogtreecommitdiff
path: root/print/pslib/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-16 17:42:35 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-03-16 17:42:35 +0000
commit1d7a4f76e5a4975098d0fbe4b5c07a34b34fcbef (patch)
treeada1e88e6a98659d4ba843995f9ff015dff8f9b6 /print/pslib/Makefile
parent8046dbb3ce7e75db08c6e9867b79cab71b9a1bb0 (diff)
downloadports-1d7a4f76e5a4975098d0fbe4b5c07a34b34fcbef.tar.gz
ports-1d7a4f76e5a4975098d0fbe4b5c07a34b34fcbef.zip
- Add LICENSE_FILE
- Switch to USES=localbase - Simplify and modernize - Switch to options helpers
Notes
Notes: svn path=/head/; revision=464717
Diffstat (limited to 'print/pslib/Makefile')
-rw-r--r--print/pslib/Makefile53
1 files changed, 19 insertions, 34 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 49c54491417d..5482c09a1549 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -6,59 +6,44 @@ PORTVERSION= 0.4.5
PORTREVISION= 4
CATEGORIES= print
MASTER_SITES= SF
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= C-library for generating multi page PostScript documents
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-USES= gettext gmake jpeg libtool pathfix pkgconfig
+USES= gettext gmake jpeg libtool localbase pathfix pkgconfig
USE_GNOME= intlhack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lintl
+LIBS+= -lintl
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= EXAMPLES MANPAGES NLS
-OPTIONS_DEFAULT= MANPAGES
-OPTIONS_SUB= yes
+EX_DISTNAME= pslib-examples-0.0.10
+EX_WRKSRC= ${WRKDIR}/${EX_DISTNAME}
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= EXAMPLES MANPAGES NLS
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MEXAMPLES}
-EX_NAME= pslib-examples-0.0.10
-EX_WRKSRC= ${WRKDIR}/${EX_NAME}
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EX_NAME}${EXTRACT_SUFX}
-.endif
+EXAMPLES_DISTFILES= ${EX_DISTNAME}${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MMANPAGES}
-BUILD_DEPENDS+= ${LOCALBASE}/bin/docbook-to-man:textproc/docbook-to-man \
- ${LOCALBASE}/bin/docbook2man:textproc/docbook-utils
-.else
-# Avoid building the manpages.
-CONFIGURE_ENV+= ac_cv_prog_DOC_TO_MAN=""
-.endif
+MANPAGES_BUILD_DEPENDS= ${LOCALBASE}/bin/docbook-to-man:textproc/docbook-to-man \
+ ${LOCALBASE}/bin/docbook2man:textproc/docbook-utils
+MANPAGES_CONFIGURE_ENV_OFF=ac_cv_prog_DOC_TO_MAN=""
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ENV+= ac_cv_header_libintl_h=no
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_CONFIGURE_ENV_OFF= ac_cv_header_libintl_h=no
-post-patch:
-.if ! ${PORT_OPTIONS:MNLS}
+post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|@USE_NLS@|no|g' ${WRKSRC}/po/Makefile.in.in
-.endif
-post-install:
- ${MKDIR} -m 0755 ${STAGEDIR}${EXAMPLESDIR}
- @${RM} ${EX_WRKSRC}/Makefile.unix ${EX_WRKSRC}/ChangeLog \
- ${EX_WRKSRC}/CMakeLists.txt
- cd ${EX_WRKSRC} && ${PAX} -rw * ${STAGEDIR}${EXAMPLESDIR}
+post-install-EXAMPLES-on:
+ @cd ${EX_WRKSRC} && ${RM} Makefile.unix ChangeLog CMakeLists.txt && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>