aboutsummaryrefslogtreecommitdiff
path: root/print/pslib/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-01-18 14:27:31 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-01-18 14:27:31 +0000
commitd9e864b2dd2615ce3195851283b34210de31a552 (patch)
tree5760d017e990948f6ac24544b170ab669e295d7d /print/pslib/Makefile
parent0ca85f332eeb4b95153bee410e3294ebd0e3487e (diff)
downloadports-d9e864b2dd2615ce3195851283b34210de31a552.tar.gz
ports-d9e864b2dd2615ce3195851283b34210de31a552.zip
- Enable stagedir support
- Add LICENSE - Convert to new LIB_DEPENDS format - Convert USE_GMAKE=yes -> USES=gmake - Rename MAN option to MANPAGES - Bump PORTREVISION to properly deal with some of the OPTION settings
Notes
Notes: svn path=/head/; revision=340170
Diffstat (limited to 'print/pslib/Makefile')
-rw-r--r--print/pslib/Makefile31
1 files changed, 12 insertions, 19 deletions
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 37febd3049be..4a2a67ce9f1d 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -3,45 +3,40 @@
PORTNAME= pslib
PORTVERSION= 0.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= SF
MAINTAINER= mva@FreeBSD.org
COMMENT= A C-library for generating multi page PostScript documents
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+LICENSE= GPLv2
-USES= pathfix pkgconfig gettext
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
+
+USES= pathfix pkgconfig gettext gmake
USE_GNOME= intlhack
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
USE_LDCONFIG= yes
-OPTIONS_DEFINE= EXAMPLES MAN NLS
-OPTIONS_DEFAULT= MAN NLS
-MAN_DESC= Manual pages
+OPTIONS_DEFINE= EXAMPLES MANPAGES NLS
+OPTIONS_DEFAULT= MANPAGES NLS
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MEXAMPLES}
EX_NAME= pslib-examples-0.0.10
EX_WRKSRC= ${WRKDIR}/${EX_NAME}
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EX_NAME}${EXTRACT_SUFX}
-PLIST_SUB+= EXAMPLES=""
-.else
-PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if ${PORT_OPTIONS:MMAN}
+.if ${PORT_OPTIONS:MMANPAGES}
BUILD_DEPENDS+= ${LOCALBASE}/bin/docbook-to-man:${PORTSDIR}/textproc/docbook-to-man \
${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
-MAN3!= ${CAT} ${FILESDIR}/man3
.else
# Avoid building the manpages.
CONFIGURE_ENV+= ac_cv_prog_DOC_TO_MAN=""
@@ -60,11 +55,9 @@ post-patch:
.endif
post-install:
-.if ${PORT_OPTIONS:MNLS}
- ${MKDIR} -m 0755 ${EXAMPLESDIR}
+ ${MKDIR} -m 0755 ${STAGEDIR}${EXAMPLESDIR}
@${RM} -f ${EX_WRKSRC}/Makefile.unix ${EX_WRKSRC}/ChangeLog \
${EX_WRKSRC}/CMakeLists.txt
- cd ${EX_WRKSRC} && ${PAX} -rw * ${EXAMPLESDIR}
-.endif
+ cd ${EX_WRKSRC} && ${PAX} -rw * ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.post.mk>