aboutsummaryrefslogtreecommitdiff
path: root/print/qpdf
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-06 14:52:04 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-06 14:52:04 +0000
commit75a96b0afb84165aa7da56fe5f307b647e002de7 (patch)
tree5306ce4835a710fe2b40156affccf8271bab2bbb /print/qpdf
parent76079b1b6468bd5a9e18074c763d590c1bffdf27 (diff)
downloadports-75a96b0afb84165aa7da56fe5f307b647e002de7.tar.gz
ports-75a96b0afb84165aa7da56fe5f307b647e002de7.zip
. fix build with libc++;
. update to version 5.0.1; . support STAGE. PR: ports/183172 Submitted by: bsam (me) Approved by: maintainer (timeout 2 weeks)
Notes
Notes: svn path=/head/; revision=332998
Diffstat (limited to 'print/qpdf')
-rw-r--r--print/qpdf/Makefile5
-rw-r--r--print/qpdf/distinfo4
-rw-r--r--print/qpdf/files/patch-include_QPDFExc.hh10
-rw-r--r--print/qpdf/files/patch-include_QUtil.hh10
-rw-r--r--print/qpdf/files/patch-include_qpdf_QPDF.hh10
-rw-r--r--print/qpdf/pkg-plist3
6 files changed, 36 insertions, 6 deletions
diff --git a/print/qpdf/Makefile b/print/qpdf/Makefile
index 832c6b502c52..54c3e6cdebd1 100644
--- a/print/qpdf/Makefile
+++ b/print/qpdf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qpdf
-PORTVERSION= 5.0.0
+PORTVERSION= 5.0.1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTVERSION}
@@ -19,9 +19,6 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= gmake
-MAN1= fix-qdf.1 qpdf.1 zlib-flate.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
-e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
diff --git a/print/qpdf/distinfo b/print/qpdf/distinfo
index 30f552e79851..9847e9418d64 100644
--- a/print/qpdf/distinfo
+++ b/print/qpdf/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qpdf-5.0.0.tar.gz) = ddeac2272cbabffbaf7320d7e783085ed3690710616e0b855947b25e59a97b37
-SIZE (qpdf-5.0.0.tar.gz) = 7556793
+SHA256 (qpdf-5.0.1.tar.gz) = d0658a0b276ac5b811cc41edb8a4fc70d343a392aba53578df3c188f57b1efbd
+SIZE (qpdf-5.0.1.tar.gz) = 7569985
diff --git a/print/qpdf/files/patch-include_QPDFExc.hh b/print/qpdf/files/patch-include_QPDFExc.hh
new file mode 100644
index 000000000000..4fc6dea5fb06
--- /dev/null
+++ b/print/qpdf/files/patch-include_QPDFExc.hh
@@ -0,0 +1,10 @@
+--- include/qpdf/QPDFExc.hh.orig 2013-10-22 10:56:42.542484811 +0400
++++ include/qpdf/QPDFExc.hh 2013-10-22 10:57:02.738482806 +0400
+@@ -13,6 +13,7 @@
+
+ #include <qpdf/Constants.h>
+ #include <stdexcept>
++#include <string>
+
+ class QPDFExc: public std::runtime_error
+ {
diff --git a/print/qpdf/files/patch-include_QUtil.hh b/print/qpdf/files/patch-include_QUtil.hh
new file mode 100644
index 000000000000..704ad649a06c
--- /dev/null
+++ b/print/qpdf/files/patch-include_QUtil.hh
@@ -0,0 +1,10 @@
+--- include/qpdf/QUtil.hh.orig 2013-10-22 10:53:22.013499403 +0400
++++ include/qpdf/QUtil.hh 2013-10-22 10:53:41.216497407 +0400
+@@ -14,6 +14,7 @@
+ #include <list>
+ #include <stdexcept>
+ #include <stdio.h>
++#include <ctime>
+
+ namespace QUtil
+ {
diff --git a/print/qpdf/files/patch-include_qpdf_QPDF.hh b/print/qpdf/files/patch-include_qpdf_QPDF.hh
new file mode 100644
index 000000000000..bf8040da1519
--- /dev/null
+++ b/print/qpdf/files/patch-include_qpdf_QPDF.hh
@@ -0,0 +1,10 @@
+--- include/qpdf/QPDF.hh.orig 2013-10-22 10:30:42.941592225 +0400
++++ include/qpdf/QPDF.hh 2013-10-22 10:30:54.303595364 +0400
+@@ -16,6 +16,7 @@
+ #include <map>
+ #include <list>
+ #include <iostream>
++#include <ctime>
+
+ #include <qpdf/QPDFObjGen.hh>
+ #include <qpdf/QPDFXRefEntry.hh>
diff --git a/print/qpdf/pkg-plist b/print/qpdf/pkg-plist
index 01844c7c859a..e984198e6a7d 100644
--- a/print/qpdf/pkg-plist
+++ b/print/qpdf/pkg-plist
@@ -32,6 +32,9 @@ lib/libqpdf.la
lib/libqpdf.so
lib/libqpdf.so.13
libdata/pkgconfig/libqpdf.pc
+man/man1/fix-qdf.1.gz
+man/man1/qpdf.1.gz
+man/man1/zlib-flate.1.gz
share/doc/qpdf/qpdf-manual.html
share/doc/qpdf/qpdf-manual.pdf
share/doc/qpdf/stylesheet.css