aboutsummaryrefslogtreecommitdiff
path: root/print/rlpr
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-05-11 01:59:51 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-05-11 01:59:51 +0000
commite4c6d6a9c62ab52713d169e8f7463d7229f1e393 (patch)
tree0665b53d7a7904168a4fcda32bdfb3c53058af41 /print/rlpr
parentfafa6406bcfb95899f946ee8a105a42de44bad8a (diff)
downloadports-e4c6d6a9c62ab52713d169e8f7463d7229f1e393.tar.gz
ports-e4c6d6a9c62ab52713d169e8f7463d7229f1e393.zip
Send print jobs to lpd servers anywhere on a network.
PR: 11072 Submiited by: Mikhail Teterin <mi@aldan.algebra.com>
Notes
Notes: svn path=/head/; revision=18776
Diffstat (limited to 'print/rlpr')
-rw-r--r--print/rlpr/Makefile40
-rw-r--r--print/rlpr/distinfo1
-rw-r--r--print/rlpr/files/patch-aa12
-rw-r--r--print/rlpr/pkg-comment1
-rw-r--r--print/rlpr/pkg-descr18
-rw-r--r--print/rlpr/pkg-plist4
6 files changed, 76 insertions, 0 deletions
diff --git a/print/rlpr/Makefile b/print/rlpr/Makefile
new file mode 100644
index 000000000000..0a857b282c2c
--- /dev/null
+++ b/print/rlpr/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: rlpr
+# Version required: 2.0
+# Date created: 11 April 1999
+# Whom: Mikhail Teterin
+#
+# $Id$
+
+DISTNAME= rlpr-2.00
+CATEGORIES= print net
+MASTER_SITES= ftp://sherilyn.ne.mediaone.net/pub/
+
+MAINTAINER= mi@aldan.algebra.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lintl"
+CONFIGURE_ARGS= --with-catgets
+
+RLPRRC= ${WRKSRC}/src/rlprrc.h
+
+post-patch:
+ @echo "Replacing references to /etc/rlprrc to ${PREFIX}/etc/rlprrc"
+ @test -e ${RLPRRC}.orig || ${MV} ${RLPRRC} ${RLPRRC}.orig && \
+ ${SED} s%/etc/%${PREFIX}/etc/% ${RLPRRC}.orig > ${RLPRRC}
+ @for man in `${GREP} -l /etc/rlprrc ${WRKSRC}/man/*.[0-9n]`; do \
+ if test -e $$man.orig; then continue; fi; \
+ ${MV} $$man $$man.orig ; \
+ ${SED} s%/etc/rlprrc%${PREFIX}/etc/rlprrc%g < $$man.orig > \
+ $$man ; \
+ done
+
+post-install:
+ @echo "Making the installed binaries suid,\
+ for the remote lpds to talk to them"
+ chmod u+s ${PREFIX}/bin/rlpq ${PREFIX}/bin/rlpr ${PREFIX}/bin/rlprm
+
+MAN1= rlpr.1 rlpq.1 rlprm.1
+MAN5= rlprrc.5
+MAN8= rlprd.8
+
+.include <bsd.port.mk>
diff --git a/print/rlpr/distinfo b/print/rlpr/distinfo
new file mode 100644
index 000000000000..3686e8cfcdda
--- /dev/null
+++ b/print/rlpr/distinfo
@@ -0,0 +1 @@
+MD5 (rlpr-2.00.tar.gz) = 09c78b2cbb4e32e841720c6adfb1ed9f
diff --git a/print/rlpr/files/patch-aa b/print/rlpr/files/patch-aa
new file mode 100644
index 000000000000..7f365e962f64
--- /dev/null
+++ b/print/rlpr/files/patch-aa
@@ -0,0 +1,12 @@
+--- src/rlpq.c.orig Sun Dec 13 19:21:22 1998
++++ src/rlpq.c Sat Apr 10 18:39:54 1999
+@@ -19,2 +19,3 @@
+ #include <pwd.h>
++#include <stdio.h>
+ #include <stdlib.h>
+--- src/rlprm.c.orig Sun Dec 13 19:21:30 1998
++++ src/rlprm.c Sat Apr 10 18:41:11 1999
+@@ -19,2 +19,3 @@
+ #include <pwd.h>
++#include <stdio.h>
+ #include <stdlib.h>
diff --git a/print/rlpr/pkg-comment b/print/rlpr/pkg-comment
new file mode 100644
index 000000000000..d273c1f471ef
--- /dev/null
+++ b/print/rlpr/pkg-comment
@@ -0,0 +1 @@
+Send print jobs to lpd servers anywhere on a network.
diff --git a/print/rlpr/pkg-descr b/print/rlpr/pkg-descr
new file mode 100644
index 000000000000..b1a451907f69
--- /dev/null
+++ b/print/rlpr/pkg-descr
@@ -0,0 +1,18 @@
+Send print jobs to lpd servers anywhere on a network. Does not require
+lpd server to be listed in client's /etc/printcap, and is therefore
+useful for printing from machines one does not have root access on.
+
+This version has been completely redesigned and rewritten from the
+ground up. the source code is oh-so-much-better than before. there are
+also a number of user-visible changes:
+
+ . addition of new rlprm command
+ . new hooks for internationalization support
+ . build procedure now uses automake in addition to autoconf
+ . new --timeout option in case remote end dies
+ . new --send-data-first option to improve support for buggy lpd's
+ . now works with hp jetdirect printers
+ . shiny-new rlpr progress meter, useful for printing over slow links
+ . all printing commands default to `lp' printer now, like bsd
+
+Will use the installed gettext (see devel/gettext port) or its own.
diff --git a/print/rlpr/pkg-plist b/print/rlpr/pkg-plist
new file mode 100644
index 000000000000..cc528074d499
--- /dev/null
+++ b/print/rlpr/pkg-plist
@@ -0,0 +1,4 @@
+bin/rlpr
+bin/rlpq
+bin/rlprm
+bin/rlprd