aboutsummaryrefslogtreecommitdiff
path: root/print/tex-basic-engines
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-07-26 06:57:26 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-07-26 06:57:26 +0000
commit520677c14aad26c1f25a6135132732a3d8ae473c (patch)
tree2f0bed45179ba9632d6f4d71623d8fe71c8dd85b /print/tex-basic-engines
parentf58520633bcc1c333b3f58740c53c65617143f33 (diff)
downloadports-520677c14aad26c1f25a6135132732a3d8ae473c.tar.gz
ports-520677c14aad26c1f25a6135132732a3d8ae473c.zip
- Separate libsynctex from tex-web2c to devel/tex-synctex.
- Separate basic TeX engines from tex-web2c to print/tex-basic-engines. - Add CTAN mirrors to MASTER_SITES. - Drop gmake where not required. - Remove extra dependencies in print/tex-aleph, print/tex-dvipdfmx, print/tex-luatex, print/tex-xetex, and japanese/tex-ptex.
Notes
Notes: svn path=/head/; revision=392909
Diffstat (limited to 'print/tex-basic-engines')
-rw-r--r--print/tex-basic-engines/Makefile50
-rw-r--r--print/tex-basic-engines/distinfo2
-rw-r--r--print/tex-basic-engines/files/patch-Makefile.in31
-rw-r--r--print/tex-basic-engines/files/patch-man-Makefile.in24
-rw-r--r--print/tex-basic-engines/pkg-descr3
-rw-r--r--print/tex-basic-engines/pkg-plist13
6 files changed, 123 insertions, 0 deletions
diff --git a/print/tex-basic-engines/Makefile b/print/tex-basic-engines/Makefile
new file mode 100644
index 000000000000..23a62a923582
--- /dev/null
+++ b/print/tex-basic-engines/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= basic-engines
+PORTVERSION= 20150521
+CATEGORIES= print
+MASTER_SITES= TEX_CTAN/systems/texlive/Source/
+PKGNAMEPREFIX= tex-
+DISTNAME= texlive-20150521-source
+DIST_SUBDIR= TeX
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Basic TeX Engines
+
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+
+USES= pkgconfig libtool tar:xz
+USE_TEX= kpathsea web2c>=20150521_1
+EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
+EXTRACT_FILES= build-aux \
+ libs/xpdf \
+ texk/web2c
+WRKSRC= ${WRKDIR}/${DISTNAME}/texk/web2c
+GNU_CONFIGURE= yes
+EXCLUDE_ENGINES=aleph luatex luajittex mf \
+ mf-nowin ptex eptex uptex euptex xetex \
+ otangle mp pmp upmp web2c web-progs synctex
+CONFIGURE_ARGS= ${EXCLUDE_ENGINES:S/^/--disable-/} \
+ --disable-missing \
+ --with-x=no \
+ --without-mf-x-toolkit \
+ --with-system-zlib \
+ --with-system-kpathsea
+.for L in libpng
+CONFIGURE_ARGS+=--with-system-$L \
+ --with-$L-include=${LOCALBASE}/include \
+ --with-$L-libdir=${LOCALBASE}/lib
+.endfor
+CFLAGS+= -I${LOCALBASE}/include
+INSTALL_TARGET= install-strip
+
+post-configure:
+ cd ${WRKDIR}/${DISTNAME}/libs/xpdf && \
+ ${SETENV} CC="${CC}" CPP="${CPP}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" \
+ LIBS="${LIBS}" \
+ ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} \
+ ${CONFIGURE_ARGS}
+
+.include <bsd.port.mk>
diff --git a/print/tex-basic-engines/distinfo b/print/tex-basic-engines/distinfo
new file mode 100644
index 000000000000..5e60be0fc6e1
--- /dev/null
+++ b/print/tex-basic-engines/distinfo
@@ -0,0 +1,2 @@
+SHA256 (TeX/texlive-20150521-source.tar.xz) = ed9bcd7bdce899c3c27c16a8c5c3017c4f09e1d7fd097038351b72497e9d4669
+SIZE (TeX/texlive-20150521-source.tar.xz) = 45459552
diff --git a/print/tex-basic-engines/files/patch-Makefile.in b/print/tex-basic-engines/files/patch-Makefile.in
new file mode 100644
index 000000000000..c57b6c2e1089
--- /dev/null
+++ b/print/tex-basic-engines/files/patch-Makefile.in
@@ -0,0 +1,31 @@
+--- Makefile.in.orig 2015-04-17 04:53:45.000000000 +0900
++++ Makefile.in 2015-07-26 07:48:39.326669000 +0900
+@@ -99,8 +99,8 @@
+ pdftex$(EXEEXT) ttf2afm$(EXEEXT) pdftosrc$(EXEEXT) \
+ luatex$(EXEEXT) luajittex$(EXEEXT) txt2zlib$(EXEEXT) \
+ xetex$(EXEEXT) $(am__EXEEXT_4) aleph$(EXEEXT) synctex$(EXEEXT)
+-bin_PROGRAMS = tangle$(EXEEXT) ctangle$(EXEEXT) $(am__EXEEXT_5) \
+- ctie$(EXEEXT) cweave$(EXEEXT) tie$(EXEEXT) $(am__EXEEXT_6) \
++bin_PROGRAMS = $(am__EXEEXT_5) \
++ $(am__EXEEXT_6) \
+ $(am__EXEEXT_7) $(am__EXEEXT_8) $(am__EXEEXT_9) \
+ $(am__EXEEXT_10) $(am__EXEEXT_11) $(am__EXEEXT_12) \
+ $(am__EXEEXT_13) $(am__EXEEXT_14) $(am__EXEEXT_15) \
+@@ -2081,7 +2081,7 @@
+ AM_CXXFLAGS = ## $(WARNING_CXXFLAGS)
+ AM_OBJCXXFLAGS = ## $(WARNING_OBJCXXFLAGS)
+ version = $(WEB2CVERSION)
+-SUBDIRS = doc lib man web2c . window omegafonts otps
++SUBDIRS = lib man web2c .
+ proglib = lib/lib.a
+ EXTRA_LIBRARIES = libmf.a libmputil.a libmplib.a libkanji.a \
+ libukanji.a libpdftex.a libluasocket.a libluajitsocket.a \
+@@ -2090,7 +2090,7 @@
+ EXTRA_LTLIBRARIES = libsynctex.la
+ lib_LIBRARIES = $(am__append_98)
+ lib_LTLIBRARIES = $(am__append_97)
+-dist_man_MANS = synctexdir/man1/synctex.1 synctexdir/man5/synctex.5
++dist_man_MANS =
+ nodist_man_MANS =
+ EXTRA_DIST = PROJECTS cftests cpascal.h help.h w2c/config.h \
+ triptrap-sh tangle.web tangle.ch tangleboot.pin cwebdir \
diff --git a/print/tex-basic-engines/files/patch-man-Makefile.in b/print/tex-basic-engines/files/patch-man-Makefile.in
new file mode 100644
index 000000000000..a06313ab8816
--- /dev/null
+++ b/print/tex-basic-engines/files/patch-man-Makefile.in
@@ -0,0 +1,24 @@
+--- man/Makefile.in.orig 2015-07-26 05:53:09.990626000 +0900
++++ man/Makefile.in 2015-07-26 05:54:10.576804000 +0900
+@@ -437,17 +437,15 @@
+ $(otangle_man_sources) aleph.man $(misc_man_sources) \
+ amslatex.min initex.min lamstex.min slitex.min spell.add \
+ virtex.min
+-bootstrap_man_sources = ctie.man cweb.man tangle.man tie.man
++bootstrap_man_sources =
+
+ # Symlinks within $(man1dir): FILE:LINK indicates LINK.1->FILE.1
+-man1_links = cweb:ctangle cweb:cweave $(am__append_4) $(am__append_8) \
++man1_links = $(am__append_4) $(am__append_8) \
+ $(am__append_10) $(am__append_13) $(am__append_15)
+-web_man_sources = bibtex.man dvicopy.man dvitomp.man dvitype.man gftodvi.man \
+- gftopk.man gftype.man mft.man patgen.man pktogf.man pktype.man \
+- pltotf.man pooltype.man tftopl.man vftovp.man vptovf.man weave.man
++web_man_sources =
+
+ pdftex_man_sources = pdftex.man pdftosrc.man ttf2afm.man
+-otangle_man_sources = ofm2opl.man opl2ofm.man ovf2ovp.man ovp2ovf.man
++otangle_man_sources =
+ misc_man_sources = \
+ amstex.man \
+ latex.man \
diff --git a/print/tex-basic-engines/pkg-descr b/print/tex-basic-engines/pkg-descr
new file mode 100644
index 000000000000..3ae45b885623
--- /dev/null
+++ b/print/tex-basic-engines/pkg-descr
@@ -0,0 +1,3 @@
+Basic TeX engines including tex and pdftex.
+
+WWW: http://tug.org/texlive/
diff --git a/print/tex-basic-engines/pkg-plist b/print/tex-basic-engines/pkg-plist
new file mode 100644
index 000000000000..8e4c0167f789
--- /dev/null
+++ b/print/tex-basic-engines/pkg-plist
@@ -0,0 +1,13 @@
+bin/initex
+bin/pdftex
+bin/pdftosrc
+bin/tex
+bin/ttf2afm
+man/man1/amstex.1.gz
+man/man1/latex.1.gz
+man/man1/pdfetex.1.gz
+man/man1/pdflatex.1.gz
+man/man1/pdftex.1.gz
+man/man1/pdftosrc.1.gz
+man/man1/tex.1.gz
+man/man1/ttf2afm.1.gz