aboutsummaryrefslogtreecommitdiff
path: root/print/ttfautohint
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-08 16:49:13 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-12-08 16:49:13 +0000
commit2715cc2812c0f189d049e8a0b521462c16cc2245 (patch)
tree2bdaecc81c4828965d3ccb37e2b001ce2d113d98 /print/ttfautohint
parent8cc4259ac5f377784267f90e4278799644195c5e (diff)
downloadports-2715cc2812c0f189d049e8a0b521462c16cc2245.tar.gz
ports-2715cc2812c0f189d049e8a0b521462c16cc2245.zip
Add ttfautohint 1.8.3
ttfautohint provides a 99% automated hinting process and a platform for finely hand-hinting the last 1%. It is ideal for web fonts and supports many scripts: Latin, Greek, Arabic, Devanagari, Hebrew, Khmer, Myanmar, Thai, and many more. WWW: https://www.freetype.org/ttfautohint/
Notes
Notes: svn path=/head/; revision=519317
Diffstat (limited to 'print/ttfautohint')
-rw-r--r--print/ttfautohint/Makefile30
-rw-r--r--print/ttfautohint/distinfo3
-rw-r--r--print/ttfautohint/files/patch-lib-llrb.h11
-rw-r--r--print/ttfautohint/pkg-descr5
-rw-r--r--print/ttfautohint/pkg-plist10
5 files changed, 59 insertions, 0 deletions
diff --git a/print/ttfautohint/Makefile b/print/ttfautohint/Makefile
new file mode 100644
index 000000000000..9cf6ef72baf0
--- /dev/null
+++ b/print/ttfautohint/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ttfautohint
+PORTVERSION= 1.8.3
+CATEGORIES= print
+MASTER_SITES= SAVANNAH/freetype \
+ SF/freetype/ttfautohint/${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Automatic font hinting library
+
+LICENSE= FTL GPLv2+
+LICENSE_COMB= dual
+LICENSE_NAME_FTL= The FreeType Project license
+LICENSE_FILE_FTL= ${WRKSRC}/FTL.TXT
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/GPLv2.TXT
+LICENSE_PERMS_FTL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= freetype2>=2.4.5:print/freetype2 \
+ harfbuzz>=1.3.0:print/harfbuzz
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+
+USES= gmake libtool pkgconfig
+
+CONFIGURE_ARGS= --with-doc=no --with-qt=no
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/print/ttfautohint/distinfo b/print/ttfautohint/distinfo
new file mode 100644
index 000000000000..6e0bae22e257
--- /dev/null
+++ b/print/ttfautohint/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1575793781
+SHA256 (ttfautohint-1.8.3.tar.gz) = 87bb4932571ad57536a7cc20b31fd15bc68cb5429977eb43d903fa61617cf87e
+SIZE (ttfautohint-1.8.3.tar.gz) = 3458637
diff --git a/print/ttfautohint/files/patch-lib-llrb.h b/print/ttfautohint/files/patch-lib-llrb.h
new file mode 100644
index 000000000000..5558de665e1b
--- /dev/null
+++ b/print/ttfautohint/files/patch-lib-llrb.h
@@ -0,0 +1,11 @@
+--- lib/llrb.h.orig 2016-01-07 09:47:40 UTC
++++ lib/llrb.h
+@@ -74,7 +74,7 @@ struct name { struct type *rbh_root; }
+ #define LLRB_RED 1
+
+ #define LLRB_ENTRY(type) \
+-struct { struct type *rbe_left, *rbe_right, *rbe_parent; _Bool rbe_color; }
++struct { struct type *rbe_left, *rbe_right, *rbe_parent; bool rbe_color; }
+
+ #define LLRB_LEFT(elm, field) (elm)->field.rbe_left
+ #define LLRB_RIGHT(elm, field) (elm)->field.rbe_right
diff --git a/print/ttfautohint/pkg-descr b/print/ttfautohint/pkg-descr
new file mode 100644
index 000000000000..7369d35ed459
--- /dev/null
+++ b/print/ttfautohint/pkg-descr
@@ -0,0 +1,5 @@
+ttfautohint provides a 99% automated hinting process and a platform for finely
+hand-hinting the last 1%. It is ideal for web fonts and supports many scripts:
+Latin, Greek, Arabic, Devanagari, Hebrew, Khmer, Myanmar, Thai, and many more.
+
+WWW: https://www.freetype.org/ttfautohint/
diff --git a/print/ttfautohint/pkg-plist b/print/ttfautohint/pkg-plist
new file mode 100644
index 000000000000..a696590afc47
--- /dev/null
+++ b/print/ttfautohint/pkg-plist
@@ -0,0 +1,10 @@
+bin/ttfautohint
+include/ttfautohint-coverages.h
+include/ttfautohint-errors.h
+include/ttfautohint-scripts.h
+include/ttfautohint.h
+lib/libttfautohint.a
+lib/libttfautohint.so
+lib/libttfautohint.so.1
+lib/libttfautohint.so.1.0.2
+libdata/pkgconfig/ttfautohint.pc