aboutsummaryrefslogtreecommitdiff
path: root/print/yatex
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 11:48:57 +0000
commit897d06aa9731645e0a7fa7c315028dcdbfa3c798 (patch)
tree485cefa9621a788f5d27ac4dcab7fc6aa9843be6 /print/yatex
parentc982f5faf1c27ba011ef14e71aadc2182660d704 (diff)
downloadports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.tar.gz
ports-897d06aa9731645e0a7fa7c315028dcdbfa3c798.zip
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command.
Notes
Notes: svn path=/head/; revision=53958
Diffstat (limited to 'print/yatex')
-rw-r--r--print/yatex/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/print/yatex/Makefile b/print/yatex/Makefile
index 40df51b12b9a..8342648ba01c 100644
--- a/print/yatex/Makefile
+++ b/print/yatex/Makefile
@@ -91,7 +91,7 @@ do-build:
-e 's,%%BASENAME%%,${BASENAME},g' \
-e 's,%%CAT%%,${CAT},g' \
-e 's,%%CP%%,${CP},g' \
- -e 's,%%ECHO%%,${ECHO},g' \
+ -e 's,%%ECHO%%,${ECHO_CMD},g' \
-e 's,%%GREP%%,${GREP},g' \
-e 's,%%RM%%,${RM},g' \
-e 's,%%SED%%,${SED},g' \
@@ -127,12 +127,12 @@ do-install:
${MKDIR} ${INFODIR}
.if (${EMACS_PORT_NAME} == xemacs21) || (${EMACS_PORT_NAME} == xemacs21-mule)
cd ${WRKSRC}; \
- for file in `${ECHO} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
+ for file in `${ECHO_CMD} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
${INSTALL_DATA} ${WRKSRC}/docs/$${file} ${INFODIR}/$${file}.info; \
done
.else
cd ${WRKSRC}; \
- for file in `${ECHO} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
+ for file in `${ECHO_CMD} ${INFOFILES} | ${SED} "s,:, ,g"`; do \
${INSTALL_DATA} ${WRKSRC}/docs/$${file} ${INFODIR}; \
done
.endif