aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-05-07 13:59:11 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-05-07 13:59:11 +0000
commit056a1db09ef80fc341b0256772140377d7e73dc0 (patch)
treebe51d5e8b38dc5c21315f265c1bfb21ae1ffac0f /print
parent483bd75e97eb62337c8fb4ddb5568438a32af2c7 (diff)
downloadports-056a1db09ef80fc341b0256772140377d7e73dc0.tar.gz
ports-056a1db09ef80fc341b0256772140377d7e73dc0.zip
- use cups-client as dependency
PR: 133136
Notes
Notes: svn path=/head/; revision=233358
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile49
-rw-r--r--print/cups-base/pkg-plist16
-rw-r--r--print/cups-base/pkg-plist.client7
-rw-r--r--print/cups-client/Makefile1
4 files changed, 32 insertions, 41 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 28bbe133dde9..6602bb76111b 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -8,6 +8,7 @@
PORTNAME= cups
PORTVERSION= 1.3.10
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
@@ -15,10 +16,6 @@ PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Common UNIX Printing System
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
-
CONFLICTS= LPRng-[0-9]*
USE_BZIP2= yes
@@ -65,13 +62,17 @@ CUPSSYSGRP= wheel
.if defined(CUPS_CLIENT)
USE_LDCONFIG= yes
CUPS_SUFFIX= -client
-PKGNAMESUFFIX= -client${PKGNAMESUFFIX2}
-PLIST= plist.client
+PLIST= ${MASTERDIR}/pkg-plist.client
+INSTALL_WRKSRC= ${WRKSRC}/cups
.else
CUPS_SUFFIX= -base
USE_RC_SUBR= cupsd
USE_GHOSTSCRIPT= yes
CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=gs
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ cups.2:${PORTSDIR}/${PKGCATEGORY}/cups-client
.endif
.if defined(CUPS_OVERWRITE_BASE)
@@ -144,9 +145,10 @@ CONFIGURE_ARGS+= --disable-dbus
RUN_DEPENDS+= xdg-open:${PORTSDIR}/devel/xdg-utils
.endif
-.if !defined(CUPS_CLIENT)
+.if defined(CUPS_CLIENT)
+MAN1= cups-config.1
+.else
MAN1= cancel.1 \
- cups-config.1 \
cupstestdsc.1 \
cupstestppd.1 \
lp.1 \
@@ -200,7 +202,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|htmlview|xdg-open|' ${WRKSRC}/desktop/cups.desktop
.endif
@${REINPLACE_CMD} -e '/SILENT/d' ${WRKSRC}/Makedefs.in
- @${REINPLACE_CMD} -e '/share/s|/usr/share|${PREFIX}/share|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/etc/cups|/usr/local/etc/cups|g' ${WRKSRC}/man/*.man*
@${REINPLACE_CMD} -e 's|CXX="$$CC"||g ; s|-lpthreads.*;|${PTHREAD_LIBS};|g' \
-e 's|/private/etc/pam.d|${LOCALBASE}/etc/pam.d|' \
@@ -211,18 +212,23 @@ post-patch:
-e 's|notifier scheduler systemv test ||' \
-e 's|$$.PHPDIR. ||' \
-e 's|conf data doc $$.FONTS.ppd templates||' \
+ -e '/share/s|/usr/share|${PREFIX}/share|g' \
${WRKSRC}/Makefile
+.else
@${REINPLACE_CMD} \
- -e 's| testadmin ||' \
- -e 's| testarray ||' \
- -e 's| testcups ||' \
- -e 's| testfile ||' \
- -e 's| testhttp ||' \
- -e 's| testi18n ||' \
- -e 's| testipp ||' \
- -e 's| testlang ||' \
- -e 's| testppd ||' \
- ${WRKSRC}/cups/Makefile
+ -e 's|cups backend|backend|' \
+ -e '/share/s|/usr/share|${PREFIX}/share|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} \
+ -e 's|cups-config.$$.MAN1EXT. ||' \
+ ${WRKSRC}/man/Makefile
+.endif
+
+.if !defined(CUPS_CLIENT)
+pre-build:
+ ${CP} -p ${LOCALBASE}/lib/libcups.a ${WRKSRC}/cups/
+ ${CP} -p ${LOCALBASE}/lib/libcups.so ${WRKSRC}/cups/
+ ${CP} -p ${LOCALBASE}/lib/libcups.so.2 ${WRKSRC}/cups/
.endif
.if !defined(CUPS_CLIENT)
@@ -256,7 +262,10 @@ post-install:
.endif
.if defined(CUPS_CLIENT)
-do-install:
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cups-config ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/cups/libcups.a ${PREFIX}/lib/
+ ${INSTALL_MAN} ${WRKSRC}/man/cups-config.man ${PREFIX}/man/man1/cups-config.1
.endif
.include <bsd.port.post.mk>
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index 3b343850e42c..2eb8fc1ca2fe 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -35,7 +35,6 @@ etc/cups/snmp.conf.N
@exec chgrp cups %D/etc/cups
%%WITH_PAMD%%etc/pam.d/cups
bin/cancel
-bin/cups-config
bin/cupstestdsc
bin/cupstestppd
bin/lp
@@ -46,22 +45,8 @@ bin/lpr
bin/lprm
bin/lpstat
etc/cups/cupsd.conf.default
-include/cups/adminutil.h
-include/cups/array.h
-include/cups/backend.h
-include/cups/cups.h
-include/cups/dir.h
-include/cups/file.h
-include/cups/http.h
include/cups/image.h
-include/cups/ipp.h
-include/cups/language.h
-include/cups/ppd.h
include/cups/raster.h
-include/cups/sidechannel.h
-include/cups/transcode.h
-lib/libcups.so
-lib/libcups.so.2
lib/libcupsimage.so
lib/libcupsimage.so.2
%%PHP%%lib/php/%%PHP_EXT_DIR%%/phpcups.so
@@ -1235,7 +1220,6 @@ sbin/reject
%%DOCSDIR%%/help/man-cancel.html
%%DOCSDIR%%/help/man-classes.conf.html
%%DOCSDIR%%/help/man-client.conf.html
-%%DOCSDIR%%/help/man-cups-config.html
%%DOCSDIR%%/help/man-cups-lpd.html
%%DOCSDIR%%/help/man-cups-polld.html
%%DOCSDIR%%/help/man-cupsaddsmb.html
diff --git a/print/cups-base/pkg-plist.client b/print/cups-base/pkg-plist.client
index 35eaa594c69f..bbd8bbe6339e 100644
--- a/print/cups-base/pkg-plist.client
+++ b/print/cups-base/pkg-plist.client
@@ -1,3 +1,4 @@
+bin/cups-config
include/cups/adminutil.h
include/cups/array.h
include/cups/backend.h
@@ -5,14 +6,12 @@ include/cups/cups.h
include/cups/dir.h
include/cups/file.h
include/cups/http.h
-include/cups/image.h
include/cups/ipp.h
include/cups/language.h
include/cups/ppd.h
-include/cups/raster.h
include/cups/sidechannel.h
include/cups/transcode.h
+lib/libcups.a
lib/libcups.so
lib/libcups.so.2
-lib/libcupsimage.so
-lib/libcupsimage.so.2
+@dirrm include/cups
diff --git a/print/cups-client/Makefile b/print/cups-client/Makefile
index 11d87d8c5df9..fda97f9df12a 100644
--- a/print/cups-client/Makefile
+++ b/print/cups-client/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= dinoex@FreeBSD.org
MASTERDIR?= ${.CURDIR}/../cups-base
CUPS_CLIENT= yes
-WITHOUT_GNUTLS= yes
OPTIONS= GNUTLS "Build with GNUTLS library" on