aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2023-06-25 07:53:33 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2023-07-11 20:15:43 +0000
commit2c2ec62c72ca36f480a349a7f69ad755a4d226dd (patch)
treeb8c0a9100db032e494cfd74006bbb6a8d55b0dbf /print
parent0b59b9276418ce4fce8a73871a13598397ab2f2e (diff)
downloadports-2c2ec62c72ca36f480a349a7f69ad755a4d226dd.tar.gz
ports-2c2ec62c72ca36f480a349a7f69ad755a4d226dd.zip
devel/gettext: Update to 0.22
Convert post-patch commands to real patches. This way there are errors when the underlying code changes. */*: Fix gettext issues. The new gettext tools are more strict. PR: 272210 Exp-run by: antoine
Diffstat (limited to 'print')
-rw-r--r--print/fontforge/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index bec017a5bb10..e82903ed460e 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fontforge
DISTVERSION= 20220308
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${DISTVERSION}/
@@ -97,14 +97,6 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
X11_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont/unifont.pcf.gz:x11-fonts/gnu-unifont
X11_CMAKE_BOOL= ENABLE_X11
-post-patch-FREETYPE-on:
- @${LN} -s $$(${MAKE} -C ${PORTSDIR}/print/freetype2 -V WRKSRC) \
- ${WRKSRC}/freetype
-
-post-stage-DOCS-on:
- @${RM} ${STAGEDIR}${DOCSDIR}/.buildinfo \
- ${STAGEDIR}${DOCSDIR}/.nojekyll
-
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MX11}
@@ -113,4 +105,21 @@ CMAKE_ARGS+= -DENABLE_GUI:BOOL=true
CMAKE_ARGS+= -DENABLE_GUI:BOOL=false
.endif
+post-patch:
+# https://github.com/fontforge/fontforge/issues/5251
+ @${REINPLACE_CMD} 's/\(%[^%[:space:]]*\)hs/\1s/g' \
+ ${WRKSRC}/fontforgeexe/searchview.c \
+ ${WRKSRC}/po/de.po ${WRKSRC}/po/ca.po ${WRKSRC}/po/hr.po \
+ ${WRKSRC}/po/it.po ${WRKSRC}/po/pl.po ${WRKSRC}/po/uk.po \
+ ${WRKSRC}/po/en_GB.po ${WRKSRC}/po/fr.po ${WRKSRC}/po/vi.po \
+ ${WRKSRC}/po/ko.po ${WRKSRC}/po/ja.po
+
+post-patch-FREETYPE-on:
+ @${LN} -s $$(${MAKE} -C ${PORTSDIR}/print/freetype2 -V WRKSRC) \
+ ${WRKSRC}/freetype
+
+post-stage-DOCS-on:
+ @${RM} ${STAGEDIR}${DOCSDIR}/.buildinfo \
+ ${STAGEDIR}${DOCSDIR}/.nojekyll
+
.include <bsd.port.mk>