aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-22 17:13:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-22 17:13:32 +0000
commit441e4db9410f3c657a46938866d5258a62b119eb (patch)
tree78d3fd9a49c675d4b4ac6fcffb7e80f4818d9b85 /print
parent86e41778111bdae5eb4ceb2a8c67944f7bc0545c (diff)
downloadports-441e4db9410f3c657a46938866d5258a62b119eb.tar.gz
ports-441e4db9410f3c657a46938866d5258a62b119eb.zip
print/ghostscript9-agpl-base: unbreak on 11.0 aarch64 via -O0
fatal error: error in backend: Cannot select: 0x431dcbe0: i32 = AArch64ISD::FCCMP 0x431f3d10, 0x431e1980, Constant:i32<0>, Constant:i32<13>, 0x43415e40 0x431f3d10: f128,ch = CopyFromReg 0x42c42930, Register:f128 %vreg170 0x431e2ab0: f128 = Register %vreg170 0x431e1980: f128,ch = CopyFromReg 0x42c42930, Register:f128 %vreg88 0x431f34c0: f128 = Register %vreg88 0x431dc390: i32 = Constant<0> 0x42df45f0: i32 = Constant<13> 0x43415e40: f128 = AArch64ISD::FCMP 0x431e2e40, 0x431e1980 0x431e2e40: f128,ch = CopyFromReg 0x42c42930, Register:f128 %vreg171 0x431e2980: f128 = Register %vreg171 0x431e1980: f128,ch = CopyFromReg 0x42c42930, Register:f128 %vreg88 0x431f34c0: f128 = Register %vreg88 In function: TrioFormat cc: error: clang frontend command failed with exit code 70 (use -v to see invocation) FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0) Target: aarch64-unknown-freebsd11.0 Reported by: pkg-fallout Approved by: portmgr blanket (unblocking 420 ports)
Notes
Notes: svn path=/head/; revision=432155
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript9-agpl-base/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/print/ghostscript9-agpl-base/Makefile b/print/ghostscript9-agpl-base/Makefile
index 52fecbfe06cb..a49825962ab8 100644
--- a/print/ghostscript9-agpl-base/Makefile
+++ b/print/ghostscript9-agpl-base/Makefile
@@ -35,7 +35,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USES= autoreconf gmake iconv jpeg pkgconfig:build tar:bzip2
+USES= autoreconf compiler gmake iconv jpeg pkgconfig:build tar:bzip2
USE_LDCONFIG= yes
EXTRACT_AFTER_ARGS= ${EXCLUDE_DIRS:S/^/--exclude /}
DATADIR= ${PREFIX}/share/${PORTNAME}/${PORTVERSION}
@@ -103,6 +103,10 @@ PORTDOC_FILES= japanese/Gdevlips.htm japanese/README.gs550j \
post-patch:
${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' \
${WRKSRC}/contrib/japanese/dmp_site.ps
+# XXX CHOSEN_COMPILER_VERSION isn't supported, so check CC hasn't changed
+ @if [ '${ARCH}:${CC}:${COMPILER_TYPE}:${COMPILER_VERSION}' = 'aarch64:cc:clang:38' ]; then \
+ ${REINPLACE_CMD} '/CC.*trio\./s/$$/ -O0/' ${WRKSRC}/base/trio.mak; \
+ fi
pre-build-drivers.mak:
@${ECHO_CMD} '# automatically generated' > ${WRKSRC}/base/drivers.mak