aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2017-03-22 14:07:53 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2017-03-22 14:07:53 +0000
commit4e6d167d30fdcd1a46a1c0296fcd1cd627d58c80 (patch)
tree0ab27586b2ba47fafeb2390966786896b731b7e7 /print
parentda20ef45a4bc9ec892337f899d5eca2498504f6c (diff)
downloadports-4e6d167d30fdcd1a46a1c0296fcd1cd627d58c80.tar.gz
ports-4e6d167d30fdcd1a46a1c0296fcd1cd627d58c80.zip
print/cups-filters: update 1.11.4 -> 1.13.4
* Add LICENSE * Add dependency to mupdf * Update distinfo * Update pkg-plist * Add patches to filter/gstoraster.c and filter/mupdftoraster.c due to execvpe() not existing under FreeBSD PR: 217848 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=436699
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile9
-rw-r--r--print/cups-filters/distinfo6
-rw-r--r--print/cups-filters/files/patch-filter_gstoraster.c11
-rw-r--r--print/cups-filters/files/patch-filter_mupdftoraster.c11
-rw-r--r--print/cups-filters/pkg-plist6
5 files changed, 36 insertions, 7 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 2962861425ef..6fa341cbfff5 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -1,20 +1,23 @@
# $FreeBSD$
PORTNAME= cups-filters
-PORTVERSION= 1.11.4
-PORTREVISION= 1
+PORTVERSION= 1.13.4
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Additional backends, filters and other software for CUPS
+LICENSE= BSD4CLAUSE GPLv2 GPLv2+ GPLv3 GPLv3+ LGPL20 LGPL21+ MIT
+LICENSE_COMB= multi
+
LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libqpdf.so:print/qpdf \
libcupsimage.so:print/cups \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
- libpoppler.so:graphics/poppler
+ libpoppler.so:graphics/poppler \
+ libmupdf.so:graphics/mupdf
CONFLICTS= cups-pstoraster-[0-9]* foomatic-filters-[0-9]*
diff --git a/print/cups-filters/distinfo b/print/cups-filters/distinfo
index 177ff3124a2a..646f554b2b8c 100644
--- a/print/cups-filters/distinfo
+++ b/print/cups-filters/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474565618
-SHA256 (cups-filters-1.11.4.tar.xz) = d6288dc9d13f16c54e74979fd2a3e3fceee882a13a47553967ae69f51d32b849
-SIZE (cups-filters-1.11.4.tar.xz) = 1408760
+TIMESTAMP = 1489586863
+SHA256 (cups-filters-1.13.4.tar.xz) = 94c7d6624f16a8c11683c863e6457c5daa70e60f9a739c355349b45c3abc8dbd
+SIZE (cups-filters-1.13.4.tar.xz) = 1421224
diff --git a/print/cups-filters/files/patch-filter_gstoraster.c b/print/cups-filters/files/patch-filter_gstoraster.c
new file mode 100644
index 000000000000..6bb19a2759e7
--- /dev/null
+++ b/print/cups-filters/files/patch-filter_gstoraster.c
@@ -0,0 +1,11 @@
+--- filter/gstoraster.c.orig 2016-11-23 21:36:11 UTC
++++ filter/gstoraster.c
+@@ -48,6 +48,8 @@ MIT Open Source License - http://www.o
+ #include <signal.h>
+ #include <errno.h>
+
++#define execvpe(a, b, c) execvp(a, b)
++
+ #define PDF_MAX_CHECK_COMMENT_LINES 20
+
+ typedef enum {
diff --git a/print/cups-filters/files/patch-filter_mupdftoraster.c b/print/cups-filters/files/patch-filter_mupdftoraster.c
new file mode 100644
index 000000000000..e5734c7e1827
--- /dev/null
+++ b/print/cups-filters/files/patch-filter_mupdftoraster.c
@@ -0,0 +1,11 @@
+--- filter/mupdftoraster.c.orig 2016-11-23 21:36:11 UTC
++++ filter/mupdftoraster.c
+@@ -50,6 +50,8 @@ MIT Open Source License - http://www.o
+ #include <unistd.h>
+ #include <errno.h>
+
++#define execvpe(a, b, c) execvp(a, b)
++
+ #define PDF_MAX_CHECK_COMMENT_LINES 20
+
+ #define CUPS_IPTEMPFILE "/tmp/ip-XXXXXX"
diff --git a/print/cups-filters/pkg-plist b/print/cups-filters/pkg-plist
index 964538e6e2d3..d0e9b38380a3 100644
--- a/print/cups-filters/pkg-plist
+++ b/print/cups-filters/pkg-plist
@@ -1,3 +1,4 @@
+bin/driverless
bin/foomatic-rip
bin/ttfread
etc/cups/cups-browsed.conf
@@ -6,6 +7,7 @@ include/cupsfilters/colord.h
include/cupsfilters/colormanager.h
include/cupsfilters/driver.h
include/cupsfilters/image.h
+include/cupsfilters/ppdgenerator.h
include/cupsfilters/raster.h
include/fontembed/bitset.h
include/fontembed/embed.h
@@ -23,9 +25,11 @@ lib/libfontembed.so.1.0.0
libdata/pkgconfig/libcupsfilters.pc
libdata/pkgconfig/libfontembed.pc
libexec/cups/backend/beh
+libexec/cups/backend/driverless
libexec/cups/backend/implicitclass
libexec/cups/backend/parallel
libexec/cups/backend/serial
+libexec/cups/driver/driverless
libexec/cups/filter/bannertopdf
%%BRAILLE%%libexec/cups/filter/brftoembosser
libexec/cups/filter/commandtoescpx
@@ -58,7 +62,7 @@ libexec/cups/filter/sys5ippprinter
libexec/cups/filter/texttopdf
libexec/cups/filter/texttops
libexec/cups/filter/texttotext
-libexec/cups/filter/urftopdf
+man/man1/driverless.1.gz
man/man1/foomatic-rip.1.gz
man/man5/cups-browsed.conf.5.gz
man/man8/cups-browsed.8.gz