aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /print
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Mass-conversion to the USE_AUTOTOOLS New World Order. The code present
in bsd.autotools.mk essentially makes this a no-op given that all the old variables set a USE_AUTOTOOLS_COMPAT variable, which is parsed in exactly the same way as USE_AUTOTOOLS itself. Moreover, USE_AUTOTOOLS has already been extensively tested by the GNOME team -- all GNOME 2.12.x ports use it. Preliminary documentation can be found at: http://people.FreeBSD.org/~ade/autotools.txt which is in the process of being SGMLized before introduction into the Porters Handbook. Light blue touch-paper. Run.
Notes
Notes: svn path=/head/; revision=148323
Diffstat (limited to 'print')
-rw-r--r--print/cjk-lyx/Makefile2
-rw-r--r--print/fontforge/Makefile2
-rw-r--r--print/foomatic-db/Makefile3
-rw-r--r--print/freetype-tools/Makefile2
-rw-r--r--print/freetype/Makefile2
-rw-r--r--print/freetype2/Makefile2
-rw-r--r--print/gimp-print/Makefile2
-rw-r--r--print/gnome-cups-manager/Makefile2
-rw-r--r--print/gnome-print/Makefile2
-rw-r--r--print/gnomephotoprinter/Makefile2
-rw-r--r--print/gnomeprint/Makefile2
-rw-r--r--print/gutenprint-base/Makefile2
-rw-r--r--print/gutenprint/Makefile2
-rw-r--r--print/libgnomecups/Makefile2
-rw-r--r--print/libgnomeprintmm/Makefile2
-rw-r--r--print/libijs/Makefile2
-rw-r--r--print/libotf/Makefile2
-rw-r--r--print/libpaper/Makefile2
-rw-r--r--print/libppd/Makefile2
-rw-r--r--print/panda/Makefile2
-rw-r--r--print/pdflib/Makefile2
-rw-r--r--print/pslib/Makefile2
-rw-r--r--print/scribus-devel/Makefile2
-rw-r--r--print/scribus/Makefile2
-rw-r--r--print/teTeX-base/Makefile2
-rw-r--r--print/xfce4-print/Makefile2
26 files changed, 26 insertions, 27 deletions
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
index 9a7ffe6b8680..f75fc4cdd4ce 100644
--- a/print/cjk-lyx/Makefile
+++ b/print/cjk-lyx/Makefile
@@ -32,7 +32,7 @@ USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
CONFIGURE_ARGS= --with-frontend=qt \
--with-extra-lib="${LOCALBASE}/lib" \
--with-extra-inc="${LOCALBASE}/include"
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index 04c6d24a8b75..8f5d019f6736 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -45,7 +45,7 @@ CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CFLAGS="${CFLAGS} \
-I${LOCALBASE}/include/freetype2"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
MAN1= fontforge.1 sfddiff.1
diff --git a/print/foomatic-db/Makefile b/print/foomatic-db/Makefile
index 4b0488a0ee44..55258dc6032d 100644
--- a/print/foomatic-db/Makefile
+++ b/print/foomatic-db/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
USE_GMAKE= yes
USE_PERL5= yes
USE_BZIP2= yes
-WANT_AUTOMAKE_VER= 15
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:15:env autoconf:259
GNU_CONFIGURE= yes
diff --git a/print/freetype-tools/Makefile b/print/freetype-tools/Makefile
index 50320260e01e..2a329de6edb4 100644
--- a/print/freetype-tools/Makefile
+++ b/print/freetype-tools/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libkpathsea.a:${PORTSDIR}/print/teTeX-base
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
USE_REINPLACE= yes
diff --git a/print/freetype/Makefile b/print/freetype/Makefile
index a42a795ae409..8d8a1bfa42a8 100644
--- a/print/freetype/Makefile
+++ b/print/freetype/Makefile
@@ -20,7 +20,7 @@ MASTER_SITE_SUBDIR= freetype1
MAINTAINER= ports@FreeBSD.org
COMMENT= A free and portable TrueType font rendering engine
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
USE_REINPLACE= yes
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index d80ad32a9944..ae14bd82dd5f 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
MAKE_ENV= TOP=""
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gnometarget pkgconfig
USE_REINPLACE= yes
LIBTOOLFILES= builds/unix/configure
diff --git a/print/gimp-print/Makefile b/print/gimp-print/Makefile
index 588768f31c68..89d47e7715f1 100644
--- a/print/gimp-print/Makefile
+++ b/print/gimp-print/Makefile
@@ -18,7 +18,7 @@ USE_GETTEXT= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gimp=no
INSTALLS_SHLIB= yes
diff --git a/print/gnome-cups-manager/Makefile b/print/gnome-cups-manager/Makefile
index 0820f7561e21..bcd483551815 100644
--- a/print/gnome-cups-manager/Makefile
+++ b/print/gnome-cups-manager/Makefile
@@ -26,7 +26,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui libgnomeui \
desktopfileutils
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/print/gnome-print/Makefile b/print/gnome-print/Makefile
index 1102e84ed125..5941c12152b9 100644
--- a/print/gnome-print/Makefile
+++ b/print/gnome-print/Makefile
@@ -30,7 +30,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/print/gnomephotoprinter/Makefile b/print/gnomephotoprinter/Makefile
index c35cf229a95e..d23948f6be6a 100644
--- a/print/gnomephotoprinter/Makefile
+++ b/print/gnomephotoprinter/Makefile
@@ -19,7 +19,7 @@ COMMENT= Gnome Photo Printer is intended for printing photos in an easy way
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui libglade2 libgnomeprintui gnomevfs2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
post-install:
${INSTALL_DATA} ${FILESDIR}/gnomephotoprinter.desktop ${PREFIX}/share/gnome/applications
diff --git a/print/gnomeprint/Makefile b/print/gnomeprint/Makefile
index 1102e84ed125..5941c12152b9 100644
--- a/print/gnomeprint/Makefile
+++ b/print/gnomeprint/Makefile
@@ -30,7 +30,7 @@ USE_GMAKE= yes
USE_PERL5= yes
USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 588768f31c68..89d47e7715f1 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -18,7 +18,7 @@ USE_GETTEXT= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gimp=no
INSTALLS_SHLIB= yes
diff --git a/print/gutenprint/Makefile b/print/gutenprint/Makefile
index 588768f31c68..89d47e7715f1 100644
--- a/print/gutenprint/Makefile
+++ b/print/gutenprint/Makefile
@@ -18,7 +18,7 @@ USE_GETTEXT= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-gimp=no
INSTALLS_SHLIB= yes
diff --git a/print/libgnomecups/Makefile b/print/libgnomecups/Makefile
index 46466f1b6a14..bbc2351ff4f3 100644
--- a/print/libgnomecups/Makefile
+++ b/print/libgnomecups/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack glib20
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index 5c7835869167..c9bb312a4938 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
USE_GCC= 3.4
USE_GNOME= gnomeprefix gnomehack libgnomeprint
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15:inc
CONFIGURE_ARGS= --enable-static
PLIST_SUB= VERSION="2.5" API_VERSION="2.6"
diff --git a/print/libijs/Makefile b/print/libijs/Makefile
index 70ef6be2da89..4ecc5742ffb7 100644
--- a/print/libijs/Makefile
+++ b/print/libijs/Makefile
@@ -18,7 +18,7 @@ COMMENT= C library that supports plugin printer driver for Ghostscript
USE_BZIP2= yes
USE_GNOME= gnometarget lthack pkgconfig
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
MAN1= ijs-config.1
diff --git a/print/libotf/Makefile b/print/libotf/Makefile
index d1368e5094cd..7fc70363b670 100644
--- a/print/libotf/Makefile
+++ b/print/libotf/Makefile
@@ -16,7 +16,7 @@ COMMENT= Library for handling OpenType fonts
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_XLIB= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/print/libpaper/Makefile b/print/libpaper/Makefile
index 6a2f69e88536..d8370805690a 100644
--- a/print/libpaper/Makefile
+++ b/print/libpaper/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.3/-3/}
MAINTAINER= lofi@freebsd.org
COMMENT= A library providing routines for paper size management
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15:inc
INSTALLS_SHLIB= Yes
USE_GETOPT_LONG=Yes
CONFIGURE_ARGS= --build=${CONFIGURE_TARGET}
diff --git a/print/libppd/Makefile b/print/libppd/Makefile
index d378177edb3c..dab1a3ec5490 100644
--- a/print/libppd/Makefile
+++ b/print/libppd/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= lpr
MAINTAINER= e-masson@kisoft-services.com
COMMENT= A library providing routines for ppd files
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= Yes
USE_GETOPT_LONG=Yes
USE_GNOME= glib12
diff --git a/print/panda/Makefile b/print/panda/Makefile
index 850fea7b6d3d..ebec9816504e 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41 \
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-berkeley-db
INSTALLS_SHLIB= yes
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 33052857bfdf..e08e8d81ebe8 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -17,7 +17,7 @@ COMMENT= A C library for dynamically generating PDF
RESTRICTED= "many odd restrictions on usage and distribution"
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/print/pslib/Makefile b/print/pslib/Makefile
index 2fab0ce2dc46..e902f430bb86 100644
--- a/print/pslib/Makefile
+++ b/print/pslib/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_GNOME= gnomehack gnometarget intlhack pkgconfig
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
ac_cv_prog_DOC_TO_MAN=""
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 5258c1f204ae..0fa3b9779611 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -29,7 +29,7 @@ USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
MAN1= scribus.1
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 5258c1f204ae..0fa3b9779611 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -29,7 +29,7 @@ USE_GHOSTSCRIPT_RUN= yes
USE_PYTHON= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
MAN1= scribus.1
diff --git a/print/teTeX-base/Makefile b/print/teTeX-base/Makefile
index cc3eee964b7b..914402bf33b4 100644
--- a/print/teTeX-base/Makefile
+++ b/print/teTeX-base/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
gd.4:${PORTSDIR}/graphics/gd
WRKSRC= ${WRKDIR}/tetex-src-${PORTVERSION}
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-multiplatform \
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index dfb6b362cafe..6acb2bd13e9c 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -28,7 +28,7 @@ RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
USE_GETTEXT= yes
USE_GNOME= gtk20
USE_X_PREFIX= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}