aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-04-28 13:40:01 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-04-28 13:40:01 +0000
commit6b7642b8e31b0de05789a838a770dd9277b1b8d9 (patch)
treef260ca1551f04d49b7bb63e886e1a22597a85245 /print
parent30a8b890b1d7cd59355ad518f3b571734e573e58 (diff)
downloadports-6b7642b8e31b0de05789a838a770dd9277b1b8d9.tar.gz
ports-6b7642b8e31b0de05789a838a770dd9277b1b8d9.zip
- Add LICENSE.
- Convert script/configure and Makefile.inc to OPTIONS_DEFINE. - Add DOCS option and use PORTDOCS. - Trim lengthy pkg-descr.
Notes
Notes: svn path=/head/; revision=316720
Diffstat (limited to 'print')
-rw-r--r--print/apsfilter/Makefile205
-rw-r--r--print/apsfilter/files/patch-Makefile.in51
-rw-r--r--print/apsfilter/pkg-descr30
-rw-r--r--print/apsfilter/pkg-plist11
-rw-r--r--print/apsfilter/scripts/configure149
5 files changed, 160 insertions, 286 deletions
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 87661908dd53..5475acf25b09 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -3,138 +3,133 @@
PORTNAME= apsfilter
PORTVERSION= 7.2.8
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= print
MASTER_SITES= http://www.apsfilter.org/download/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Magic print filter with print preview, duplex printing, and more
-
DIST_SUBDIR= apsfilter
-USE_SUBMAKE= yes
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Magic print filter with print preview, duplex printing, and more
-SUB_FILES+= pkg-message
+LICENSE= PCL
+LICENSE_NAME= Postcard License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-SAMBA_PORT?= net/samba36
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ hpijs:${PORTSDIR}/print/hpijs
-# special arrangement for package building, build stuff without X11
-# to make memory footprint of apsfilter package smaller
-.if defined(BATCH) && defined(PACKAGE_BUILDING)
-NO_X= yes
+USE_BZIP2= yes
+USE_SUBMAKE= yes
+WRKSRC= ${WRKDIR}/apsfilter
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE=DOCS X11 GS PSUTILS ASCII CONVERT DVIPS FIG2DEV HTML2PS \
+ ATALK SAMBA COMPRESS MP3 OGG WAV
+OPTIONS_DEFAULT=X11 GS PSUTILS ASCII CONVERT A4
+OPTIONS_SINGLE=PAPERSIZE
+OPTIONS_SINGLE_PAPERSIZE=A4 LETTER LETTERDJ
+NO_OPTIONS_SORT=yes
+PAPERSIZE_DESC= papersize
+A4_DESC= A4 papersize
+LETTER_DESC= letter papersize
+LETTERDJ_DESC= letter + special Deskjet adjectments
+GS_DESC= Postscript for non-PS printer
+PSUTILS_DESC= for pseudo duplex printing + paper handling
+ASCII_DESC= ASCII files in different styles/orientation
+CONVERT_DESC= support for lots of graphic file formats
+DVIPS_DESC= TeX DVI files
+FIG2DEV_DESC= XFIG drawings
+HTML2PS_DESC= HTML documents
+ATALK_DESC= remote printing on AppleTalk remote printer
+SAMBA_DESC= remote printing on Windows remote printer
+COMPRESS_DESC= print compressed documents
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+MAKE_ARGS= -DDOCS
+PORTDOCS= ANNOUNCE FAQ HOWTO-BUGREPORTS apsfilter4.png \
+ README.BSD handbook.html README.TeX paper
.endif
-.if defined(WITHOUT_X11)
+.if empty(PORT_OPTIONS:MX11)
# XXX Hack. If you've done something like "-DWITHOUT_X11" on the command line
# (instead of WITHOUT_X11=true, or similar) gmake won't pick it up. So make
# sure that NO_X is defined *and* has a value.
MAKE_ENV+= NO_X=true
+.if empty(GHOSTSCRIPT_PORT:M*-nox11)
+GSUFX= -nox11
+.endif
.endif
-USE_GHOSTSCRIPT_RUN= yes
-
-#
# hint: for batch mode you can now draw the following decisions
# - <default> build and install most important filter utilities
# that don't require X
# - APSFILTER_ALL build and install all supported filter utilities
-# - WITHOUT_X11 toggles not to build tools that need X11, even if
-# APSFILTER_ALL is set
-# - PAPERSIZE Use PAPERSIZE as in a2ps port, default to letter.
-PAPERSIZE?= letter
-
-.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
-.BEGIN:
- @${ECHO_CMD}
- @${ECHO_CMD} "PAPERSIZE incorrect value: ${PAPERSIZE}."
- @${ECHO_CMD}
- @${ECHO_CMD} "Must specify PAPERSIZE as one of a4, letter, or letterdj."
- @${ECHO_CMD} "letterdj allows a slightly larger margins for DeskJets."
- @${FALSE}
+
+.if !empty(PORT_OPTIONS:MA4)
+PSUFX= -a4
+.elif !empty(PORT_OTPIONS:MLETTER)
+PSUFX= -letter
+.elif !empty(PORT_OTPIONS:MLETTERDJ)
+PSUFX= -letterdj
.endif
-.if defined(BATCH) && defined(APSFILTER_ALL)
-#
-# Build and install all filter apsfilter knows about (rather expensive)
-#
-# all needed decompression utilities
-RUN_DEPENDS+= melt:${PORTSDIR}/archivers/freeze
-RUN_DEPENDS+= lzop:${PORTSDIR}/archivers/lzop
-# all needed "ASCII to ps" filter utilities
-RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps
-RUN_DEPENDS+= enscript:${PORTSDIR}/print/enscript-${PAPERSIZE}
-RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
-RUN_DEPENDS+= recode:${PORTSDIR}/converters/recode
-# all needed "ARCHIVE" extraction utilities
-RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
-RUN_DEPENDS+= cabextract:${PORTSDIR}/archivers/cabextract
-RUN_DEPENDS+= lha:${PORTSDIR}/archivers/lha
-RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
-RUN_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm
-RUN_DEPENDS+= unarj:${PORTSDIR}/archivers/unarj
-RUN_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
-RUN_DEPENDS+= zoo:${PORTSDIR}/archivers/zoo
-# all needed "xxx to ps" filter utilities
-RUN_DEPENDS+= fitstopnm:${PORTSDIR}/graphics/netpbm
-RUN_DEPENDS+= htmldoc:${PORTSDIR}/textproc/htmldoc
-RUN_DEPENDS+= psnup:${PORTSDIR}/print/psutils
-.if !defined(WITHOUT_X11)
-# "xxx to ps" filter utilities that require X
-RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
-RUN_DEPENDS+= dvips:${PORTSDIR}/print/dvipsk-tetex
-RUN_DEPENDS+= wmf2eps:${PORTSDIR}/graphics/libwmf
-RUN_DEPENDS+= sk2ps:${PORTSDIR}/graphics/skencil
-RUN_DEPENDS+= tgif:${PORTSDIR}/graphics/tgif
-RUN_DEPENDS+= transfig:${PORTSDIR}/print/transfig
-# filter utilities for playing audio files via line printer scheduler
-RUN_DEPENDS+= mpg321:${PORTSDIR}/audio/mpg321
-RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
-RUN_DEPENDS+= wavplay:${PORTSDIR}/audio/wavplay
-.else
-# "xxx to ps" filter utilities that don't require X
-# XXX needs more work
+_DEPENDS_GS= gs:${PORTSDIR}/${GHOSTSCRIPT_PORT}${GSUFX}
+_DEPENDS_ASCII= a2ps:${PORTSDIR}/print/a2ps \
+ enscript:${PORTSDIR}/print/enscript${PSUFX} \
+ mpage:${PORTSDIR}/print/mpage \
+ recode:${PORTSDIR}/converters/recode
+_DEPENDS_COMPRESS= \
+ melt:${PORTSDIR}/archivers/freeze \
+ lzop:${PORTSDIR}/archivers/lzop \
+ arc:${PORTSDIR}/archivers/arc \
+ cabextract:${PORTSDIR}/archivers/cabextract \
+ lha:${PORTSDIR}/archivers/lha \
+ rar:${PORTSDIR}/archivers/rar \
+ rpm:${PORTSDIR}/archivers/rpm \
+ unarj:${PORTSDIR}/archivers/unarj \
+ unzip:${PORTSDIR}/archivers/unzip \
+ zoo:${PORTSDIR}/archivers/zoo
+_DEPENDS_PSUTILS= \
+ psnup:${PORTSDIR}/print/psutils \
+ fitstopnm:${PORTSDIR}/graphics/netpbm \
+ htmldoc:${PORTSDIR}/textproc/htmldoc
+_DEPENDS_CONVERT= \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ wmf2eps:${PORTSDIR}/graphics/libwmf \
+ sk2ps:${PORTSDIR}/graphics/skencil \
+ tgif:${PORTSDIR}/graphics/tgif \
+ transfig:${PORTSDIR}/print/transfig
+_DEPENDS_DVIPS= dvips:${PORTSDIR}/print/dvipsk-tetex
+_DEPENDS_FIG2DEV= \
+ fig2dev:${PORTSDIR}/print/transfig
+_DEPENDS_HTML2PS= \
+ html2ps:${PORTSDIR}/print/html2ps${PSUFX}
+_DEPENDS_ATALK= pap:${PORTSDIR}/net/netatalk
+_DEPENDS_SAMBA= smbclient:${PORTSDIR}/net/samba36
+_DEPENDS_MP3= mpg321:${PORTSDIR}/audio/mpg321
+_DEPENDS_OGG= ogg123:${PORTSDIR}/audio/vorbis-tools
+_DEPENDS_WAV= wavplay:${PORTSDIR}/audio/wavplay
+
+.for D in ${OPTIONS_DEFINE:NCONVERT}
+.if (!empty(PORT_OPTIONS:M$D) || \
+ (defined(BATCH) && defined(APSFILTER_ALL))) && \
+ defined(_DEPENDS_$D)
+RUN_DEPENDS+= ${_DEPENDS_$D}
.endif
-# all possible remote printing support
-RUN_DEPENDS+= pap:${PORTSDIR}/net/netatalk
-RUN_DEPENDS+= smbclient:${PORTSDIR}/${SAMBA_PORT}
-.elif defined(BATCH)
-#
-# in normal batch/portbuilding mode (without building all)
-# don't build too many dependencies
-# since apsfilter should fit easily on installation CD 1...
-#
-# most important "xxx to ps" filter utilities
-RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps
-RUN_DEPENDS+= psnup:${PORTSDIR}/print/psutils
+.endfor
+.if !empty(PORT_OPTIONS:MCONVERT) && !empty(PORT_OPTIONS:MX11) || \
+ (defined(BATCH) && defined(APSFILTER_ALL))
+RUN_DEPENDS+= ${_DEPENDS_CONVERT}
.endif
-# needed for aps2file
-RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-
-# HP IJS driver is not automatically part of ghostscript port anymore
-RUN_DEPENDS+= hpijs:${PORTSDIR}/print/hpijs
-
MAN1= apsfilter.1 aps2file.1 apsfilter-bug.1 apspreview.1
MAN5= apsfilterrc.5
-HAS_CONFIGURE= yes
-USE_BZIP2= yes
-WRKSRC= ${WRKDIR}/apsfilter
-SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" GHOSTSCRIPT_PORT="${GHOSTSCRIPT_PORT}"
-CONFIGURE_ARGS= --prefix=${PREFIX}
-
-.if !defined(BATCH)
-pre-configure:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-post-clean:
- @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
-
-.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
-.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
-.endif
-.endif
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/print/apsfilter/files/patch-Makefile.in b/print/apsfilter/files/patch-Makefile.in
new file mode 100644
index 000000000000..5badd5e0d94b
--- /dev/null
+++ b/print/apsfilter/files/patch-Makefile.in
@@ -0,0 +1,51 @@
+--- Makefile.in.orig 2006-07-10 00:54:22.000000000 +0900
++++ Makefile.in 2013-04-28 22:20:56.000000000 +0900
+@@ -28,11 +28,14 @@
+
+ install: update
+
++.if defined(DOCS)
++update: update-docs
++.else
+ update:
++.endif
+ ${MKDIR} ${bindir}
+ ${MKDIR} ${mandir}/man1
+ ${MKDIR} ${mandir}/man5
+- ${MKDIR} ${APSDOC}
+ ${MKDIR} ${APSCONF}
+ ${MKDIR} ${APSSHARE}
+ ${MKDIR} ${APSSHARE}/bin
+@@ -66,22 +69,24 @@
+ ${INSTALL_DATA} setup/printer-stp ${APSSHARE}/setup
+ ${INSTALL_DATA} template/README ${APSSHARE}/template
+ ${INSTALL_DATA} template/apsfilterrc ${APSSHARE}/template
++ ${INSTALL_DATA} man/apsfilter.1 ${mandir}/man1/apsfilter.1
++ ${INSTALL_DATA} man/aps2file.1 ${mandir}/man1/aps2file.1
++ ${INSTALL_DATA} man/apspreview.1 ${mandir}/man1/apspreview.1
++ ${INSTALL_DATA} man/apsfilter-bug.1 ${mandir}/man1/apsfilter-bug.1
++ ${INSTALL_DATA} man/apsfilterrc.5 ${mandir}/man5/apsfilterrc.5
++ tar cf - driver | ( cd ${APSSHARE} && tar xf -)
++ ${LN} ${APSSHARE} ${APSCONF}/basedir
++
++update-docs:
++ ${MKDIR} ${APSDOC}
+ ${INSTALL_DATA} ANNOUNCE ${APSDOC}
+ ${INSTALL_DATA} FAQ ${APSDOC}
+ ${INSTALL_DATA} HOWTO-BUGREPORTS ${APSDOC}
+- ${INSTALL_DATA} LICENSE ${APSDOC}
+ ${INSTALL_DATA} doc/README.BSD ${APSDOC}
+ ${INSTALL_DATA} doc/README.TeX ${APSDOC}
+ ${INSTALL_DATA} doc/handbook.html ${APSDOC}
+ ${INSTALL_DATA} doc/apsfilter4.png ${APSDOC}
+ ${INSTALL_DATA} doc/paper ${APSDOC}
+- ${INSTALL_DATA} man/apsfilter.1 ${mandir}/man1/apsfilter.1
+- ${INSTALL_DATA} man/aps2file.1 ${mandir}/man1/aps2file.1
+- ${INSTALL_DATA} man/apspreview.1 ${mandir}/man1/apspreview.1
+- ${INSTALL_DATA} man/apsfilter-bug.1 ${mandir}/man1/apsfilter-bug.1
+- ${INSTALL_DATA} man/apsfilterrc.5 ${mandir}/man5/apsfilterrc.5
+- tar cf - driver | ( cd ${APSSHARE} && tar xf -)
+- ${LN} ${APSSHARE} ${APSCONF}/basedir
+
+ clean:
+ (cd doc; make clean)
diff --git a/print/apsfilter/pkg-descr b/print/apsfilter/pkg-descr
index 61a2133313af..3e11da1938c2 100644
--- a/print/apsfilter/pkg-descr
+++ b/print/apsfilter/pkg-descr
@@ -1,24 +1,10 @@
-Apsfilter is a magic printfilter, that allows you to print different document
-types "automagically" without having to convert them manually into something
-which is understood by your lineprinter. Apsfilter development started in 1993,
-so apsfilter is now a mature and powerful printing solution for any flavour of
-Unix running lpd or LPRng as line printer scheduler. It supports the latest
-ghostscript version and 3rd party printer driver like hpijs, ijs, hpdj, pcl3
-and gimp-print, to mention some.
-Apsfilter autodetects lots of file(34), archive(11) and compression(6) types.
-Its even possible to print compressed documents. Apsfilter supports printing
-on local and on Appletalk-, Novell (NEW !), Unix- and Windows remote printers.
-General and "per printer-queue" based config files allow you to configure
-the printer for your needs. Additionally lpr commandline options, -C for
-lpd and -Z for LPRng, allow you to change printing parameters like print
-quality, orientation, duplex mode, etc. "on the fly" without having to
-reconfigure any config file.
-A SETUP script helps you to test various supported ghostscript drivers prior
-installation. SETUP finally makes the necessary entries in /etc/printcap,
-creates spool directories and apsfilter default config files as needed.
-A handbook in HTML is available. Support ONLY via mailinglists, see homepage !
-New tools: "aps2file" allows you to print to a file via apsfilter,
-"apspreview" previews files as generated by apsfilter using gv and friends,
-"apsfilter-bug" assists you in doing bug- and problem reports.
+Apsfilter is a magic printfilter, that allows you to print different
+document types "automagically" without having to convert them manually
+into something which is understood by your lineprinter. Apsfilter
+development started in 1993, so apsfilter is now a mature and powerful
+printing solution for any flavour of Unix running lpd or LPRng as line
+printer scheduler. It supports the latest ghostscript version and 3rd
+party printer driver like hpijs, ijs, hpdj, pcl3 and gimp-print, to
+mention some.
WWW: http://www.apsfilter.org/
diff --git a/print/apsfilter/pkg-plist b/print/apsfilter/pkg-plist
index f82db62cb7fb..ab5699bdd707 100644
--- a/print/apsfilter/pkg-plist
+++ b/print/apsfilter/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
bin/aps2file
bin/apsfilter-bug
bin/apspreview
@@ -310,15 +311,6 @@ etc/apsfilter/basedir
%%DATADIR%%/setup/test.ps
%%DATADIR%%/template/README
%%DATADIR%%/template/apsfilterrc
-%%DOCSDIR%%/ANNOUNCE
-%%DOCSDIR%%/FAQ
-%%DOCSDIR%%/HOWTO-BUGREPORTS
-%%DOCSDIR%%/LICENSE
-%%DOCSDIR%%/README.BSD
-%%DOCSDIR%%/README.TeX
-%%DOCSDIR%%/apsfilter4.png
-%%DOCSDIR%%/handbook.html
-%%DOCSDIR%%/paper
@dirrm etc/apsfilter
@dirrm %%DATADIR%%/bin
@dirrm %%DATADIR%%/driver/gimp
@@ -334,4 +326,3 @@ etc/apsfilter/basedir
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/template
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
diff --git a/print/apsfilter/scripts/configure b/print/apsfilter/scripts/configure
deleted file mode 100644
index 1766fae00c00..000000000000
--- a/print/apsfilter/scripts/configure
+++ /dev/null
@@ -1,149 +0,0 @@
-#! /bin/sh
-
-# $FreeBSD$
-
-if [ "$BATCH" != "yes" ]; then
-
-#
-# configure - apsfilter package dependency configuration
-#
-
-/usr/bin/dialog --title "supported file types" --clear \
- --checklist "\n\
-Select file types you want to print:" -1 -1 14 \
-A4 "A4 papersize" ON \
-LETTER "letter papersize" OFF \
-LETTERDJ "letter + special DeskJet adjustements" OFF \
-GS "Postscript for non-PS printer, needs X11" ON \
-GS_NO_X11 "Postscript for non-PS printer, no X11" OFF \
-GS_PDF_CRYPT "print encrypted PDF files using gs" ON \
-PSUTILS "for pseudo duplex printing + paper handling" ON \
-A2PS "ASCII files in different styles/orientation" ON \
-CONVERT "support for lots of graphic file formats" ON \
-DVIPS "TeX DVI files" OFF \
-FIG2DEV "XFIG drawings" OFF \
-HTML2PS "HTML documents" OFF \
-TROFF "Troff documents" OFF \
-ATALK "remote printing on AppleTalk remote printer" OFF \
-SAMBA "remote printing on Windows remote printer" OFF \
-BZIP2 "print bunzip2 compressed documents" OFF \
-FREEZE "print freeze compressed documents" OFF \
-MP3 "play MP3 audio files on local or remote queue" OFF \
-OGG "play Ogg audio files on local or remote queue" OFF \
-WAV "play wav audio files on local or remote queue" OFF \
-2> /tmp/apsfilter-checklist.$$
-
-retval=$?
-
-if [ -s /tmp/apsfilter-checklist.$$ ]; then
- set `cat /tmp/apsfilter-checklist.$$`
-fi
-rm -f /tmp/apsfilter-checklist.$$
-
-case $retval in
- 0) if [ -z "$*" ]; then
- echo "Nothing selected"
- fi
- ;;
- 1) echo "Cancel pressed."
- exit 1
- ;;
-esac
-
-/bin/mkdir -p ${WRKDIRPREFIX}${CURDIR}
-exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
-
-while [ "$1" ]; do
- case $1 in
- \"A4\")
- PAPERSIZE=a4
- echo "PAPERSIZE=a4"
- ;;
- \"LETTER\")
- PAPERSIZE=letter
- echo "PAPERSIZE=letter"
- ;;
- \"LETTERDJ\")
- PAPERSIZE=letterdj
- echo "PAPERSIZE=letterdj"
- ;;
- \"GS\")
- echo RUN_DEPENDS+=gs:${PORTSDIR}/${GHOSTSCRIPT_PORT}
- ;;
- \"GS_NO_X11\")
- echo WITHOUT_X11=yes
- case ${GHOSTSCRIPT_PORT} in
- *-nox11)
- _GSSUF=""
- ;;
- *)
- _GSSUF=-nox11
- ;;
- esac
- echo RUN_DEPENDS+=gs:${PORTSDIR}/${GHOSTSCRIPT_PORT}${_GSSUF}
- ;;
- \"GS_PDF_CRYPT\")
- echo PDFENCRYPT=YES
- ;;
- \"PSUTILS\")
- echo RUN_DEPENDS+=psnup:${PORTSDIR}/print/psutils
- ;;
- \"A2PS\")
- echo RUN_DEPENDS+=a2ps:${PORTSDIR}/print/a2ps
- ;;
- \"CONVERT\")
- echo RUN_DEPENDS+=convert:${PORTSDIR}/graphics/ImageMagick
- ;;
- \"DVIPS\")
- echo RUN_DEPENDS+=dvips:${PORTSDIR}/print/dvipsk-tetex
- ;;
- \"FIG2DEV\")
- echo RUN_DEPENDS+=fig2dev:${PORTSDIR}/print/transfig
- ;;
- \"HTML2PS\")
- case $PAPERSIZE in
- letter)
- echo RUN_DEPENDS+=html2ps:${PORTSDIR}/print/html2ps-letter
- ;;
- letterdj)
- echo RUN_DEPENDS+=html2ps:${PORTSDIR}/print/html2ps-letter
- ;;
- a4)
- echo RUN_DEPENDS+=html2ps:${PORTSDIR}/print/html2ps-a4
- ;;
- esac
- ;;
- \"TROFF\")
- TROFF=YES
- ;;
- \"ATALK\")
- echo RUN_DEPENDS+=pap:${PORTSDIR}/net/netatalk
- ;;
- \"SAMBA\")
- echo RUN_DEPENDS+=smbclient:${PORTSDIR}/net/samba3
- ;;
- \"BZIP2\")
- ;;
- \"FREEZE\")
- echo RUN_DEPENDS+=melt:${PORTSDIR}/archivers/freeze
- ;;
- \"MP3\")
- echo RUN_DEPENDS+=mpg321:${PORTSDIR}/audio/mpg321
- ;;
- \"OGG\")
- echo RUN_DEPENDS+=ogg123:${PORTSDIR}/audio/vorbis-tools
- ;;
- \"WAV\")
- echo RUN_DEPENDS+=wavplay:${PORTSDIR}/audio/wavplay
- ;;
- esac
- shift
-done
-
-fi # if $BATCH
-
-# if batch, then start creating Makefile.inc here
-if [ "$BATCH" = "yes" ]; then
- /bin/mkdir -p ${WRKDIRPREFIX}${CURDIR}
- exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
-fi