aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-29 01:56:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-29 01:56:20 +0000
commit73acb220c44cb9a6057da1b2d971705ff0264f12 (patch)
treef6aa45d5c4cdcf422c0b1c805dd1b3da596ad762 /print
parent7402330bc4e07472d6d03f74d81b242a3ad20fa8 (diff)
downloadports-73acb220c44cb9a6057da1b2d971705ff0264f12.tar.gz
ports-73acb220c44cb9a6057da1b2d971705ff0264f12.zip
Add py-pycups1 1.9.74 (copied from py-pycups)
- Add PORTSCOUT
Notes
Notes: svn path=/head/; revision=536830
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-pycups1/Makefile40
-rw-r--r--print/py-pycups1/distinfo3
-rw-r--r--print/py-pycups1/pkg-descr4
4 files changed, 48 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index c502e94a7e62..39dda97cd6a9 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -184,6 +184,7 @@
SUBDIR += py-preppy
SUBDIR += py-psautohint
SUBDIR += py-pycups
+ SUBDIR += py-pycups1
SUBDIR += py-pyscript
SUBDIR += py-python-ly
SUBDIR += py-qt5-printsupport
diff --git a/print/py-pycups1/Makefile b/print/py-pycups1/Makefile
new file mode 100644
index 000000000000..02b4058962fc
--- /dev/null
+++ b/print/py-pycups1/Makefile
@@ -0,0 +1,40 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pycups
+PORTVERSION= 1.9.74
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 1
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CUPS bindings for Python
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libcups.so:print/cups
+
+USES= iconv localbase python tar:bzip2
+USE_PYTHON= autoplist concurrent distutils
+
+# pycups 2.0.0+ requires Python 3.6+
+PORTSCOUT= limit:^1\.
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(VERSION=\).*$$|\1${PORTVERSION}|' ${WRKSRC}/Makefile
+.if empty(ICONV_LIB)
+ @${REINPLACE_CMD} -e 's| or sys.platform.startswith("freebsd"):|:|' ${WRKSRC}/setup.py
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/cupsconnection.c
+ @${REINPLACE_CMD} -e 's|#ifdef __SVR4|#ifdef __FreeBSD__|' ${WRKSRC}/cupsppd.c
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cups.so
+
+.include <bsd.port.post.mk>
diff --git a/print/py-pycups1/distinfo b/print/py-pycups1/distinfo
new file mode 100644
index 000000000000..160cd09733cc
--- /dev/null
+++ b/print/py-pycups1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1538663166
+SHA256 (pycups-1.9.74.tar.bz2) = 86090f259a7c5d0d5caa3407a0e57c9e134027620cbc8f90bf4e37c8b53ed7b9
+SIZE (pycups-1.9.74.tar.bz2) = 52831
diff --git a/print/py-pycups1/pkg-descr b/print/py-pycups1/pkg-descr
new file mode 100644
index 000000000000..0a9cc53c4a5a
--- /dev/null
+++ b/print/py-pycups1/pkg-descr
@@ -0,0 +1,4 @@
+CUPS bindings for Python
+
+WWW: https://pypi.org/project/pycups/
+WWW: https://github.com/zdohnal/pycups