aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-10-10 12:11:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-10-10 12:11:03 +0000
commit84a01c181c76cb069032c62421cd9d95b1f2679a (patch)
treeb431d7d0372da381c07531163794d70ca692b03f /print
parent2dd91743427188c5f005899a6c39ce892036db53 (diff)
downloadports-84a01c181c76cb069032c62421cd9d95b1f2679a.tar.gz
ports-84a01c181c76cb069032c62421cd9d95b1f2679a.zip
- Update to 1.21.3.
- Reorganise options to enable configurations that don't depend on Ghostscript or Poppler.
Notes
Notes: svn path=/head/; revision=481734
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile109
-rw-r--r--print/cups-filters/distinfo6
-rw-r--r--print/cups-filters/files/patch-Makefile.in28
-rw-r--r--print/cups-filters/files/patch-cupsfilters_colormanager.c10
-rw-r--r--print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c10
-rw-r--r--print/cups-filters/pkg-descr13
-rw-r--r--print/cups-filters/pkg-plist42
7 files changed, 134 insertions, 84 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index d032e4cbec75..30605e0b1cc8 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cups-filters
-PORTVERSION= 1.16.0
-PORTREVISION= 6
+PORTVERSION= 1.21.3
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
@@ -16,37 +15,38 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libqpdf.so:print/qpdf \
libcupsimage.so:print/cups \
libfreetype.so:print/freetype2 \
- libfontconfig.so:x11-fonts/fontconfig \
- libpoppler.so:graphics/poppler
+ libfontconfig.so:x11-fonts/fontconfig
CONFLICTS= cups-pstoraster-[0-9]* foomatic-filters-[0-9]*
-USES= compiler:c++11-lib cpe gettext ghostscript gmake gnome libtool \
- iconv pathfix pkgconfig shebangfix tar:xz
+USES= compiler:c++11-lib cpe gmake gnome iconv libtool localbase \
+ pkgconfig shebangfix tar:xz
CPE_VENDOR= linuxfoundation
SHEBANG_FILES= filter/braille/drivers/generic/brftoembosser.in \
filter/braille/drivers/index/imageubrltoindexv3.in \
filter/braille/drivers/index/imageubrltoindexv4.in \
filter/braille/drivers/index/textbrftoindexv3.in \
+ filter/braille/filters/brftopagedbrf.in \
filter/braille/filters/imagetobrf.in \
filter/braille/filters/liblouis1.defs.gen.in \
- filter/braille/filters/texttobrf.in
+ filter/braille/filters/musicxmltobrf.in \
+ filter/braille/filters/texttobrf.in \
+ filter/braille/filters/vectortobrf.in \
+ filter/braille/filters/vectortopdf.in
USE_GNOME= glib20
+USE_LDCONFIG= yes
USE_RC_SUBR= cups_browsed
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-shell=/bin/sh --with-pdftops-path=${LOCALBASE}/bin/pdftops
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-USE_LDCONFIG= yes
-
-OPTIONS_DEFINE= BRAILLE COLORD DOCS IJS IMAGEFILTERS
-OPTIONS_GROUP= CUPS_BROWSED
+OPTIONS_DEFINE= BRAILLE COLORD DOCS
+OPTIONS_GROUP= FILTERS CUPS_BROWSED
+OPTIONS_GROUP_FILTERS= GHOSTSCRIPT IMAGES MUPDF POPPLER
OPTIONS_GROUP_CUPS_BROWSED= AVAHI LDAP
-OPTIONS_SINGLE= PDFTOPS_RENDERER
-OPTIONS_SINGLE_PDFTOPS_RENDERER=GS HYBRID PDFTOPS MUPDF
-OPTIONS_DEFAULT= AVAHI COLORD HYBRID IJS IMAGEFILTERS
+OPTIONS_SINGLE= PDFTOPS
+OPTIONS_SINGLE_PDFTOPS= PSGHOSTSCRIPT PSHYBRID PSMUPDF PSPOPPLER
+OPTIONS_DEFAULT= COLORD GHOSTSCRIPT IMAGES AVAHI LDAP PSHYBRID
OPTIONS_SUB= yes
BRAILLE_CONFIGURE_ENABLE= braille
@@ -63,59 +63,76 @@ COLORD_DESC= Get ICC color profiles from colord (via D-Bus)
COLORD_LIB_DEPENDS= libdbus-1.so:devel/dbus
COLORD_RUN_DEPENDS= colord>0:graphics/colord
-IJS_CONFIGURE_ENABLE= ijs
-IJS_DESC= Support PPD files that use pdftoijs
-IJS_LIB_DEPENDS= libijs.so:print/libijs
+# Filters
+
+FILTERS_DESC= Filters
-IMAGEFILTERS_CONFIGURE_ENABLE= imagefilters
-IMAGEFILTERS_CONFIGURE_WITH= jpeg png tiff
-IMAGEFILTERS_DESC= Support printing image files
-IMAGEFILTERS_LIB_DEPENDS= libtiff.so:graphics/tiff \
+GHOSTSCRIPT_CONFIGURE_ENABLE= ghostscript
+GHOSTSCRIPT_DESC= PS-to-PDF and PS/PDF-to-raster using Ghostscript
+GHOSTSCRIPT_USES= ghostscript
+
+IMAGES_CONFIGURE_ENABLE= imagefilters
+IMAGES_CONFIGURE_WITH= jpeg png tiff
+IMAGES_DESC= Accept JPEG, PNG, and TIFF files as input
+IMAGES_LIB_DEPENDS= libtiff.so:graphics/tiff \
libpng.so:graphics/png
-IMAGEFILTERS_USES= jpeg
+IMAGES_USES= jpeg
+
+MUPDF_BUILD_DEPENDS= mutool:graphics/mupdf
+MUPDF_RUN_DEPENDS= mutool:graphics/mupdf
+MUPDF_CONFIGURE_ENABLE= mutool
+MUPDF_DESC= PDF-to-raster using MuPDF
+
+POPPLER_CONFIGURE_ENABLE= poppler
+POPPLER_DESC= PDF-to-raster using Poppler
+POPPLER_LIB_DEPENDS= libpoppler.so:graphics/poppler
# cups-browsed(8) options
-AVAHI_CONFIGURE_ENABLE= avahi
+CUPS_BROWSED_DESC= cups-browsed(8) options
+
+AVAHI_CONFIGURE_ENABLE= avahi
AVAHI_CONFIGURE_OFF= --with-browseremoteprotocols=cups
AVAHI_CONFIGURE_ON= --with-browseremoteprotocols="dnssd cups"
+AVAHI_DESC= Discover Zeroconf/Bonjour network printers
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
-AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
+AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
AVAHI_SUB_LIST_OFF= AVAHI_DAEMON=
-CUPS_BROWSED_DESC= cups-browsed(8) options
-
LDAP_CONFIGURE_ENABLE= ldap
+LDAP_DESC= Get printer locations from an LDAP server
LDAP_USE= OPENLDAP=yes
# Default PDF-to-PostScript renderer
-GS_CONFIGURE_ON= --with-pdftops=gs
-GS_DESC= Ghostscript gs(1)
+PDFTOPS_DESC= Default PDF-to-PostScript renderer
-HYBRID_BUILD_DEPENDS= pdftops:graphics/poppler-utils
-HYBRID_RUN_DEPENDS= pdftops:graphics/poppler-utils
-HYBRID_CONFIGURE_ON= --with-pdftops=hybrid
-HYBRID_DESC= Ghostscript or Poppler depending on printer
+PSGHOSTSCRIPT_CONFIGURE_ON= --with-pdftops=gs
+PSGHOSTSCRIPT_DESC= Ghostscript gs(1)
+PSGHOSTSCRIPT_IMPLIES= GHOSTSCRIPT
-PDFTOPS_BUILD_DEPENDS= pdftops:graphics/poppler-utils
-PDFTOPS_RUN_DEPENDS= pdftops:graphics/poppler-utils
-PDFTOPS_CONFIGURE_ON= --with-pdftops=pdftops
-PDFTOPS_DESC= Poppler pdftops(1)
+PSHYBRID_BUILD_DEPENDS= pdftops:graphics/poppler-utils
+PSHYBRID_RUN_DEPENDS= pdftops:graphics/poppler-utils
+PSHYBRID_CONFIGURE_ON= --with-pdftops=hybrid
+PSHYBRID_DESC= Ghostscript or Poppler depending on printer
+PSHYBRID_IMPLIES= GHOSTSCRIPT
-MUPDF_BUILD_DEPENDS= mutool:graphics/mupdf
-MUPDF_RUN_DEPENDS= mutool:graphics/mupdf
-MUPDF_CONFIGURE_ON= --with-pdftops=mupdf
-MUPDF_CONFIGURE_ENABLE= mutool
-MUPDF_DESC= MuPDF renderer
+PSMUPDF_CONFIGURE_ON= --with-pdftops=mupdf
+PSMUPDF_DESC= MuPDF mutool(1)
+PSMUPDF_IMPLIES= MUPDF
-PDFTOPS_RENDERER_DESC= Default PDF-to-PostScript renderer
+PSPOPPLER_BUILD_DEPENDS= pdftops:graphics/poppler-utils
+PSPOPPLER_RUN_DEPENDS= pdftops:graphics/poppler-utils
+PSPOPPLER_CONFIGURE_ON= --with-pdftops=pdftops
+PSPOPPLER_DESC= Poppler pdftops(1)
post-patch:
- @${REINPLACE_CMD} 's:-std=c++0x:-std=c++11:' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
-e 's|README.gz|README|' \
${WRKSRC}/utils/cups-browsed.8 \
- ${WRKSRC}/utils/cups-browsed.conf.5
+ ${WRKSRC}/utils/cups-browsed.conf.5 \
+ ${WRKSRC}/utils/driverless.1
+ @${REINPLACE_CMD} '/^texttotext_LDADD =/s/$$/ ${ICONV_LIB}/' \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/print/cups-filters/distinfo b/print/cups-filters/distinfo
index 55b6091f25a2..940c8f0dcfbf 100644
--- a/print/cups-filters/distinfo
+++ b/print/cups-filters/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501216422
-SHA256 (cups-filters-1.16.0.tar.xz) = b37c6a4e8806035ce229c055ec66a4258f3b3c5346f1f0ad535db1b5ee6f96cd
-SIZE (cups-filters-1.16.0.tar.xz) = 1433588
+TIMESTAMP = 1538924799
+SHA256 (cups-filters-1.21.3.tar.xz) = f5a61222148f68d0afc3bb5960eda167f9bcd0055dcd4c5c4a6909f1a79126e0
+SIZE (cups-filters-1.21.3.tar.xz) = 1474152
diff --git a/print/cups-filters/files/patch-Makefile.in b/print/cups-filters/files/patch-Makefile.in
new file mode 100644
index 000000000000..bf12a47c1777
--- /dev/null
+++ b/print/cups-filters/files/patch-Makefile.in
@@ -0,0 +1,28 @@
+--- Makefile.in.orig 2018-10-03 20:13:01 UTC
++++ Makefile.in
+@@ -5770,13 +5770,13 @@ $(cups_notifier_sources): utils/org.cups.cupsd.Notifie
+ distclean-local:
+ rm -rf *.cache *~
+
+-install-exec-hook:
++install-data-hook:
+ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(pkgfilterdir)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(pkgbackenddir)
+-@ENABLE_FOOMATIC_TRUE@ $(LN_S) -r -f $(DESTDIR)$(pkgfilterdir)/foomatic-rip $(DESTDIR)$(bindir)
+-@ENABLE_DRIVERLESS_TRUE@ $(LN_S) -r -f $(DESTDIR)$(pkgppdgendir)/driverless $(DESTDIR)$(bindir)
+-@ENABLE_DRIVERLESS_TRUE@ $(LN_S) -r -f $(DESTDIR)$(pkgppdgendir)/driverless $(DESTDIR)$(pkgbackenddir)
++@ENABLE_FOOMATIC_TRUE@ $(INSTALL) -l rs $(DESTDIR)$(pkgfilterdir)/foomatic-rip $(DESTDIR)$(bindir)
++@ENABLE_DRIVERLESS_TRUE@ $(INSTALL) -l rs $(DESTDIR)$(pkgppdgendir)/driverless $(DESTDIR)$(bindir)
++@ENABLE_DRIVERLESS_TRUE@ $(INSTALL) -l rs $(DESTDIR)$(pkgppdgendir)/driverless $(DESTDIR)$(pkgbackenddir)
+ @ENABLE_BRAILLE_TRUE@ $(LN_S) -f imagetobrf $(DESTDIR)$(pkgfilterdir)/imagetoubrl
+ @ENABLE_BRAILLE_TRUE@ $(LN_S) -f vectortopdf $(DESTDIR)$(pkgfilterdir)/svgtopdf
+ @ENABLE_BRAILLE_TRUE@ $(LN_S) -f vectortopdf $(DESTDIR)$(pkgfilterdir)/xfigtopdf
+@@ -5787,7 +5787,6 @@ install-exec-hook:
+ @ENABLE_BRAILLE_TRUE@ $(LN_S) -f vectortobrf $(DESTDIR)$(pkgfilterdir)/vectortoubrl
+ @ENABLE_BRAILLE_TRUE@ $(LN_S) -f textbrftoindexv3 $(DESTDIR)$(pkgfilterdir)/textbrftoindexv4
+
+-install-data-hook:
+ @RCLINKS_TRUE@ for level in $(RCLEVELS); do \
+ @RCLINKS_TRUE@ $(INSTALL) -d -m 755 $(DESTDIR)$(INITDIR)/rc$${level}.d; \
+ @RCLINKS_TRUE@ $(LN_S) -f ../init.d/cups-browsed $(DESTDIR)$(INITDIR)/rc$${level}.d/S$(RCSTART)cups-browsed; \
diff --git a/print/cups-filters/files/patch-cupsfilters_colormanager.c b/print/cups-filters/files/patch-cupsfilters_colormanager.c
index d6615e17846c..3b1b190005e7 100644
--- a/print/cups-filters/files/patch-cupsfilters_colormanager.c
+++ b/print/cups-filters/files/patch-cupsfilters_colormanager.c
@@ -1,6 +1,6 @@
---- cupsfilters/colormanager.c.orig 2015-06-26 15:45:26 UTC
+--- cupsfilters/colormanager.c.orig 2018-10-03 20:12:51 UTC
+++ cupsfilters/colormanager.c
-@@ -26,6 +26,7 @@ MIT Open Source License - http://www.o
+@@ -26,6 +26,7 @@ MIT Open Source License - http://www.opensource.org/
*/
@@ -8,12 +8,12 @@
#include "colormanager.h"
#include <cupsfilters/colord.h>
//#include <cupsfilters/kmdevices.h>
-@@ -323,7 +324,7 @@ _get_ppd_icc_fallback (ppd_file_t *ppd,
+@@ -327,7 +328,7 @@ _get_ppd_icc_fallback (ppd_file_t *ppd, char **qualifi
/* expand to a full path if not already specified */
if (attr->value[0] != '/')
snprintf(full_path, sizeof(full_path),
- "%s/profiles/%s", CUPSDATA, attr->value);
+ "%s/profiles/%s", CUPS_DATADIR, attr->value);
- else
+ else {
strncpy(full_path, attr->value, sizeof(full_path));
-
+ if (strlen(attr->value) > 1023)
diff --git a/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c b/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c
deleted file mode 100644
index 6d852b0802f0..000000000000
--- a/print/cups-filters/files/patch-filter_foomatic-rip_foomaticrip.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- filter/foomatic-rip/foomaticrip.c.orig 2015-10-20 14:59:20 UTC
-+++ filter/foomatic-rip/foomaticrip.c
-@@ -656,6 +656,7 @@ int print_file(const char *filename, int
- rip_die(EXIT_PRNERR_NORETRY_BAD_SETTINGS,
- "Couldn't dup stdout of pdf-to-ps\n");
-
-+ clearerr(stdin);
- ret = print_file("<STDIN>", 0);
-
- wait_for_process(renderer_pid);
diff --git a/print/cups-filters/pkg-descr b/print/cups-filters/pkg-descr
index 2d921bee79b8..d14512934352 100644
--- a/print/cups-filters/pkg-descr
+++ b/print/cups-filters/pkg-descr
@@ -1,5 +1,10 @@
-The CUPS Filters package contains backends, filters and other
-software that was once part of the core CUPS distribution but is
-no longer maintained by Apple Inc.
+The CUPS Filters package contains backends, filters and other software
+that was once part of the core CUPS distribution but is no longer
+maintained by Apple Inc. In addition it contains additional filters and
+software developed independently of Apple, especially filters for the
+PDF-centric printing workflow introduced by OpenPrinting and a daemon to
+browse Bonjour broadcasts of remote CUPS printers to make these printers
+available locally and to provide backward compatibility to the old CUPS
+broadcasting and browsing of CUPS 1.5.x and older.
-WWW: http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
+WWW: https://wiki.linuxfoundation.org/openprinting/cups-filters
diff --git a/print/cups-filters/pkg-plist b/print/cups-filters/pkg-plist
index 8671560ce6bf..dd8d65c7cfe1 100644
--- a/print/cups-filters/pkg-plist
+++ b/print/cups-filters/pkg-plist
@@ -2,7 +2,6 @@ bin/driverless
bin/foomatic-rip
bin/ttfread
etc/cups/cups-browsed.conf
-etc/fonts/conf.d/99pdftoopvp.conf
include/cupsfilters/colord.h
include/cupsfilters/colormanager.h
include/cupsfilters/driver.h
@@ -25,6 +24,7 @@ lib/libfontembed.so.1.0.0
libdata/pkgconfig/libcupsfilters.pc
libdata/pkgconfig/libfontembed.pc
libexec/cups/backend/beh
+%%BRAILLE%%libexec/cups/backend/cups-brf
libexec/cups/backend/driverless
libexec/cups/backend/implicitclass
libexec/cups/backend/parallel
@@ -32,29 +32,34 @@ libexec/cups/backend/serial
libexec/cups/driver/driverless
libexec/cups/filter/bannertopdf
%%BRAILLE%%libexec/cups/filter/brftoembosser
+%%BRAILLE%%libexec/cups/filter/brftopagedbrf
+%%BRAILLE%%libexec/cups/filter/cgmtopdf
+%%BRAILLE%%libexec/cups/filter/cmxtopdf
libexec/cups/filter/commandtoescpx
libexec/cups/filter/commandtopclx
+%%BRAILLE%%libexec/cups/filter/emftopdf
libexec/cups/filter/foomatic-rip
-libexec/cups/filter/gstopdf
-libexec/cups/filter/gstopxl
-libexec/cups/filter/gstoraster
+%%GHOSTSCRIPT%%libexec/cups/filter/gstopdf
+%%GHOSTSCRIPT%%libexec/cups/filter/gstopxl
+%%GHOSTSCRIPT%%libexec/cups/filter/gstoraster
%%BRAILLE%%libexec/cups/filter/imagetobrf
-%%IMAGEFILTERS%%libexec/cups/filter/imagetopdf
-%%IMAGEFILTERS%%libexec/cups/filter/imagetops
-%%IMAGEFILTERS%%libexec/cups/filter/imagetoraster
+%%IMAGES%%libexec/cups/filter/imagetopdf
+%%IMAGES%%libexec/cups/filter/imagetops
+%%IMAGES%%libexec/cups/filter/imagetoraster
%%BRAILLE%%libexec/cups/filter/imagetoubrl
%%BRAILLE%%libexec/cups/filter/imageubrltoindexv3
%%BRAILLE%%libexec/cups/filter/imageubrltoindexv4
%%MUPDF%%libexec/cups/filter/mupdftoraster
-%%IJS%%libexec/cups/filter/pdftoijs
-libexec/cups/filter/pdftoopvp
+%%BRAILLE%%libexec/cups/filter/musicxmltobrf
libexec/cups/filter/pdftopdf
libexec/cups/filter/pdftops
-libexec/cups/filter/pdftoraster
+%%POPPLER%%libexec/cups/filter/pdftoraster
libexec/cups/filter/rastertoescpx
+libexec/cups/filter/rastertopclm
libexec/cups/filter/rastertopclx
libexec/cups/filter/rastertopdf
libexec/cups/filter/rastertops
+%%BRAILLE%%libexec/cups/filter/svgtopdf
libexec/cups/filter/sys5ippprinter
%%BRAILLE%%libexec/cups/filter/textbrftoindexv3
%%BRAILLE%%libexec/cups/filter/textbrftoindexv4
@@ -62,6 +67,11 @@ libexec/cups/filter/sys5ippprinter
libexec/cups/filter/texttopdf
libexec/cups/filter/texttops
libexec/cups/filter/texttotext
+%%BRAILLE%%libexec/cups/filter/vectortobrf
+%%BRAILLE%%libexec/cups/filter/vectortopdf
+%%BRAILLE%%libexec/cups/filter/vectortoubrl
+%%BRAILLE%%libexec/cups/filter/wmftopdf
+%%BRAILLE%%libexec/cups/filter/xfigtopdf
man/man1/driverless.1.gz
man/man1/foomatic-rip.1.gz
man/man5/cups-browsed.conf.5.gz
@@ -96,13 +106,14 @@ share/cups/data/topsecret.pdf
share/cups/data/unclassified.pdf
share/cups/drv/cupsfilters.drv
%%BRAILLE%%share/cups/drv/generic-brf.drv
+%%BRAILLE%%share/cups/drv/generic-ubrl.drv
%%BRAILLE%%share/cups/drv/indexv3.drv
%%BRAILLE%%share/cups/drv/indexv4.drv
%%BRAILLE%%share/cups/mime/braille.convs
%%BRAILLE%%share/cups/mime/braille.types
-share/cups/mime/cupsfilters-ghostscript.convs
+%%GHOSTSCRIPT%%share/cups/mime/cupsfilters-ghostscript.convs
%%MUPDF%%share/cups/mime/cupsfilters-mupdf.convs
-share/cups/mime/cupsfilters-poppler.convs
+%%POPPLER%%share/cups/mime/cupsfilters-poppler.convs
share/cups/mime/cupsfilters.convs
share/cups/mime/cupsfilters.types
%%BRAILLE%%share/cups/ppdc/braille.defs
@@ -111,7 +122,7 @@ share/cups/ppdc/escp.h
%%BRAILLE%%share/cups/ppdc/imagemagick.defs
%%BRAILLE%%share/cups/ppdc/index.defs
%%BRAILLE%%share/cups/ppdc/liblouis.defs
-%%BRAILLE%%share/cups/ppdc/liblouis1.defs.gen.in
+%%BRAILLE%%share/cups/ppdc/liblouis1.defs
%%BRAILLE%%share/cups/ppdc/liblouis2.defs
%%BRAILLE%%share/cups/ppdc/liblouis3.defs
%%BRAILLE%%share/cups/ppdc/liblouis4.defs
@@ -125,7 +136,6 @@ share/cups/ppdc/pcl.h
share/ppd/cupsfilters/Fuji_Xerox-DocuPrint_CM305_df-PDF.ppd
share/ppd/cupsfilters/Generic-PDF_Printer-PDF.ppd
share/ppd/cupsfilters/HP-Color_LaserJet_CM3530_MFP-PDF.ppd
-%%IJS%%share/ppd/cupsfilters/HP-PhotoSmart_Pro_B8300-hpijs-pdftoijs.ppd
share/ppd/cupsfilters/Ricoh-PDF_Printer-PDF.ppd
-share/ppd/cupsfilters/pxlcolor.ppd
-share/ppd/cupsfilters/pxlmono.ppd
+%%GHOSTSCRIPT%%share/ppd/cupsfilters/pxlcolor.ppd
+%%GHOSTSCRIPT%%share/ppd/cupsfilters/pxlmono.ppd