aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2015-04-10 01:03:36 +0000
committerMikhail Teterin <mi@FreeBSD.org>2015-04-10 01:03:36 +0000
commit98a033c60c563c876acd0ab060fdf69020907ce8 (patch)
tree4ab908f30ab9d92a575efc702bd5d5131cf5e4e6 /print
parent6f2b46a5c26aaa099e567dd5d12c668c7f2d209e (diff)
downloadports-98a033c60c563c876acd0ab060fdf69020907ce8.tar.gz
ports-98a033c60c563c876acd0ab060fdf69020907ce8.zip
Unbreak, upgrade from 1.3.6 (released in 2007) to 1.3.7 (released in
2013). Approved by: being condemned
Notes
Notes: svn path=/head/; revision=383685
Diffstat (limited to 'print')
-rw-r--r--print/pecl-ps/Makefile12
-rw-r--r--print/pecl-ps/distinfo4
-rw-r--r--print/pecl-ps/files/patch-ps.c66
3 files changed, 7 insertions, 75 deletions
diff --git a/print/pecl-ps/Makefile b/print/pecl-ps/Makefile
index 2c128c2f94a1..960aea846caa 100644
--- a/print/pecl-ps/Makefile
+++ b/print/pecl-ps/Makefile
@@ -2,29 +2,27 @@
# $FreeBSD$
PORTNAME= ps
-PORTVERSION= 1.3.6
-PORTREVISION= 3
+PORTVERSION= 1.3.7
CATEGORIES= print pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
DISTNAME= ps-${PORTVERSION}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= alan@fromorbit.com
COMMENT= PHP extension for pslib to generate postscript
-DEPRECATED= requires php53, security EOL reached 14 Aug 2014
-EXPIRATION_DATE= 2015-04-15
-
LIB_DEPENDS= libps.so:${PORTSDIR}/print/pslib
+USES= tar:tgz
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PORTNAME}
-IGNORE_WITH_PHP=5 55 56
post-patch:
@${REINPLACE_CMD} -e 's|-ldl|-lintl|g' ${WRKSRC}/config.m4
+test check regression-test: build
+ ${MAKE} -C ${WRKSRC} test < /dev/null
+
.include <bsd.port.mk>
diff --git a/print/pecl-ps/distinfo b/print/pecl-ps/distinfo
index 1149a7c9b45e..329aa518b392 100644
--- a/print/pecl-ps/distinfo
+++ b/print/pecl-ps/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/ps-1.3.6.tgz) = 37496f6a1d47f7634ea364bd8d4c3f4f20ddd7c461f38203e607b73dde9b61ba
-SIZE (PECL/ps-1.3.6.tgz) = 635832
+SHA256 (PECL/ps-1.3.7.tgz) = b4f83f7a4426e59a3026dec59405755c9a12f223d1286abb972d81abb11c8205
+SIZE (PECL/ps-1.3.7.tgz) = 634024
diff --git a/print/pecl-ps/files/patch-ps.c b/print/pecl-ps/files/patch-ps.c
deleted file mode 100644
index d89431ac996c..000000000000
--- a/print/pecl-ps/files/patch-ps.c
+++ /dev/null
@@ -1,66 +0,0 @@
---- ps.c 2006-05-31 23:09:47.000000000 +1000
-+++ ps.c 2008-09-22 13:50:07.000000000 +1000
-@@ -1285,7 +1285,8 @@
- zval *zps;
- char *type, *filename, *image, *stringparam = NULL;
- int type_len, filename_len, stringparam_len;
-- int imageid, intparam = 0;
-+ long imageid;
-+ int intparam = 0;
- PSDoc *ps;
-
- if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rss|sl", &zps, &type, &type_len, &filename, &filename_len, &stringparam, &stringparam_len, &intparam)) {
-@@ -1316,7 +1317,7 @@
- {
- zval **arg1, **arg2;
- int i, j, color, count;
-- int imageid;
-+ long imageid;
- gdImagePtr im;
- unsigned char *buffer, *ptr;
- PSDoc *ps;
-@@ -1382,7 +1383,7 @@
- PHP_FUNCTION(ps_close_image)
- {
- zval *zps;
-- int imageid;
-+ long imageid;
- PSDoc *ps;
-
- if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rl", &zps, &imageid)) {
-@@ -1400,7 +1401,7 @@
- PHP_FUNCTION(ps_place_image)
- {
- zval *zps;
-- int imageid;
-+ long imageid;
- double x, y, scale;
- PSDoc *ps;
-
-@@ -1761,7 +1762,7 @@
- zval **arg1, **arg2, **arg3, **arg4, **arg5, **arg6, **arg7;
- PSDoc *ps;
- char *image;
-- int imageid;
-+ long imageid;
-
- if (ZEND_NUM_ARGS() != 7 || zend_get_parameters_ex(7, &arg1, &arg2, &arg3, &arg4, &arg5, &arg6, &arg7) == FAILURE) {
- WRONG_PARAM_COUNT;
-@@ -1802,7 +1803,7 @@
- char *type, *params, *source, *data;
- int type_len, params_len, source_len, data_len;
- int length, width, height, components, bpc;
-- int imageid;
-+ long imageid;
- char *image;
- PSDoc *ps;
-
-@@ -2024,7 +2025,7 @@
- * Add an existing image as thumbnail for the current page. */
- PHP_FUNCTION(ps_add_thumbnail) {
- zval *zps;
-- int imageid;
-+ long imageid;
- PSDoc *ps;
-
- if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rl", &zps, &imageid)) {