aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-05-15 11:36:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-05-15 11:36:56 +0000
commitae05e3c4b3df8118127dea665d1ce1acd7b86a0c (patch)
tree7a1600dddf19e79ed8bcc03a1094621508cb6a1a /print
parentc8ed37629b41b3fb23958a77ad36b858ff17d961 (diff)
downloadports-ae05e3c4b3df8118127dea665d1ce1acd7b86a0c.tar.gz
ports-ae05e3c4b3df8118127dea665d1ce1acd7b86a0c.zip
CUPS backend for the canon proprietary USB over IP network printing
protocol, BJNP. This backend is based on reverse engineering using TCP/IP. It can be used with CUPS 1.2 and 1.3. This backend allows Cups to connect over the network to a Canon printers WWW: http://cups-bjnp.sourceforge.net/ PR: ports/134075 Submitted by: Stephen Hurd <shurd@sasktel.net>
Notes
Notes: svn path=/head/; revision=233929
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/cups-bjnp/Makefile21
-rw-r--r--print/cups-bjnp/distinfo3
-rw-r--r--print/cups-bjnp/files/patch-bjnp-io.c11
-rw-r--r--print/cups-bjnp/files/patch-configure20
-rw-r--r--print/cups-bjnp/pkg-descr6
-rw-r--r--print/cups-bjnp/pkg-plist3
7 files changed, 65 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index ea384c9277c1..bb36968f555f 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -46,6 +46,7 @@
SUBDIR += cpp2latex
SUBDIR += cups
SUBDIR += cups-base
+ SUBDIR += cups-bjnp
SUBDIR += cups-client
SUBDIR += cups-magicolor
SUBDIR += cups-pdf
diff --git a/print/cups-bjnp/Makefile b/print/cups-bjnp/Makefile
new file mode 100644
index 000000000000..36f3d12b4f5f
--- /dev/null
+++ b/print/cups-bjnp/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: cups-bjnp
+# Date created: 15 May 2009
+# Whom: shurd@sasktel.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups-bjnp
+PORTVERSION= 0.5
+CATEGORIES= print
+MASTER_SITES= SF
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= CUPS backend for Canon USB over IP protocol
+
+LIB_DEPENDS= cupsimage.2:${PORTSDIR}/print/cups-base
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS+="-I${LOCALBASE}/include" CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" LIBS="-lcompat"
+
+.include <bsd.port.mk>
diff --git a/print/cups-bjnp/distinfo b/print/cups-bjnp/distinfo
new file mode 100644
index 000000000000..7a39320aef49
--- /dev/null
+++ b/print/cups-bjnp/distinfo
@@ -0,0 +1,3 @@
+MD5 (cups-bjnp-0.5.tar.gz) = 8d0781ec4b31b7eee2e8ce4a2d47aa90
+SHA256 (cups-bjnp-0.5.tar.gz) = f303b3f23ec583344fa8f9c659aa9515566deb352f5971e96a1d72f8ee208dd7
+SIZE (cups-bjnp-0.5.tar.gz) = 138914
diff --git a/print/cups-bjnp/files/patch-bjnp-io.c b/print/cups-bjnp/files/patch-bjnp-io.c
new file mode 100644
index 000000000000..fed2beda30fc
--- /dev/null
+++ b/print/cups-bjnp/files/patch-bjnp-io.c
@@ -0,0 +1,11 @@
+--- bjnp-io.c.orig 2009-02-28 12:08:51.000000000 -0800
++++ bjnp-io.c 2009-04-28 16:59:11.000000000 -0700
+@@ -15,6 +15,8 @@
+ * <to be added>
+ */
+
++#include "config.h"
++
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <sys/select.h>
diff --git a/print/cups-bjnp/files/patch-configure b/print/cups-bjnp/files/patch-configure
new file mode 100644
index 000000000000..077481d0075b
--- /dev/null
+++ b/print/cups-bjnp/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2009-03-12 13:15:28.000000000 -0700
++++ configure 2009-04-28 17:25:40.000000000 -0700
+@@ -3671,14 +3671,14 @@
+
+ else
+
+- dirs="/usr/lib/cups/backend /usr/local/lib/cups/backend /opt/lib/cups/backend"
++ dirs="/usr/lib/cups/backend /usr/local/lib/cups/backend /opt/lib/cups/backend /usr/local/libexec/cups/backend"
+ cupsbackenddir=""
+ for dir in $dirs; do
+- if test -d $dir -a -n "cupsbackenddir"; then
++ if test -d $dir -a -z "$cupsbackenddir"; then
+ cupsbackenddir=$dir
+ fi
+ done
+- if test -n $cupsbackenddir; then
++ if test -n "$cupsbackenddir"; then
+ echo found Cups backend directory $cupsbackenddir
+ else
+ { { $as_echo "$as_me:$LINENO: error: Cups backend directory not specified and auto-detection failed!" >&5
diff --git a/print/cups-bjnp/pkg-descr b/print/cups-bjnp/pkg-descr
new file mode 100644
index 000000000000..7d31946f026f
--- /dev/null
+++ b/print/cups-bjnp/pkg-descr
@@ -0,0 +1,6 @@
+CUPS backend for the canon proprietary USB over IP network printing
+protocol, BJNP. This backend is based on reverse engineering using
+TCP/IP. It can be used with CUPS 1.2 and 1.3. This backend allows Cups
+to connect over the network to a Canon printers
+
+WWW: http://cups-bjnp.sourceforge.net/
diff --git a/print/cups-bjnp/pkg-plist b/print/cups-bjnp/pkg-plist
new file mode 100644
index 000000000000..94297e18b538
--- /dev/null
+++ b/print/cups-bjnp/pkg-plist
@@ -0,0 +1,3 @@
+libexec/cups/backend/bjnp
+@dirrmtry libexec/cups/backend
+@dirrmtry libexec/cups