aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-24 21:22:21 +0000
commitb1bf1620a6571c5eb84bed4e3f06cf52094d0a48 (patch)
tree93506aaee5230ee46b75930c4b3a6b8e0f243d74 /print
parent123411e1ee17366ee88efd54b8482949b8e76eb5 (diff)
downloadports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.tar.gz
ports-b1bf1620a6571c5eb84bed4e3f06cf52094d0a48.zip
Update freetype to 2.5.2.
Remove patch to add -I/usr/local/include in freetype-config --cflags. If ports need extra headers they should look for them, and not get them via a side-effect. Freetype had a header resuffle in 2.5.1, patch ports to use the new header style. Thanks go to bdrewery for the two exp-runs and rakuco for helping me with some troublesome cmake ports. PR: ports/184587
Notes
Notes: svn path=/head/; revision=337385
Diffstat (limited to 'print')
-rw-r--r--print/freetype2/Makefile13
-rw-r--r--print/freetype2/distinfo4
-rw-r--r--print/freetype2/files/patch-builds::unix::freetype-config.in17
-rw-r--r--print/freetype2/pkg-plist105
-rw-r--r--print/ft2demos/Makefile9
-rw-r--r--print/ft2demos/distinfo4
-rw-r--r--print/lilypond/files/patch-lily_freetype-error.cc12
-rw-r--r--print/lilypond/files/patch-lily_open-type-font.cc12
-rw-r--r--print/lilypond/files/patch-lily_pango-font.cc12
-rw-r--r--print/lilypond/files/patch-lily_ttf.cc12
-rw-r--r--print/paps/files/patch-src_libpaps.c14
-rw-r--r--print/ttf2pt1/files/patch-ft.c20
12 files changed, 141 insertions, 93 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index c8e966b4f7ca..db602a411cda 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/print/freetype2/Makefile,v 1.28 2011/10/25 18:31:21 kwm Exp $
PORTNAME= freetype2
-PORTVERSION= 2.5.0.1
+PORTVERSION= 2.5.2
CATEGORIES= print
MASTER_SITES= SF/freetype/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+\.[0-9]+).*/\1/}/ \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/freetype2/ \
@@ -16,21 +16,19 @@ DISTNAME= ${PORTNAME:S/2//}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Free and portable TrueType font rendering engine
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USES= gmake
MAKE_ENV= TOP=""
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME= ltverhack:9
-LIBTOOLFILES= builds/unix/configure
+ltverhack_PATCH_FILES= builds/unix/ltmain.sh
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
OPTIONS_DEFINE= LCD_FILTERING PNG
LCD_FILTERING_DESC?= Sub-pixel rendering (patented)
PNG_DESC= Png compressed OpenType embedded bitmaps support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLCD_FILTERING}
@@ -47,12 +45,11 @@ pre-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/builds/unix/install.mk
-pre-configure:
- @${REINPLACE_CMD} -e '/^LIBTOOL/s|LIBTOOL := $$(FT_LIBTOOL_DIR)/libtool|LIBTOOL := ${WRKDIR}/gnome-libtool|' \
- ${WRKSRC}/builds/unix/unix-cc.in
-
post-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} setup)
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libfreetype.so.9
+
.include <bsd.port.mk>
diff --git a/print/freetype2/distinfo b/print/freetype2/distinfo
index a86731fa1a74..c5cc19e10d89 100644
--- a/print/freetype2/distinfo
+++ b/print/freetype2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freetype-2.5.0.1.tar.bz2) = 57bce5b37989577aa8b4a588426839f6bf39bcc3869748cb18f6827df251f4e5
-SIZE (freetype-2.5.0.1.tar.bz2) = 1607037
+SHA256 (freetype-2.5.2.tar.bz2) = 4ff4bd393aa01071ec7b849d035508a505a78f88b2bcf25ff11e58e43c0b9def
+SIZE (freetype-2.5.2.tar.bz2) = 1676373
diff --git a/print/freetype2/files/patch-builds::unix::freetype-config.in b/print/freetype2/files/patch-builds::unix::freetype-config.in
deleted file mode 100644
index 4a935f869f9c..000000000000
--- a/print/freetype2/files/patch-builds::unix::freetype-config.in
+++ /dev/null
@@ -1,17 +0,0 @@
---- builds/unix/freetype-config.in.orig 2009-12-21 18:23:42.000000000 -0500
-+++ builds/unix/freetype-config.in 2010-02-21 15:51:17.000000000 -0500
-@@ -131,12 +131,8 @@ if test "$echo_ft_version" = "yes" ; the
- fi
-
- if test "$echo_cflags" = "yes" ; then
-- cflags="-I${SYSROOT}$includedir/freetype2"
-- if test "${SYSROOT}$includedir" != "/usr/include" ; then
-- echo $cflags -I${SYSROOT}$includedir
-- else
-- echo $cflags
-- fi
-+ cflags="-I$includedir/freetype2 -I$includedir"
-+ echo $cflags
- fi
-
- if test "$echo_libs" = "yes" ; then
diff --git a/print/freetype2/pkg-plist b/print/freetype2/pkg-plist
index e858413c34f4..219af878b706 100644
--- a/print/freetype2/pkg-plist
+++ b/print/freetype2/pkg-plist
@@ -1,61 +1,60 @@
bin/freetype-config
-include/freetype2/freetype/config/ftconfig.h
-include/freetype2/freetype/config/ftheader.h
-include/freetype2/freetype/config/ftmodule.h
-include/freetype2/freetype/config/ftoption.h
-include/freetype2/freetype/config/ftstdlib.h
-include/freetype2/freetype/freetype.h
-include/freetype2/freetype/ftadvanc.h
-include/freetype2/freetype/ftautoh.h
-include/freetype2/freetype/ftbbox.h
-include/freetype2/freetype/ftbdf.h
-include/freetype2/freetype/ftbitmap.h
-include/freetype2/freetype/ftbzip2.h
-include/freetype2/freetype/ftcache.h
-include/freetype2/freetype/ftcffdrv.h
-include/freetype2/freetype/ftchapters.h
-include/freetype2/freetype/ftcid.h
-include/freetype2/freetype/fterrdef.h
-include/freetype2/freetype/fterrors.h
-include/freetype2/freetype/ftgasp.h
-include/freetype2/freetype/ftglyph.h
-include/freetype2/freetype/ftgxval.h
-include/freetype2/freetype/ftgzip.h
-include/freetype2/freetype/ftimage.h
-include/freetype2/freetype/ftincrem.h
-include/freetype2/freetype/ftlcdfil.h
-include/freetype2/freetype/ftlist.h
-include/freetype2/freetype/ftlzw.h
-include/freetype2/freetype/ftmac.h
-include/freetype2/freetype/ftmm.h
-include/freetype2/freetype/ftmodapi.h
-include/freetype2/freetype/ftmoderr.h
-include/freetype2/freetype/ftotval.h
-include/freetype2/freetype/ftoutln.h
-include/freetype2/freetype/ftpfr.h
-include/freetype2/freetype/ftrender.h
-include/freetype2/freetype/ftsizes.h
-include/freetype2/freetype/ftsnames.h
-include/freetype2/freetype/ftstroke.h
-include/freetype2/freetype/ftsynth.h
-include/freetype2/freetype/ftsystem.h
-include/freetype2/freetype/ftttdrv.h
-include/freetype2/freetype/fttrigon.h
-include/freetype2/freetype/fttypes.h
-include/freetype2/freetype/ftwinfnt.h
-include/freetype2/freetype/ftxf86.h
-include/freetype2/freetype/t1tables.h
-include/freetype2/freetype/ttnameid.h
-include/freetype2/freetype/tttables.h
-include/freetype2/freetype/tttags.h
-include/freetype2/freetype/ttunpat.h
-include/ft2build.h
+include/freetype2/config/ftconfig.h
+include/freetype2/config/ftheader.h
+include/freetype2/config/ftmodule.h
+include/freetype2/config/ftoption.h
+include/freetype2/config/ftstdlib.h
+include/freetype2/freetype.h
+include/freetype2/ft2build.h
+include/freetype2/ftadvanc.h
+include/freetype2/ftautoh.h
+include/freetype2/ftbbox.h
+include/freetype2/ftbdf.h
+include/freetype2/ftbitmap.h
+include/freetype2/ftbzip2.h
+include/freetype2/ftcache.h
+include/freetype2/ftcffdrv.h
+include/freetype2/ftchapters.h
+include/freetype2/ftcid.h
+include/freetype2/fterrdef.h
+include/freetype2/fterrors.h
+include/freetype2/ftgasp.h
+include/freetype2/ftglyph.h
+include/freetype2/ftgxval.h
+include/freetype2/ftgzip.h
+include/freetype2/ftimage.h
+include/freetype2/ftincrem.h
+include/freetype2/ftlcdfil.h
+include/freetype2/ftlist.h
+include/freetype2/ftlzw.h
+include/freetype2/ftmac.h
+include/freetype2/ftmm.h
+include/freetype2/ftmodapi.h
+include/freetype2/ftmoderr.h
+include/freetype2/ftotval.h
+include/freetype2/ftoutln.h
+include/freetype2/ftpfr.h
+include/freetype2/ftrender.h
+include/freetype2/ftsizes.h
+include/freetype2/ftsnames.h
+include/freetype2/ftstroke.h
+include/freetype2/ftsynth.h
+include/freetype2/ftsystem.h
+include/freetype2/ftttdrv.h
+include/freetype2/fttrigon.h
+include/freetype2/fttypes.h
+include/freetype2/ftwinfnt.h
+include/freetype2/ftxf86.h
+include/freetype2/t1tables.h
+include/freetype2/ttnameid.h
+include/freetype2/tttables.h
+include/freetype2/tttags.h
+include/freetype2/ttunpat.h
lib/libfreetype.a
lib/libfreetype.la
lib/libfreetype.so
lib/libfreetype.so.9
libdata/pkgconfig/freetype2.pc
share/aclocal/freetype2.m4
-@dirrm include/freetype2/freetype/config
-@dirrm include/freetype2/freetype
+@dirrm include/freetype2/config
@dirrm include/freetype2
diff --git a/print/ft2demos/Makefile b/print/ft2demos/Makefile
index 39f201132980..37751298146e 100644
--- a/print/ft2demos/Makefile
+++ b/print/ft2demos/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ft2demos
-PORTVERSION= 2.4.11
+PORTVERSION= 2.5.2
CATEGORIES= print
MASTER_SITES= SF/freetype/freetype-demos/${PORTVERSION} \
RINGSERVER/graphics/freetype/freetype2
@@ -11,11 +11,11 @@ MAINTAINER= 5u623l20@gmail.com
COMMENT= Demo programs for FreeType2
BUILD_DEPENDS+= ${FREETYPE_WRKSRC}/config.mk:${PORTSDIR}/print/freetype2:build
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_XORG= xext
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool:env
MAKE_ENV= TOP_DIR="${FREETYPE_WRKSRC}"
MAKE_ARGS= EXES="${FT_PROGRAMS}" X11_PATH="${LOCALBASE}"
@@ -25,12 +25,11 @@ PLIST_FILES= ${FT_PROGRAMS:S,^,bin/,}
FT_PROGRAMS= ftbench ftchkwd ftdiff ftdump ftgamma ftgrid ftlint ftmemchk \
ftmulti ftpatchk ftstring fttimer ftvalid ftview
-NO_STAGE= yes
.include <bsd.port.pre.mk>
FREETYPE_WRKSRC!= cd ${PORTSDIR}/print/freetype2; ${MAKE} -V WRKSRC
do-install:
- @(cd ${WRKSRC}/bin/.libs/; ${INSTALL_PROGRAM} ${FT_PROGRAMS} ${PREFIX}/bin)
+ @(cd ${WRKSRC}/bin/.libs/; ${INSTALL_PROGRAM} ${FT_PROGRAMS} ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.post.mk>
diff --git a/print/ft2demos/distinfo b/print/ft2demos/distinfo
index 694a4a1e9e55..05757a922c30 100644
--- a/print/ft2demos/distinfo
+++ b/print/ft2demos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ft2demos-2.4.11.tar.bz2) = 49cc6c45542cc39cca0d9135b865fab428b1f9805b46c22fd848528f51c76075
-SIZE (ft2demos-2.4.11.tar.bz2) = 164608
+SHA256 (ft2demos-2.5.2.tar.bz2) = a3cdf60186caeb68cafc98b6b32c54ae9467a7a844865db161510a17a2d14471
+SIZE (ft2demos-2.5.2.tar.bz2) = 185966
diff --git a/print/lilypond/files/patch-lily_freetype-error.cc b/print/lilypond/files/patch-lily_freetype-error.cc
new file mode 100644
index 000000000000..d729c4536253
--- /dev/null
+++ b/print/lilypond/files/patch-lily_freetype-error.cc
@@ -0,0 +1,12 @@
+--- lily/freetype-error.cc.orig 2013-12-16 15:18:38.000000000 +0100
++++ lily/freetype-error.cc 2013-12-16 15:19:06.000000000 +0100
+@@ -31,7 +31,8 @@
+ const char *err_msg;
+ } ft_errors[] =
+
+-#include <freetype/fterrors.h>
++#include <ft2build.h>
++#include FT_ERRORS_H
+
+ ;
+
diff --git a/print/lilypond/files/patch-lily_open-type-font.cc b/print/lilypond/files/patch-lily_open-type-font.cc
new file mode 100644
index 000000000000..78d55522b016
--- /dev/null
+++ b/print/lilypond/files/patch-lily_open-type-font.cc
@@ -0,0 +1,12 @@
+--- lily/open-type-font.cc.orig 2013-12-16 15:54:16.000000000 +0100
++++ lily/open-type-font.cc 2013-12-16 15:54:45.000000000 +0100
+@@ -23,7 +23,8 @@
+
+ using namespace std;
+
+-#include <freetype/tttables.h>
++#include <ft2build.h>
++#include FT_TRUETYPE_TABLES_H
+
+ #include "dimensions.hh"
+ #include "international.hh"
diff --git a/print/lilypond/files/patch-lily_pango-font.cc b/print/lilypond/files/patch-lily_pango-font.cc
new file mode 100644
index 000000000000..227a0444fd58
--- /dev/null
+++ b/print/lilypond/files/patch-lily_pango-font.cc
@@ -0,0 +1,12 @@
+--- lily/pango-font.cc.orig 2013-12-16 15:49:55.000000000 +0100
++++ lily/pango-font.cc 2013-12-16 15:50:46.000000000 +0100
+@@ -22,7 +22,8 @@
+ #define PANGO_ENABLE_BACKEND
+
+ #include <pango/pangoft2.h>
+-#include <freetype/ftxf86.h>
++#include <ft2build.h>
++#include FT_XFREE86_H
+
+ #include <map>
+ #include <cstdio>
diff --git a/print/lilypond/files/patch-lily_ttf.cc b/print/lilypond/files/patch-lily_ttf.cc
new file mode 100644
index 000000000000..0211987989dc
--- /dev/null
+++ b/print/lilypond/files/patch-lily_ttf.cc
@@ -0,0 +1,12 @@
+--- lily/ttf.cc.orig 2013-12-16 15:48:08.000000000 +0100
++++ lily/ttf.cc 2013-12-16 15:48:37.000000000 +0100
+@@ -20,7 +20,8 @@
+ #include <cstdio>
+ #include "freetype.hh"
+
+-#include <freetype/tttables.h>
++#include <ft2build.h>
++#include FT_TRUETYPE_TABLES_H
+
+ #include "international.hh"
+ #include "memory-stream.hh"
diff --git a/print/paps/files/patch-src_libpaps.c b/print/paps/files/patch-src_libpaps.c
new file mode 100644
index 000000000000..790c3a8dda74
--- /dev/null
+++ b/print/paps/files/patch-src_libpaps.c
@@ -0,0 +1,14 @@
+--- src/libpaps.c.orig 2013-12-16 16:10:33.000000000 +0100
++++ src/libpaps.c 2013-12-16 16:11:06.000000000 +0100
+@@ -25,8 +25,9 @@
+
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/print/ttf2pt1/files/patch-ft.c b/print/ttf2pt1/files/patch-ft.c
index 02c702492731..80140af7a608 100644
--- a/print/ttf2pt1/files/patch-ft.c
+++ b/print/ttf2pt1/files/patch-ft.c
@@ -1,12 +1,20 @@
---- ft.c.orig Sun Mar 21 18:24:06 2004
-+++ ft.c Sun Mar 21 18:24:31 2004
-@@ -12,7 +12,8 @@
+--- ft.c.orig 2003-12-31 22:30:50.000000000 +0100
++++ ft.c 2013-12-16 16:50:37.000000000 +0100
+@@ -12,11 +12,12 @@
#include <stdlib.h>
#include <ctype.h>
#include <sys/types.h>
-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftsnames.h>
+-#include <freetype/ttnameid.h>
+-#include <freetype/ftoutln.h>
+#include <ft2build.h>
+#include FT_FREETYPE_H
- #include <freetype/ftglyph.h>
- #include <freetype/ftsnames.h>
- #include <freetype/ttnameid.h>
++#include FT_GLYPH_H
++#include FT_SFNT_NAMES_H
++#include FT_TRUETYPE_IDS_H
++#include FT_OUTLINE_H
+ #include "pt1.h"
+ #include "global.h"
+