aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:32 +0000
commitbc77dd6e55d042ee29d1b5ed93308fa9fe275244 (patch)
tree433b68c50a1c71e98b96a24bbe537bc9109771b1 /print
parent10f2d2c572f6ef58759bbc0599f67402cc3bf6f1 (diff)
downloadports-bc77dd6e55d042ee29d1b5ed93308fa9fe275244.tar.gz
ports-bc77dd6e55d042ee29d1b5ed93308fa9fe275244.zip
print/py-pypdf3: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'print')
-rw-r--r--print/py-pypdf3/Makefile5
-rw-r--r--print/py-pypdf3/files/patch-setup.py11
2 files changed, 15 insertions, 1 deletions
diff --git a/print/py-pypdf3/Makefile b/print/py-pypdf3/Makefile
index 3dc58ab11256..b24b72a2a1e8 100644
--- a/print/py-pypdf3/Makefile
+++ b/print/py-pypdf3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pypdf3
PORTVERSION= 1.0.6
+PORTREVISION= 1
CATEGORIES= print python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +13,12 @@ WWW= https://github.com/sfneal/PyPDF3
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/print/py-pypdf3/files/patch-setup.py b/print/py-pypdf3/files/patch-setup.py
new file mode 100644
index 000000000000..4fc2bfc17249
--- /dev/null
+++ b/print/py-pypdf3/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2022-02-03 16:27:04 UTC
++++ setup.py
+@@ -30,7 +30,7 @@ setup(
+ raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE))
+
+ setup(
+- name="PyPDF3",
++ name="pypdf3",
+ version=verstr,
+ install_requires=['tqdm'],
+ description="Pure Python PDF toolkit",