aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:03:08 +0000
commitc7c32639cce504dbfefa9d1a09034d60600acaca (patch)
tree542278ecb4449b3df78960fd5f6cf7d8be50914f /print
parent42aab3eb75f5152697ee03e5e8457ce58906e2c1 (diff)
downloadports-c7c32639cce504dbfefa9d1a09034d60600acaca.tar.gz
ports-c7c32639cce504dbfefa9d1a09034d60600acaca.zip
Convert my ports to new options helpers
Notes
Notes: svn path=/head/; revision=395231
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile22
-rw-r--r--print/texvc/Makefile14
2 files changed, 13 insertions, 23 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 0238a6a5f8d4..a5b0db6ca80c 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -99,17 +99,11 @@ SCAN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
SCAN_CONFIGURE_ENABLE= scan-build
XSANE_DESC= Install XSane for scanning (requires SCAN)
+XSANE_IMPLIES= SCAN
+XSANE_RUN_DEPENDS= xsane:${PORTSDIR}/graphics/xsane
DOCS_CONFIGURE_ENABLE= doc-build
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSCAN}
-. if ${PORT_OPTIONS:MXSANE}
-RUN_DEPENDS+= xsane:${PORTSDIR}/graphics/xsane
-. endif
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|-ldld||g; s|-ldl||g' \
-e 's,-lusb-1.0,-lusb,g' \
@@ -139,20 +133,20 @@ post-patch:
-e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' \
-e 's,^#!/usr/bin/env python,#!${PYTHON_CMD},' \
-e 's,^#!/bin/env python,#!${PYTHON_CMD},'
-.if !${PORT_OPTIONS:MDOCS}
+
+post-patch-DOCS-off:
${REINPLACE_CMD} -e '/[[:space:]]install-docDATA/ s|install-docDATA||' \
${WRKSRC}/Makefile.in
-.endif
post-install:
-.if ${PORT_OPTIONS:MQT}
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/autostart
- ${INSTALL_DATA} ${WRKSRC}/hplip-systray.desktop ${STAGEDIR}${PREFIX}/etc/xdg/autostart/hplip-systray.desktop
-.endif
${MKDIR} ${STAGEDIR}${PREFIX}/etc/hp
${INSTALL_DATA} ${WRKSRC}/hplip.conf ${STAGEDIR}${PREFIX}/etc/hp/hplip.conf.sample
${LN} -sf ${LOCALBASE}/bin/foomatic-rip ${STAGEDIR}${PREFIX}/libexec/cups/filter/foomatic-rip-hplip
${MKDIR} ${STAGEDIR}${PREFIX}/share/cups/model
${LN} -sf ${LOCALBASE}/share/ppd/HP ${STAGEDIR}${PREFIX}/share/cups/model/hplip
+post-install-QT-on:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/autostart
+ ${INSTALL_DATA} ${WRKSRC}/hplip-systray.desktop ${STAGEDIR}${PREFIX}/etc/xdg/autostart/hplip-systray.desktop
+
.include <bsd.port.mk>
diff --git a/print/texvc/Makefile b/print/texvc/Makefile
index d205282aad47..73c1b7bf29b9 100644
--- a/print/texvc/Makefile
+++ b/print/texvc/Makefile
@@ -18,16 +18,12 @@ BUILD_WRKSRC= ${WRKSRC}/src
PLIST_FILES= bin/texvc
OPTIONS_DEFINE= RASTER
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-RASTER_DESC= rasterization support
-
-.include <bsd.port.options.mk>
+OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
-.if ${PORT_OPTIONS:MRASTER}
-USES+= ghostscript:run
-USE_TEX= latex dvipsk
-RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
-.endif
+RASTER_DESC= rasterization support
+RASTER_USES= ghostscript:run
+RASTER_USE= TEX=latex,dvipsk
+RASTER_RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/texvc ${STAGEDIR}${PREFIX}/bin