aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-11-04 13:42:42 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-11-04 13:42:42 +0000
commite357486dc79b2d69d6c57f43c27c9327238fe6cb (patch)
treeb4946ed832538113fb61a05ee74a8eb9b9296e83 /print
parentbd383db4a17396199cb4b5410bd5ee1191f43eaa (diff)
downloadports-e357486dc79b2d69d6c57f43c27c9327238fe6cb.tar.gz
ports-e357486dc79b2d69d6c57f43c27c9327238fe6cb.zip
Import of asprint port. asprint is a simple browser designed
to work with AfterStep that allows a user to select files to print. PR: 4331 Submitted by: Brett Taylor <brett@peloton.physics.montana.edu>
Notes
Notes: svn path=/head/; revision=8484
Diffstat (limited to 'print')
-rw-r--r--print/asprint/Makefile23
-rw-r--r--print/asprint/distinfo1
-rw-r--r--print/asprint/files/patch-aa37
-rw-r--r--print/asprint/files/patch-ab10
-rw-r--r--print/asprint/pkg-comment1
-rw-r--r--print/asprint/pkg-descr5
-rw-r--r--print/asprint/pkg-plist1
7 files changed, 78 insertions, 0 deletions
diff --git a/print/asprint/Makefile b/print/asprint/Makefile
new file mode 100644
index 000000000000..acb3d077abb3
--- /dev/null
+++ b/print/asprint/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: asmail
+# Version required: 1.0
+# Date created: 16 August 1997
+# Whom: brett@peloton.physics.montana.edu
+#
+# $Id$
+#
+
+DISTNAME= asprint
+PKGNAME= asprint-1.0
+CATEGORIES= print
+MASTER_SITES= ftp://afterstep.foo.net/pub/AfterStep/apps/asprint/
+
+MAINTAINER= brett@peloton.physics.montana.edu
+
+USE_X11= yes
+ALL_TARGET= asprint
+MAKEFILE= makefile
+
+do-install:
+ ${INSTALL_PROGRAM} $(WRKSRC)/asprint ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/print/asprint/distinfo b/print/asprint/distinfo
new file mode 100644
index 000000000000..8593ce58ec99
--- /dev/null
+++ b/print/asprint/distinfo
@@ -0,0 +1 @@
+MD5 (asprint.tar.gz) = 4b9248b1ba615fe61e3319b9ede23db0
diff --git a/print/asprint/files/patch-aa b/print/asprint/files/patch-aa
new file mode 100644
index 000000000000..50728293cc32
--- /dev/null
+++ b/print/asprint/files/patch-aa
@@ -0,0 +1,37 @@
+*** makefile Fri Mar 14 03:34:48 1997
+--- makefile Sat Aug 16 18:23:57 1997
+***************
+*** 2,18 ****
+
+ CFLAGS = -O2
+ CC = gcc
+! XLIB = -L/usr/X11/lib -lXaw3d -lXmu -lXt
+!
+ OBJS = asprint.o
+! INCS =
+!
+! default : asprint ./makefile
+! clean:
+! rm -f $(OBJS) *~ asprint core
+
+ asprint: $(OBJS)
+ $(CC) -o asprint $(CFLAGS) $(OBJS) $(XLIB)
+
+ .c.o:
+! $(CC) $(CFLAGS) -c $<
+--- 2,16 ----
+
+ CFLAGS = -O2
+ CC = gcc
+! XLIB = -L/usr/X11R6/lib -lXaw -lXmu -lXt
+ OBJS = asprint.o
+! INCS = -I/usr/X11R6/include
+
+ asprint: $(OBJS)
+ $(CC) -o asprint $(CFLAGS) $(OBJS) $(XLIB)
+
++ clean:
++ rm -f $(OBJS) *~ asprint core
++
+ .c.o:
+! $(CC) $(CFLAGS) -c $(INCS) $<
diff --git a/print/asprint/files/patch-ab b/print/asprint/files/patch-ab
new file mode 100644
index 000000000000..517ec2a3adc1
--- /dev/null
+++ b/print/asprint/files/patch-ab
@@ -0,0 +1,10 @@
+--- asprint.c~ Tue Mar 11 22:52:39 1997
++++ asprint.c Sat Aug 16 20:00:57 1997
+@@ -19,6 +19,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <sys/stat.h>
++#include <limits.h>
+ #include <dirent.h>
+ #include <unistd.h>
+
diff --git a/print/asprint/pkg-comment b/print/asprint/pkg-comment
new file mode 100644
index 000000000000..3b65bcd1b0be
--- /dev/null
+++ b/print/asprint/pkg-comment
@@ -0,0 +1 @@
+A simple browser to allow a user to print.
diff --git a/print/asprint/pkg-descr b/print/asprint/pkg-descr
new file mode 100644
index 000000000000..938cc6192a4c
--- /dev/null
+++ b/print/asprint/pkg-descr
@@ -0,0 +1,5 @@
+A simple browser to allow a user to print. It uses Athena widgets.
+The filter doesn't apply correctly however.
+
+-brett
+brett@peloton.physics.montana.edu
diff --git a/print/asprint/pkg-plist b/print/asprint/pkg-plist
new file mode 100644
index 000000000000..7ba869288beb
--- /dev/null
+++ b/print/asprint/pkg-plist
@@ -0,0 +1 @@
+bin/asprint