aboutsummaryrefslogtreecommitdiff
path: root/russian/d1489
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-29 17:55:04 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-29 17:55:04 +0000
commite000028a41f35bda6cdd8b98eab48dc94f46160e (patch)
tree84cd4cbd28f8c64c610d6453d5c47cd2594c1874 /russian/d1489
parentdccb050abdf55abfae215b3d2c2b415ec7dffb4a (diff)
downloadports-e000028a41f35bda6cdd8b98eab48dc94f46160e.tar.gz
ports-e000028a41f35bda6cdd8b98eab48dc94f46160e.zip
Support staging.
Notes
Notes: svn path=/head/; revision=328720
Diffstat (limited to 'russian/d1489')
-rw-r--r--russian/d1489/Makefile3
-rw-r--r--russian/d1489/files/patch-Makefile29
2 files changed, 30 insertions, 2 deletions
diff --git a/russian/d1489/Makefile b/russian/d1489/Makefile
index 8b849d3d9974..451f814ffc9d 100644
--- a/russian/d1489/Makefile
+++ b/russian/d1489/Makefile
@@ -10,8 +10,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Cp866<->koi8-r and cp1251<->koi8-r decoders, font converter (RFC1489)
-MAKE_ARGS= PREFIX=${PREFIX}
+MAKE_ARGS= PREFIX=${PREFIX} STAGEDIR=${STAGEDIR}
PLIST_FILES= bin/a2kfcnv bin/fromdos bin/todos bin/fromwin bin/towin
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/russian/d1489/files/patch-Makefile b/russian/d1489/files/patch-Makefile
new file mode 100644
index 000000000000..3740a1cd23a3
--- /dev/null
+++ b/russian/d1489/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2005-10-17 03:08:22.000000000 +0500
++++ Makefile 2013-09-29 21:42:45.000000000 +0400
+@@ -24,6 +24,7 @@
+ # SUCH DAMAGE.
+
+ PREFIX=/usr/local
++DISTDIR=${STAGEDIR}${PREFIX}
+ LOCAL_CFLAGS=-O
+ #LOCAL_CFLAGS=-O -DNO_RENAME
+ LOCAL_LDFLAGS=-s
+@@ -39,12 +40,12 @@ a2kfcnv: a2kfcnv.c koi82alt.h
+ a2kfcnv.c -o $@
+
+ install: todos a2kfcnv
+- cp todos ${PREFIX}/bin
+- -rm -f ${PREFIX}/bin/fromdos ${PREFIX}/bin/fromwin ${PREFIX}/bin/towin
+- ln ${PREFIX}/bin/todos ${PREFIX}/bin/fromdos
+- ln ${PREFIX}/bin/todos ${PREFIX}/bin/fromwin
+- ln ${PREFIX}/bin/todos ${PREFIX}/bin/towin
+- cp a2kfcnv ${PREFIX}/bin
++ cp todos ${DISTDIR}/bin
++ -rm -f ${DISTDIR}/bin/fromdos ${DISTDIR}/bin/fromwin ${DISTDIR}/bin/towin
++ ln -f ${PREFIX}/bin/todos ${DISTDIR}/bin/fromdos
++ ln -f ${PREFIX}/bin/todos ${DISTDIR}/bin/fromwin
++ ln -f ${PREFIX}/bin/todos ${DISTDIR}/bin/towin
++ cp a2kfcnv ${DISTDIR}/bin
+
+ clean:
+ -rm -f todos a2kfcnv