aboutsummaryrefslogtreecommitdiff
path: root/russian/wordpress
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-01-30 01:50:42 +0000
committerXin LI <delphij@FreeBSD.org>2013-01-30 01:50:42 +0000
commita107fbed69a03df163dbde0f7701ec889b010885 (patch)
tree9a3c97788ea989e94568aee73b46f83a61c0ae17 /russian/wordpress
parent62f582e043680e90b067a6f636bcaa30880847fe (diff)
downloadports-a107fbed69a03df163dbde0f7701ec889b010885.tar.gz
ports-a107fbed69a03df163dbde0f7701ec889b010885.zip
Update to 3.5.1. While I'm there, also change russian to use gzipped tarball,
make the port to use OptionsNG and fix installation permissions. PR: ports/175525 [1], ports/175632 [2], ports/175679 [3] Submitted by: Takefu <takefu airport fm> [1], Mihail Timofeev <miha_hard mail ru> [2], delphij [3] Approved by: maintainer, 9267096@gmail.com [1][2], ychsiao [1][3] Security: 559e00b7-6a4d-11e2-b6b0-10bf48230856
Notes
Notes: svn path=/head/; revision=311195
Diffstat (limited to 'russian/wordpress')
-rw-r--r--russian/wordpress/Makefile19
-rw-r--r--russian/wordpress/distinfo4
-rw-r--r--russian/wordpress/files/pkg-install.in12
3 files changed, 27 insertions, 8 deletions
diff --git a/russian/wordpress/Makefile b/russian/wordpress/Makefile
index 112840176f1a..9c89bb926f12 100644
--- a/russian/wordpress/Makefile
+++ b/russian/wordpress/Makefile
@@ -2,27 +2,31 @@
# $FreeBSD$
PORTNAME= wordpress
-PORTVERSION= 3.5
+PORTVERSION= 3.5.1
CATEGORIES= russian www
MASTER_SITES= http://ru.wordpress.org/
DISTNAME= ${PORTNAME}-${PORTVERSION}-ru_RU
MAINTAINER= 9267096@gmail.com
-COMMENT= State-of-the-art semantic personal publishing platform
+COMMENT= A state-of-the-art semantic personal publishing platform
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
CONFLICTS_INSTALL= wordpress-3.* de-wordpress-3.* ja-wordpress-3.*
NO_BUILD= yes
-USE_ZIP= yes
USE_PHP= curl gd mysql pcre tokenizer xml zip
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= pkg-message pkg-install
+SUB_LIST= CHGRP="${CHGRP}" CHOWN="${CHOWN}" CHMOD="${CHMOD}"\
+ FIND="${FIND}" WWWGRP="${WWWGRP}" WWWOWN="${WWWOWN}"
PLIST= ${WRKDIR}/pkg-plist
-PORTDOCS= readme.html
-SUB_FILES= pkg-message
+PORTDOCS= license.txt readme.html
+
+OPTIONS_DEFINE= DOCS
pre-everything::
@${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
@@ -36,15 +40,18 @@ pre-install:
if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
${CP} -R ${WRKSRC}/ ${WWWDIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/russian/wordpress/distinfo b/russian/wordpress/distinfo
index fe7da5800215..96ae43d46b0e 100644
--- a/russian/wordpress/distinfo
+++ b/russian/wordpress/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wordpress-3.5-ru_RU.zip) = 850d56fee6cdd45c765d627d41df7c8b318470bebbb7b07a722ee7eb4d53cf21
-SIZE (wordpress-3.5-ru_RU.zip) = 6664495
+SHA256 (wordpress-3.5.1-ru_RU.tar.gz) = 4e233d270fbadcaa9ab68e8fe26df7864b03194e5f6dd4a9860d7d872628b4c7
+SIZE (wordpress-3.5.1-ru_RU.tar.gz) = 6185231
diff --git a/russian/wordpress/files/pkg-install.in b/russian/wordpress/files/pkg-install.in
new file mode 100644
index 000000000000..4c547cb9144a
--- /dev/null
+++ b/russian/wordpress/files/pkg-install.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+case $2 in
+ PRE-INSTALL)
+ ;;
+ POST-INSTALL)
+ %%CHOWN%% -R %%WWWOWN%% %%WWWDIR%%/wp-content
+ %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHGRP%% %%WWWGRP%%
+ %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHMOD%% g+w
+ ;;
+ *)
+ ;;
+esac \ No newline at end of file