aboutsummaryrefslogtreecommitdiff
path: root/science/axom/pkg-plist
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-21 10:10:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-21 10:11:41 +0000
commitd3f13fc91cf0c08177b8a1731b053be89145b39a (patch)
tree64247407694bf040034bb6de801c9307d41bb14f /science/axom/pkg-plist
parentd8192011d116bb00611928ec51ee64bad8414f76 (diff)
downloadports-d3f13fc91cf0c08177b8a1731b053be89145b39a.tar.gz
ports-d3f13fc91cf0c08177b8a1731b053be89145b39a.zip
science/axom: Add options LUA MFEM MPI OPENMP; Simplify tests
Diffstat (limited to 'science/axom/pkg-plist')
-rw-r--r--science/axom/pkg-plist23
1 files changed, 23 insertions, 0 deletions
diff --git a/science/axom/pkg-plist b/science/axom/pkg-plist
index 00f1e37e0cde..0e65c4994e67 100644
--- a/science/axom/pkg-plist
+++ b/science/axom/pkg-plist
@@ -1,3 +1,5 @@
+%%MPI%%bin/convert_sidre_protocol
+%%MFEM%%bin/data_collection_util
bin/mesh_tester
include/axom/CLI11.hpp
include/axom/config.hpp
@@ -65,6 +67,7 @@ include/axom/inlet/Inlet.hpp
include/axom/inlet/InletVector.hpp
include/axom/inlet/JSONReader.hpp
include/axom/inlet/JSONSchemaWriter.hpp
+%%LUA%%include/axom/inlet/LuaReader.hpp
include/axom/inlet/Proxy.hpp
include/axom/inlet/Reader.hpp
include/axom/inlet/SphinxWriter.hpp
@@ -83,6 +86,15 @@ include/axom/klee/KleeError.hpp
include/axom/klee/Shape.hpp
include/axom/klee/ShapeSet.hpp
include/axom/klee/Units.hpp
+%%MPI%%include/axom/lumberjack.hpp
+%%MPI%%include/axom/lumberjack/BinaryTreeCommunicator.hpp
+%%MPI%%include/axom/lumberjack/Combiner.hpp
+%%MPI%%include/axom/lumberjack/Communicator.hpp
+%%MPI%%include/axom/lumberjack/Lumberjack.hpp
+%%MPI%%include/axom/lumberjack/MPIUtility.hpp
+%%MPI%%include/axom/lumberjack/Message.hpp
+%%MPI%%include/axom/lumberjack/RootCommunicator.hpp
+%%MPI%%include/axom/lumberjack/TextEqualityCombiner.hpp
include/axom/mint.hpp
include/axom/mint/config.hpp
include/axom/mint/deprecated/MCArray.hpp
@@ -169,8 +181,11 @@ include/axom/quest.hpp
include/axom/quest/AllNearestNeighbors.hpp
include/axom/quest/Discretize.hpp
include/axom/quest/InOutOctree.hpp
+%%MFEM%%include/axom/quest/IntersectionShaper.hpp
include/axom/quest/MeshTester.hpp
include/axom/quest/PointInCell.hpp
+%%MFEM%%include/axom/quest/SamplingShaper.hpp
+%%MFEM%%include/axom/quest/Shaper.hpp
include/axom/quest/SignedDistance.hpp
include/axom/quest/detail/AllNearestNeighbors_detail.hpp
include/axom/quest/detail/Discretize_detail.hpp
@@ -181,10 +196,12 @@ include/axom/quest/detail/inout/InOutOctreeMeshDumper.hpp
include/axom/quest/detail/inout/InOutOctreeStats.hpp
include/axom/quest/detail/inout/InOutOctreeValidator.hpp
include/axom/quest/detail/inout/MeshWrapper.hpp
+%%MFEM%%include/axom/quest/detail/shaping/shaping_helpers.hpp
include/axom/quest/interface/inout.hpp
include/axom/quest/interface/internal/QuestHelpers.hpp
include/axom/quest/interface/internal/mpicomm_wrapper.hpp
include/axom/quest/interface/signed_distance.hpp
+%%MPI%%include/axom/quest/readers/PSTLReader.hpp
include/axom/quest/readers/STLReader.hpp
include/axom/sidre.hpp
include/axom/sidre/core/Array.hpp
@@ -196,11 +213,14 @@ include/axom/sidre/core/Group.hpp
include/axom/sidre/core/ItemCollection.hpp
include/axom/sidre/core/Iterator.hpp
include/axom/sidre/core/ListCollection.hpp
+%%MFEM%%include/axom/sidre/core/MFEMSidreDataCollection.hpp
include/axom/sidre/core/MapCollection.hpp
include/axom/sidre/core/SidreDataTypeIds.h
include/axom/sidre/core/SidreTypes.hpp
include/axom/sidre/core/View.hpp
include/axom/sidre/core/sidre.hpp
+%%MPI%%include/axom/sidre/spio/IOBaton.hpp
+%%MPI%%include/axom/sidre/spio/IOManager.hpp
include/axom/slam.hpp
include/axom/slam/BitSet.hpp
include/axom/slam/BivariateMap.hpp
@@ -241,6 +261,9 @@ include/axom/slic/interface/slic.hpp
include/axom/slic/interface/slic_macros.hpp
include/axom/slic/internal/stacktrace.hpp
include/axom/slic/streams/GenericOutputStream.hpp
+%%MPI%%include/axom/slic/streams/LumberjackStream.hpp
+%%MPI%%include/axom/slic/streams/SynchronizedStream.hpp
+%%LUA%%include/axom/sol.hpp
include/axom/sparsehash/README
include/axom/sparsehash/dense_hash_map
include/axom/sparsehash/dense_hash_set