aboutsummaryrefslogtreecommitdiff
path: root/science/cdo
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-06-29 01:03:28 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-06-29 01:03:28 +0000
commit0287c477296ee65c52b422c55070da3e0baa5abc (patch)
treebb3fe47176d98490743a7ad692fa214bfea016b8 /science/cdo
parentcacc031ebcd27d12b515be6a1a965904b3932ae2 (diff)
downloadports-0287c477296ee65c52b422c55070da3e0baa5abc.tar.gz
ports-0287c477296ee65c52b422c55070da3e0baa5abc.zip
- Update to 1.0.8
PR: ports/114104 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet AT sunpoet.net> (maintainer)
Notes
Notes: svn path=/head/; revision=194423
Diffstat (limited to 'science/cdo')
-rw-r--r--science/cdo/Makefile2
-rw-r--r--science/cdo/distinfo6
-rw-r--r--science/cdo/files/patch-src-cdo_pthread.c2
-rw-r--r--science/cdo/files/patch-src-config.h.in4
-rw-r--r--science/cdo/files/patch-src-pthread_debug.c10
-rw-r--r--science/cdo/files/patch-src-pthread_debug.h2
6 files changed, 13 insertions, 13 deletions
diff --git a/science/cdo/Makefile b/science/cdo/Makefile
index 4ad4f7db0c2d..fd4ab1e8ab83 100644
--- a/science/cdo/Makefile
+++ b/science/cdo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= cdo
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.8
CATEGORIES= science
MASTER_SITES= http://www.mpimet.mpg.de/fileadmin/software/cdo/ \
http://sunpoet.net/distfiles/
diff --git a/science/cdo/distinfo b/science/cdo/distinfo
index 933c52e1da39..c5bfe8b54e85 100644
--- a/science/cdo/distinfo
+++ b/science/cdo/distinfo
@@ -1,3 +1,3 @@
-MD5 (cdo-1.0.7.tar.gz) = ee087cbd434f3bacc7b4154300f2cffe
-SHA256 (cdo-1.0.7.tar.gz) = 9aee78fcd0fc500b64e527bee10dea9b9bb607832e0bf40db50685f370ab9d58
-SIZE (cdo-1.0.7.tar.gz) = 2315855
+MD5 (cdo-1.0.8.tar.gz) = 7d6a10374ee844df5882a8c9b3c16feb
+SHA256 (cdo-1.0.8.tar.gz) = 5796a6639f128b3d255cdd65dbfeb91a66c5478a37b7e05bc2d8f9573480a6b4
+SIZE (cdo-1.0.8.tar.gz) = 2372654
diff --git a/science/cdo/files/patch-src-cdo_pthread.c b/science/cdo/files/patch-src-cdo_pthread.c
index 1a5c03102069..f19dfa3ab61e 100644
--- a/science/cdo/files/patch-src-cdo_pthread.c
+++ b/science/cdo/files/patch-src-cdo_pthread.c
@@ -1,5 +1,5 @@
--- src/cdo_pthread.c.orig Wed Mar 22 22:04:18 2006
-+++ src/cdo_pthread.c Sat Apr 7 01:07:02 2007
++++ src/cdo_pthread.c Fri Jun 29 00:18:34 2007
@@ -32,8 +32,10 @@
{
#if defined (HAVE_LIBPTHREAD)
diff --git a/science/cdo/files/patch-src-config.h.in b/science/cdo/files/patch-src-config.h.in
index b4787e08098e..99883663e4c3 100644
--- a/science/cdo/files/patch-src-config.h.in
+++ b/science/cdo/files/patch-src-config.h.in
@@ -1,5 +1,5 @@
---- src/config.h.in.orig Tue Dec 19 19:07:07 2006
-+++ src/config.h.in Sat Apr 7 04:00:39 2007
+--- src/config.h.in.orig Wed Apr 18 16:24:45 2007
++++ src/config.h.in Fri Jun 29 00:18:34 2007
@@ -107,3 +107,7 @@
/* Define for large files, on AIX-style hosts. */
diff --git a/science/cdo/files/patch-src-pthread_debug.c b/science/cdo/files/patch-src-pthread_debug.c
index 9aa0ad43b02f..73561eaedd61 100644
--- a/science/cdo/files/patch-src-pthread_debug.c
+++ b/science/cdo/files/patch-src-pthread_debug.c
@@ -1,5 +1,5 @@
---- src/pthread_debug.c.orig Mon Dec 4 16:11:40 2006
-+++ src/pthread_debug.c Sat Apr 7 01:12:05 2007
+--- src/pthread_debug.c.orig Mon May 14 14:30:15 2007
++++ src/pthread_debug.c Fri Jun 29 00:24:12 2007
@@ -77,6 +77,7 @@
}
@@ -7,9 +7,9 @@
+#if defined (PTHREAD_MUTEXATTR_CONDATTR)
void print_pthread_mutexattr(const char *caller, pthread_mutexattr_t *m_attr)
{
- int protocol, kind, pshared;
-@@ -107,6 +108,7 @@
- POUT2(caller, pshared, PTHREAD_PROCESS_SHARED, PTHREAD_PROCESS_PRIVATE);
+ #if defined (_POSIX_THREAD_PRIO_PROTECT) && defined (_POSIX_THREAD_PRIO_INHERIT)
+@@ -115,6 +116,7 @@
+ }
#endif
}
+#endif
diff --git a/science/cdo/files/patch-src-pthread_debug.h b/science/cdo/files/patch-src-pthread_debug.h
index c94e750bcc1f..94cfd2e67089 100644
--- a/science/cdo/files/patch-src-pthread_debug.h
+++ b/science/cdo/files/patch-src-pthread_debug.h
@@ -1,5 +1,5 @@
--- src/pthread_debug.h.orig Wed Feb 15 21:22:38 2006
-+++ src/pthread_debug.h Sat Apr 7 01:13:25 2007
++++ src/pthread_debug.h Fri Jun 29 00:18:34 2007
@@ -15,8 +15,10 @@
void Pthread_cond_wait(const char *caller, pthread_cond_t *cond, pthread_mutex_t *mutex);