aboutsummaryrefslogtreecommitdiff
path: root/science/dlpoly-classic
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-04-17 17:35:33 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-04-17 17:35:33 +0000
commit02c3ca4376ef3c3aa56b22e46ff0bdb0017d7561 (patch)
tree0d2f17ab4aaec9e7706a0583584f581832cf4843 /science/dlpoly-classic
parente2ad52a7858344e7d8c2820dbd6ffb5437fbfcc3 (diff)
downloadports-02c3ca4376ef3c3aa56b22e46ff0bdb0017d7561.tar.gz
ports-02c3ca4376ef3c3aa56b22e46ff0bdb0017d7561.zip
DL_POLY is a general purpose classical molecular dynamics (MD) simulation
software developed at Daresbury Laboratory by I.T. Todorov and W. Smith. WWW: http://ccpforge.cse.rl.ac.uk/gf/project/dl_poly_classic/ PR: ports/166725 Submitted by: Jason Bacon <jwbacon@tds.net>
Notes
Notes: svn path=/head/; revision=294961
Diffstat (limited to 'science/dlpoly-classic')
-rw-r--r--science/dlpoly-classic/Makefile82
-rw-r--r--science/dlpoly-classic/distinfo2
-rw-r--r--science/dlpoly-classic/files/dlpoly-gui.in9
-rw-r--r--science/dlpoly-classic/pkg-descr4
-rw-r--r--science/dlpoly-classic/pkg-message12
-rw-r--r--science/dlpoly-classic/pkg-plist14
6 files changed, 123 insertions, 0 deletions
diff --git a/science/dlpoly-classic/Makefile b/science/dlpoly-classic/Makefile
new file mode 100644
index 000000000000..9b97af950a43
--- /dev/null
+++ b/science/dlpoly-classic/Makefile
@@ -0,0 +1,82 @@
+############################################################################
+# New ports collection Makefile for: dlpoly-classic
+# Date created: 21 Jan 2010
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+############################################################################
+
+PORTNAME= dlpoly
+PORTVERSION= 1.8
+CATEGORIES= science java
+MASTER_SITES= http://ccpforge.cse.rl.ac.uk/gf/download/frsrelease/238/2028/
+PKGNAMESUFFIX= classic
+DISTNAME= dl_class_${PORTVERSION}
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Molecular dynamics simulation package
+
+BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpif90:${PORTSDIR}/net/openmpi
+RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+
+OPTIONS= GUI "Install Java GUI" on
+
+USE_GMAKE= yes
+USE_FORTRAN= yes
+
+SUB_FILES= dlpoly-gui
+
+BUILD_WRKSRC= ${WRKSRC}/source
+
+MPIF90= ${LOCALBASE}/mpi/openmpi/bin/mpif90
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GUI)
+USE_JAVA= yes
+PLIST_FILES+= bin/dlpoly-gui \
+ ${DATADIR_REL}/GUI.jar
+PLIST_DIRS+= ${DATADIR_REL}
+.endif
+
+post-patch:
+ ${CP} ${WRKSRC}/build/MakePAR ${WRKSRC}/build/MakeSEQ ${BUILD_WRKSRC}
+ ${REINPLACE_CMD} 's|gfortran|${FC}|g' ${BUILD_WRKSRC}/MakeSEQ
+ ${REINPLACE_CMD} 's|DLPOLY\.X|dlpoly-classic|g' ${BUILD_WRKSRC}/MakeSEQ
+ ${REINPLACE_CMD} 's|mpif90|${MPIF90}|g' \
+ ${BUILD_WRKSRC}/MakePAR
+ ${REINPLACE_CMD} 's|DLPOLY\.X|dlpoly-classic-mpi|g' \
+ ${BUILD_WRKSRC}/MakePAR
+
+do-build:
+ (cd ${BUILD_WRKSRC} && \
+ ${CP} -f MakeSEQ Makefile && \
+ ${MAKE} ${FC})
+ (cd ${BUILD_WRKSRC} && \
+ ${MAKE} clean && \
+ ${CP} -f MakePAR Makefile && \
+ ${MAKE} gfortran)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/execute/dlpoly-classic ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/execute/dlpoly-classic-mpi ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manual/* ${DOCSDIR}
+.endif
+.ifndef(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/execute ${EXAMPLESDIR}
+ ${RM} ${EXAMPLESDIR}/execute/dlpoly*
+.endif
+.if defined(WITH_GUI)
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/java/GUI.jar ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/dlpoly-gui ${PREFIX}/bin
+.endif
+
+post-install:
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>
diff --git a/science/dlpoly-classic/distinfo b/science/dlpoly-classic/distinfo
new file mode 100644
index 000000000000..b3c2627eccc3
--- /dev/null
+++ b/science/dlpoly-classic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dl_class_1.8.tar.gz) = 4ee7e7ded64dd659ddccca6e26326045ce8f49b59217dcbb404363e5a5daf3d5
+SIZE (dl_class_1.8.tar.gz) = 2769075
diff --git a/science/dlpoly-classic/files/dlpoly-gui.in b/science/dlpoly-classic/files/dlpoly-gui.in
new file mode 100644
index 000000000000..3abdfa7c3472
--- /dev/null
+++ b/science/dlpoly-classic/files/dlpoly-gui.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ $# != 1 ]; then
+ printf "Usage: $0 file\n"
+ exit 1
+fi
+
+java -jar %%DATADIR%%/GUI.jar
+
diff --git a/science/dlpoly-classic/pkg-descr b/science/dlpoly-classic/pkg-descr
new file mode 100644
index 000000000000..18afcab28912
--- /dev/null
+++ b/science/dlpoly-classic/pkg-descr
@@ -0,0 +1,4 @@
+DL_POLY is a general purpose classical molecular dynamics (MD) simulation
+software developed at Daresbury Laboratory by I.T. Todorov and W. Smith.
+
+WWW: http://ccpforge.cse.rl.ac.uk/gf/project/dl_poly_classic/
diff --git a/science/dlpoly-classic/pkg-message b/science/dlpoly-classic/pkg-message
new file mode 100644
index 000000000000..bc238819dd10
--- /dev/null
+++ b/science/dlpoly-classic/pkg-message
@@ -0,0 +1,12 @@
+------------------------------------------------------------------------------
+This port provides both serial and parallel (MPI) binaries. Use of
+the MPI binary is strongly recommended on any machine with multiple
+cores available. The serial binary is provided only for testing and
+very small models.
+
+To run a model on a workstation using 4 cores, use:
+
+ mpirun -n 4 dlpoly-classic-mpi
+
+To run on a cluster, please see the documentation for your scheduler software.
+------------------------------------------------------------------------------
diff --git a/science/dlpoly-classic/pkg-plist b/science/dlpoly-classic/pkg-plist
new file mode 100644
index 000000000000..3846f9bfb768
--- /dev/null
+++ b/science/dlpoly-classic/pkg-plist
@@ -0,0 +1,14 @@
+bin/dlpoly-classic
+bin/dlpoly-classic-mpi
+%%PORTDOCS%%%%DOCSDIR%%/USRMAN.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/cleanup
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/copy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/gopoly
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/gui
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/select
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/store
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/execute/supa
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/execute
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%