aboutsummaryrefslogtreecommitdiff
path: root/science/erkale
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2020-01-21 22:03:19 +0000
committerSteve Wills <swills@FreeBSD.org>2020-01-21 22:03:19 +0000
commit033b9daecd27faf93fa20a1d0ecfcf37094800d8 (patch)
treefea95fa876ec763af039c730a5e75b867dd3aae2 /science/erkale
parent68eac340c54e4593ee7c6167944a632bc3c47900 (diff)
downloadports-033b9daecd27faf93fa20a1d0ecfcf37094800d8.tar.gz
ports-033b9daecd27faf93fa20a1d0ecfcf37094800d8.zip
math/openblas: Update to 0.3.7
While here, improve formatting and fix build of dependant ports. PR: 231371 Submitted by: yuri (initial version), pkubaj (ppc fixes) Approved by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=523749
Diffstat (limited to 'science/erkale')
-rw-r--r--science/erkale/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/science/erkale/Makefile b/science/erkale/Makefile
index 401f1ca66c55..844b8de1038c 100644
--- a/science/erkale/Makefile
+++ b/science/erkale/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libderiv.so:science/libint \
libgsl.so:math/gsl \
libhdf5.so:science/hdf5 \
libint.so:science/libint \
- libopenblas.so:math/openblas \
libsz.so:science/szip \
libxc.so:science/libxc
RUN_DEPENDS= ${LOCALBASE}/share/erkale/basis/6-21G.gbs:science/erkale-pseudopotentials
@@ -49,7 +48,7 @@ LIB_DEPENDS+= libomp.so:devel/llvm${LLVM_DEFAULT}
OPTIONS_SINGLE= LINALG
OPTIONS_SINGLE_LINALG= NETLIB OPENBLAS
-OPTIONS_DEFAULT= NETLIB
+OPTIONS_DEFAULT= OPENBLAS
LINALG_DESC= Linear algebra library
NETLIB_USES= blaslapack:netlib
@@ -58,8 +57,8 @@ NETLIB_LDFLAGS= ${LOCALBASE}/lib/libcblas.so ${LOCALBASE}/lib/liblapack.so ${LO
NETLIB_LIB_DEPENDS= libcblas.so:math/cblas
OPENBLAS_USES= blaslapack:openblas
-OPENBLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=-lopenblas -DBLAS_LIBRARIES:STRING=-lopenblasp
-OPENBLAS_BROKEN= hits the number of threads limit: https://github.com/xianyi/OpenBLAS/issues/1882
+OPENBLAS_CMAKE_ON= -DLAPACK_LIBRARIES:STRING=-lopenblas -DBLAS_LIBRARIES:STRING=-lopenblas
+OPENBLAS_LIB_DEPENDS= libopenblas.so:math/openblas
# use clang from ports because cmake can't find OpenMP with base clang, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=223678
# have the same compiler for both serial and parallel flavors so that performance numbers can be compared