aboutsummaryrefslogtreecommitdiff
path: root/science/kst2
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2006-04-30 12:00:13 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2006-04-30 12:00:13 +0000
commitfdd1538a7b54ae17bbed6d63febbf87797a3a0ef (patch)
tree62195477b0624420119c943a1a7e0fc2166e25c9 /science/kst2
parent2664912cd157ad2e1ebd20fbe131314c205e50ec (diff)
downloadports-fdd1538a7b54ae17bbed6d63febbf87797a3a0ef.tar.gz
ports-fdd1538a7b54ae17bbed6d63febbf87797a3a0ef.zip
Fix build on 4.x
Reported by: kris
Notes
Notes: svn path=/head/; revision=160898
Diffstat (limited to 'science/kst2')
-rw-r--r--science/kst2/Makefile5
-rw-r--r--science/kst2/files/patch-kst-kst-datasources-dirfile-getdata.c12
-rw-r--r--science/kst2/files/patch-kst-kst-kst.cpp11
3 files changed, 28 insertions, 0 deletions
diff --git a/science/kst2/Makefile b/science/kst2/Makefile
index 4966b7ef7436..99e00a98d487 100644
--- a/science/kst2/Makefile
+++ b/science/kst2/Makefile
@@ -30,6 +30,10 @@ MAN1= kst.1
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.endif
+
.if defined(WITH_NETCDF)
LIB_DEPENDS+= netcdf.1:${PORTSDIR}/science/netcdf
PLIST_SUB+= NETCDF=""
@@ -47,6 +51,7 @@ PLIST_SUB+= CDF="@comment "
.endif
post-patch:
+ @${TOUCH} ${WRKSRC}/kst/kst/ksttimers.h.in
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.if !defined(WITH_NETCDF)
@${REINPLACE_CMD} -e 's| netcdf||g' ${WRKSRC}/kst/kst/datasources/Makefile.in
diff --git a/science/kst2/files/patch-kst-kst-datasources-dirfile-getdata.c b/science/kst2/files/patch-kst-kst-datasources-dirfile-getdata.c
new file mode 100644
index 000000000000..e3dffccfd0d4
--- /dev/null
+++ b/science/kst2/files/patch-kst-kst-datasources-dirfile-getdata.c
@@ -0,0 +1,12 @@
+--- kst/kst/datasources/dirfile/getdata.c.orig Sun Apr 30 01:25:45 2006
++++ kst/kst/datasources/dirfile/getdata.c Sun Apr 30 01:45:10 2006
+@@ -1012,8 +1012,8 @@
+ /* */
+ /***************************************************************************/
+ static void *AllocTmpbuff(char type, int n) {
+- assert(n > 0);
+ void *buff=NULL;
++ assert(n > 0);
+ switch(type) {
+ case 'n':
+ buff = NULL;
diff --git a/science/kst2/files/patch-kst-kst-kst.cpp b/science/kst2/files/patch-kst-kst-kst.cpp
new file mode 100644
index 000000000000..fef9fc05c7f4
--- /dev/null
+++ b/science/kst2/files/patch-kst-kst-kst.cpp
@@ -0,0 +1,11 @@
+--- kst/kst/kst.cpp.orig Sun Apr 30 00:32:11 2006
++++ kst/kst/kst.cpp Sun Apr 30 00:40:06 2006
+@@ -1489,7 +1489,7 @@
+ bool firstPage = true;
+ while (it->currentItem()) {
+ KstViewWindow *win = dynamic_cast<KstViewWindow*>(it->currentItem());
+- KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : 0L;
++ KstTopLevelViewPtr tlv = win ? kst_cast<KstTopLevelView>(win->view()) : static_cast<KstTopLevelViewPtr>(0L);
+ if (win && tlv && !tlv->children().isEmpty()) {
+ ++pages;
+ #if KDE_VERSION < KDE_MAKE_VERSION(3,3,0)