aboutsummaryrefslogtreecommitdiff
path: root/science/libsvm
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-12-22 15:48:54 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-12-22 15:48:54 +0000
commit22c7ef8f29cba323587dda68f83cc9259efb8cb2 (patch)
treeadaa551bbac7a199617f41cc675b8332344beaef /science/libsvm
parentdc9707d19cbf969f198804aadb2d97ff317fa5b9 (diff)
downloadports-22c7ef8f29cba323587dda68f83cc9259efb8cb2.tar.gz
ports-22c7ef8f29cba323587dda68f83cc9259efb8cb2.zip
- Add OCFLAGS to make CFLAGS the same as distribution's by default
(this is preferable by the authors).
Notes
Notes: svn path=/head/; revision=224574
Diffstat (limited to 'science/libsvm')
-rw-r--r--science/libsvm/Makefile7
-rw-r--r--science/libsvm/files/patch-Makefile9
2 files changed, 7 insertions, 9 deletions
diff --git a/science/libsvm/Makefile b/science/libsvm/Makefile
index 7449f051d9ab..038927ad0159 100644
--- a/science/libsvm/Makefile
+++ b/science/libsvm/Makefile
@@ -15,6 +15,8 @@ MASTER_SITES= http://www.csie.ntu.edu.tw/~cjlin/libsvm/ \
MAINTAINER= rafan@FreeBSD.org
COMMENT= A library for Support Vector Machines
+OPTIONS= OCFLAGS "Use optimized CFLAGS" On
+
USE_ZIP= yes
.if defined(PKGNAMESUFFIX) && ${PKGNAMESUFFIX} == "-python"
@@ -48,6 +50,11 @@ PORTDOCS= ${TXT_DOCS}
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_OCFLAGS)
+# same as LIBSVM itself
+CFLAGS= -Wall -Wconversion -O3
+.endif
+
post-patch:
post-extract:
diff --git a/science/libsvm/files/patch-Makefile b/science/libsvm/files/patch-Makefile
deleted file mode 100644
index 7156305752f2..000000000000
--- a/science/libsvm/files/patch-Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile.orig 2008-12-22 23:43:29.000000000 +0800
-+++ Makefile 2008-12-22 23:43:58.000000000 +0800
-@@ -1,5 +1,5 @@
- CXX? = g++
--CFLAGS = -Wall -Wconversion -O3 -fPIC
-+CFLAGS += -Wall -Wconversion -O3 -fPIC
- SHVER = 1
-
- all: svm-train svm-predict svm-scale