aboutsummaryrefslogtreecommitdiff
path: root/science/massxpert/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /science/massxpert/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'science/massxpert/Makefile')
-rw-r--r--science/massxpert/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/massxpert/Makefile b/science/massxpert/Makefile
index 345abc87ec97..724310556be0 100644
--- a/science/massxpert/Makefile
+++ b/science/massxpert/Makefile
@@ -20,10 +20,10 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
libfontconfig.so:x11-fonts/fontconfig
USE_GCC= any
-USES= cmake gettext tar:bzip2
+USES= cmake gettext qt:4 tar:bzip2
USE_XORG= ice sm x11 xau xcb xdmcp xext xrender
USE_GNOME= glib20
-USE_QT4= corelib gui xml rcc_build qmake_build uic_build moc_build \
+USE_QT= corelib gui xml rcc_build qmake_build uic_build moc_build \
svg
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes