aboutsummaryrefslogtreecommitdiff
path: root/science/mcstas
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-12-05 17:32:37 +0000
committerSteve Wills <swills@FreeBSD.org>2017-12-05 17:32:37 +0000
commitef7b06f26ce13b39d4ed5cd1c6e2c44d1257ec91 (patch)
treef66b86dc772dadb8d9943874a1f0411c9a8b6900 /science/mcstas
parent32c76c47d86ae2396395ea65ac85ee66d3cfdc33 (diff)
downloadports-ef7b06f26ce13b39d4ed5cd1c6e2c44d1257ec91.tar.gz
ports-ef7b06f26ce13b39d4ed5cd1c6e2c44d1257ec91.zip
science/mcstas: simplify Makefile
While here, remove unecessary pkg-install/deinstall PR: 223905 Submitted by: Erik B Knudsen <erkn@fysik.dtu.dk> (maintainer)
Notes
Notes: svn path=/head/; revision=455594
Diffstat (limited to 'science/mcstas')
-rw-r--r--science/mcstas/Makefile23
-rw-r--r--science/mcstas/distinfo1
-rw-r--r--science/mcstas/files/pkg-deinstall.in24
-rw-r--r--science/mcstas/files/pkg-install.in29
-rw-r--r--science/mcstas/pkg-plist122
5 files changed, 76 insertions, 123 deletions
diff --git a/science/mcstas/Makefile b/science/mcstas/Makefile
index af196074366b..77aa8c9c5f09 100644
--- a/science/mcstas/Makefile
+++ b/science/mcstas/Makefile
@@ -1,25 +1,28 @@
-# Created by: Erik B Knudsen <erkn@fysik.dtu.dk>
# $FreeBSD$
PORTNAME= mcstas
-PORTVERSION= 2.2a
+DISTVERSION= 2.2a
CATEGORIES= science
-MASTER_SITES= http://download.mcstas.org/${PORTNAME}-${PORTVERSION}/unix/McStas-${PORTVERSION}-UNIX-src/
-DISTNAME= mcstas-${PORTVERSION}-src
+MASTER_SITES= http://download.mcstas.org/${PORTNAME}-${DISTVERSION}/unix/McStas-${DISTVERSION}-UNIX-src/
+DISTNAME= mcstas-${DISTVERSION}-src
MAINTAINER= erkn@fysik.dtu.dk
COMMENT= Monte Carlo neutron ray tracing package
-LICENSE= GPLv2
+LICENSE= LGPL21+
-USES= bison:build cmake
+USES= bison:build cmake:outsource
CMAKE_ARGS= "-Denable_mcstas=1"
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-SUB_FILES= pkg-deinstall pkg-install
+MANDIRS= ${PREFIX}/${PORTNAME}/${DISTVERSION}/doc/man/man1
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
+
+MCEXECS= mcstas mcformat
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/${PORTVERSION}/bin/mcformat
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/mcstas/${PORTVERSION}/bin/mcstas
+.for e in ${MCEXECS}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${PORTNAME}/${DISTVERSION}/bin/${e}
+ ${LN} -s ${PREFIX}/${PORTNAME}/${DISTVERSION}/bin/${e} ${STAGEDIR}${PREFIX}/bin/${e}
+.endfor
.include <bsd.port.mk>
diff --git a/science/mcstas/distinfo b/science/mcstas/distinfo
index 543b860af46b..759882bb2324 100644
--- a/science/mcstas/distinfo
+++ b/science/mcstas/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1511649139
SHA256 (mcstas-2.2a-src.tar.gz) = 7f8cca7ceea87e4b99c17ee16e4f1e6fd89712d2de1ba61ab97a2cd7ea0f8b9d
SIZE (mcstas-2.2a-src.tar.gz) = 347943
diff --git a/science/mcstas/files/pkg-deinstall.in b/science/mcstas/files/pkg-deinstall.in
deleted file mode 100644
index 47d2ae9a5a9c..000000000000
--- a/science/mcstas/files/pkg-deinstall.in
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-PKG_PREFIX=${PKG_PREFIX:-%%PREFIX%%}
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
-fi
-
-execs="mcstas mcformat"
-
-case $2 in
- DEINSTALL)
-
- if [ ! -f "${PKG_PREFIX}/bin" ]; then
- echo "Deinstalling links to executables in ${PKG_PREFIX}/bin.";
- for target in ${execs}; do
- rm ${PKG_PREFIX}/bin/${target};
- done
- fi
- ;;
-esac
-
-exit 0
diff --git a/science/mcstas/files/pkg-install.in b/science/mcstas/files/pkg-install.in
deleted file mode 100644
index a3fe95daaf97..000000000000
--- a/science/mcstas/files/pkg-install.in
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-PKG_PREFIX=${PKG_PREFIX:-%%PREFIX%%}
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
-fi
-
-pname=${1%-*}
-pversion=${1##*-}
-
-#echo the extracted port name is $pname
-#echo the extracted port version is $pversion
-
-execs="mcstas mcformat"
-
-case $2 in
- POST-INSTALL)
- if [ ! -f "${PKG_PREFIX}/bin" ]; then
- echo "Installing links to ${1} executables in ${PKG_PREFIX}/bin.";
- for target in ${execs}; do
- ln -s ${PKG_PREFIX}/${pname}/${pversion}/bin/${target} ${PKG_PREFIX}/bin/${target};
- done
- fi
- ;;
-esac
-
-exit 0
diff --git a/science/mcstas/pkg-plist b/science/mcstas/pkg-plist
index 87d20b68f7a9..82cdcd664394 100644
--- a/science/mcstas/pkg-plist
+++ b/science/mcstas/pkg-plist
@@ -1,60 +1,62 @@
-mcstas/%%PORTVERSION%%/LGPL
-mcstas/%%PORTVERSION%%/LICENSE.LIB
-mcstas/%%PORTVERSION%%/NOMENCLATURE
-mcstas/%%PORTVERSION%%/README
-mcstas/%%PORTVERSION%%/bin/mcformat
-mcstas/%%PORTVERSION%%/bin/mcstas
-mcstas/%%PORTVERSION%%/data/Al.nxs
-mcstas/%%PORTVERSION%%/data/Cu.nxs
-mcstas/%%PORTVERSION%%/doc/man/man1/mcformat-%%PORTVERSION%%.1
-mcstas/%%PORTVERSION%%/doc/man/man1/mcstas-%%PORTVERSION%%.1
-mcstas/%%PORTVERSION%%/environment
-mcstas/%%PORTVERSION%%/module
-mcstas/%%PORTVERSION%%/share/adapt_tree-lib.c
-mcstas/%%PORTVERSION%%/share/adapt_tree-lib.h
-mcstas/%%PORTVERSION%%/share/general.c
-mcstas/%%PORTVERSION%%/share/general.h
-mcstas/%%PORTVERSION%%/share/interoff-lib.c
-mcstas/%%PORTVERSION%%/share/interoff-lib.h
-mcstas/%%PORTVERSION%%/share/interpolation/array-utils.c
-mcstas/%%PORTVERSION%%/share/interpolation/array-utils.h
-mcstas/%%PORTVERSION%%/share/interpolation/natural/README
-mcstas/%%PORTVERSION%%/share/interpolation/natural/delaunay.c
-mcstas/%%PORTVERSION%%/share/interpolation/natural/delaunay.h
-mcstas/%%PORTVERSION%%/share/interpolation/natural/example.c
-mcstas/%%PORTVERSION%%/share/interpolation/natural/natural.c
-mcstas/%%PORTVERSION%%/share/interpolation/natural/natural.h
-mcstas/%%PORTVERSION%%/share/interpolation/natural/predicates.c
-mcstas/%%PORTVERSION%%/share/interpolation/natural/utils-extra.c
-mcstas/%%PORTVERSION%%/share/interpolation/natural/utils-extra.h
-mcstas/%%PORTVERSION%%/share/interpolation/natural/vertex.h
-mcstas/%%PORTVERSION%%/share/interpolation/nearest/README
-mcstas/%%PORTVERSION%%/share/interpolation/nearest/example.c
-mcstas/%%PORTVERSION%%/share/interpolation/nearest/kdtree.c
-mcstas/%%PORTVERSION%%/share/interpolation/nearest/kdtree.h
-mcstas/%%PORTVERSION%%/share/interpolation/nearest/vertex.h
-mcstas/%%PORTVERSION%%/share/interpolation/resample.c
-mcstas/%%PORTVERSION%%/share/interpolation/resample.h
-mcstas/%%PORTVERSION%%/share/intersection.c
-mcstas/%%PORTVERSION%%/share/intersection.h
-mcstas/%%PORTVERSION%%/share/mccode-r.c
-mcstas/%%PORTVERSION%%/share/mccode-r.h
-mcstas/%%PORTVERSION%%/share/mcstas-r.c
-mcstas/%%PORTVERSION%%/share/mcstas-r.h
-mcstas/%%PORTVERSION%%/share/nxslib/README.TXT
-mcstas/%%PORTVERSION%%/share/nxslib/nxs.c
-mcstas/%%PORTVERSION%%/share/nxslib/nxs.h
-mcstas/%%PORTVERSION%%/share/nxslib/sgclib.c
-mcstas/%%PORTVERSION%%/share/nxslib/sgfind.c
-mcstas/%%PORTVERSION%%/share/nxslib/sghkl.c
-mcstas/%%PORTVERSION%%/share/nxslib/sginfo.h
-mcstas/%%PORTVERSION%%/share/nxslib/sgio.c
-mcstas/%%PORTVERSION%%/share/nxslib/sgsi.c
-mcstas/%%PORTVERSION%%/share/pol-lib.c
-mcstas/%%PORTVERSION%%/share/pol-lib.h
-mcstas/%%PORTVERSION%%/share/read_table-lib.c
-mcstas/%%PORTVERSION%%/share/read_table-lib.h
-mcstas/%%PORTVERSION%%/share/ref-lib.c
-mcstas/%%PORTVERSION%%/share/ref-lib.h
-mcstas/%%PORTVERSION%%/share/vitess-lib.c
-mcstas/%%PORTVERSION%%/share/vitess-lib.h
+mcstas/%%DISTVERSION%%/LGPL
+mcstas/%%DISTVERSION%%/LICENSE.LIB
+mcstas/%%DISTVERSION%%/NOMENCLATURE
+mcstas/%%DISTVERSION%%/README
+mcstas/%%DISTVERSION%%/bin/mcformat
+mcstas/%%DISTVERSION%%/bin/mcstas
+mcstas/%%DISTVERSION%%/data/Al.nxs
+mcstas/%%DISTVERSION%%/data/Cu.nxs
+mcstas/%%DISTVERSION%%/doc/man/man1/mcformat-%%DISTVERSION%%.1.gz
+mcstas/%%DISTVERSION%%/doc/man/man1/mcstas-%%DISTVERSION%%.1.gz
+mcstas/%%DISTVERSION%%/environment
+mcstas/%%DISTVERSION%%/module
+mcstas/%%DISTVERSION%%/share/adapt_tree-lib.c
+mcstas/%%DISTVERSION%%/share/adapt_tree-lib.h
+mcstas/%%DISTVERSION%%/share/general.c
+mcstas/%%DISTVERSION%%/share/general.h
+mcstas/%%DISTVERSION%%/share/interoff-lib.c
+mcstas/%%DISTVERSION%%/share/interoff-lib.h
+mcstas/%%DISTVERSION%%/share/interpolation/array-utils.c
+mcstas/%%DISTVERSION%%/share/interpolation/array-utils.h
+mcstas/%%DISTVERSION%%/share/interpolation/natural/README
+mcstas/%%DISTVERSION%%/share/interpolation/natural/delaunay.c
+mcstas/%%DISTVERSION%%/share/interpolation/natural/delaunay.h
+mcstas/%%DISTVERSION%%/share/interpolation/natural/example.c
+mcstas/%%DISTVERSION%%/share/interpolation/natural/natural.c
+mcstas/%%DISTVERSION%%/share/interpolation/natural/natural.h
+mcstas/%%DISTVERSION%%/share/interpolation/natural/predicates.c
+mcstas/%%DISTVERSION%%/share/interpolation/natural/utils-extra.c
+mcstas/%%DISTVERSION%%/share/interpolation/natural/utils-extra.h
+mcstas/%%DISTVERSION%%/share/interpolation/natural/vertex.h
+mcstas/%%DISTVERSION%%/share/interpolation/nearest/README
+mcstas/%%DISTVERSION%%/share/interpolation/nearest/example.c
+mcstas/%%DISTVERSION%%/share/interpolation/nearest/kdtree.c
+mcstas/%%DISTVERSION%%/share/interpolation/nearest/kdtree.h
+mcstas/%%DISTVERSION%%/share/interpolation/nearest/vertex.h
+mcstas/%%DISTVERSION%%/share/interpolation/resample.c
+mcstas/%%DISTVERSION%%/share/interpolation/resample.h
+mcstas/%%DISTVERSION%%/share/intersection.c
+mcstas/%%DISTVERSION%%/share/intersection.h
+mcstas/%%DISTVERSION%%/share/mccode-r.c
+mcstas/%%DISTVERSION%%/share/mccode-r.h
+mcstas/%%DISTVERSION%%/share/mcstas-r.c
+mcstas/%%DISTVERSION%%/share/mcstas-r.h
+mcstas/%%DISTVERSION%%/share/nxslib/README.TXT
+mcstas/%%DISTVERSION%%/share/nxslib/nxs.c
+mcstas/%%DISTVERSION%%/share/nxslib/nxs.h
+mcstas/%%DISTVERSION%%/share/nxslib/sgclib.c
+mcstas/%%DISTVERSION%%/share/nxslib/sgfind.c
+mcstas/%%DISTVERSION%%/share/nxslib/sghkl.c
+mcstas/%%DISTVERSION%%/share/nxslib/sginfo.h
+mcstas/%%DISTVERSION%%/share/nxslib/sgio.c
+mcstas/%%DISTVERSION%%/share/nxslib/sgsi.c
+mcstas/%%DISTVERSION%%/share/pol-lib.c
+mcstas/%%DISTVERSION%%/share/pol-lib.h
+mcstas/%%DISTVERSION%%/share/read_table-lib.c
+mcstas/%%DISTVERSION%%/share/read_table-lib.h
+mcstas/%%DISTVERSION%%/share/ref-lib.c
+mcstas/%%DISTVERSION%%/share/ref-lib.h
+mcstas/%%DISTVERSION%%/share/vitess-lib.c
+mcstas/%%DISTVERSION%%/share/vitess-lib.h
+bin/mcstas
+bin/mcformat