aboutsummaryrefslogtreecommitdiff
path: root/science/meep/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:25:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:25:16 +0000
commit597afc47baba19000afd8ec4880a2c47975b0367 (patch)
treeeb9a806366343ecfc3a5146e70b637f09d4e62c7 /science/meep/Makefile
parent8d6597e0bb9591c40fc6d0c6e2159fca51178d56 (diff)
downloadports-597afc47baba19000afd8ec4880a2c47975b0367.tar.gz
ports-597afc47baba19000afd8ec4880a2c47975b0367.zip
Remove ${PORTSDIR}/ from dependencies, categories r, s, t, and u.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412349
Diffstat (limited to 'science/meep/Makefile')
-rw-r--r--science/meep/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
index e419b2f0ef2a..cf8d125db62d 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -10,13 +10,13 @@ MASTER_SITES= http://ab-initio.mit.edu/meep/
MAINTAINER= devel@stasyan.com
COMMENT= FDTD simulation software to model electromagnetic systems
-BUILD_DEPENDS= harminv:${PORTSDIR}/science/harminv \
- gsed:${PORTSDIR}/textproc/gsed
-LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2 \
- libblas.so:${PORTSDIR}/math/blas \
- libctl.so:${PORTSDIR}/science/libctl \
- libhdf5.so:${PORTSDIR}/science/hdf5
-RUN_DEPENDS= harminv:${PORTSDIR}/science/harminv
+BUILD_DEPENDS= harminv:science/harminv \
+ gsed:textproc/gsed
+LIB_DEPENDS= libguile-2.0.so:lang/guile2 \
+ libblas.so:math/blas \
+ libctl.so:science/libctl \
+ libhdf5.so:science/hdf5
+RUN_DEPENDS= harminv:science/harminv
GNU_CONFIGURE= yes
USE_GCC= yes
@@ -49,14 +49,14 @@ PLIST_SUB+= MPI="@comment " NOMPI=""
.endif
.if ${PORT_OPTIONS:MMPICH2}
-LIB_DEPENDS+= libmpich.so.8:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= libmpich.so.8:net/mpich2
CONFIGURE_ENV+= MPICXX=${LOCALBASE}/bin/mpicc
CFLAGS+= -I${LOCALBASE}/include
.endif
.if ${PORT_OPTIONS:MOPENMPI}
-BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpiCC:net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:net/openmpi
CONFIGURE_ENV+= MPICXX=${LOCALBASE}/mpi/openmpi/bin/mpiCC
CFLAGS+= -I${LOCALBASE}/mpi/openmpi/include
.endif