aboutsummaryrefslogtreecommitdiff
path: root/science/meep
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-25 00:27:10 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-25 00:27:10 +0000
commit551d43b7242c721a963241844108beeb7b603a3a (patch)
tree4ba31109f4b7291a6bfedc7dfc5b48959db9930e /science/meep
parent9b77b5a94274fd5adc704c1a800954fe17a1cc25 (diff)
downloadports-551d43b7242c721a963241844108beeb7b603a3a.tar.gz
ports-551d43b7242c721a963241844108beeb7b603a3a.zip
Meep (or MEEP) is a free finite-difference time-domain (FDTD) simulation
software package developed at MIT to model electromagnetic systems, along with our MPB eigenmode package. WWW: http://ab-initio.mit.edu/wiki/index.php/Meep PR: ports/142158 Submitted by: Stas Timokhin <devel@stasyan.com>
Notes
Notes: svn path=/head/; revision=248499
Diffstat (limited to 'science/meep')
-rw-r--r--science/meep/Makefile36
-rw-r--r--science/meep/distinfo3
-rw-r--r--science/meep/files/patch-configure17
-rw-r--r--science/meep/files/patch-src_mympi.hpp10
-rw-r--r--science/meep/pkg-descr5
-rw-r--r--science/meep/pkg-plist13
6 files changed, 84 insertions, 0 deletions
diff --git a/science/meep/Makefile b/science/meep/Makefile
new file mode 100644
index 000000000000..786cc46f6daf
--- /dev/null
+++ b/science/meep/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: science/meep
+# Date created: 26 Dec 2009
+# Whom: Stas Timokhin <devel@stasyan.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meep
+PORTVERSION= 1.1.1
+CATEGORIES= science
+MASTER_SITES= http://ab-initio.mit.edu/meep/
+
+MAINTAINER= devel@stasyan.com
+COMMENT= FDTD simulation software to model electromagnetic systems
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_FORTRAN= yes
+USE_GCC= 4.4+
+USE_ICONV= yes
+USE_GETTEXT= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LD_LIBRARY_PATH= -L${LOCALBASE}/lib -L/usr/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LD_LIBRARY_PATH="${LD_LIBRARY_PATH}" LDFLAGS="${LDFLAGS}"
+
+BUILD_DEPENDS+= bash:${PORTSDIR}/shells/bash \
+ harminv:${PORTSDIR}/science/harminv
+LIB_DEPENDS+= guile.20:${PORTSDIR}/lang/guile \
+ blas.2:${PORTSDIR}/math/blas \
+ ctl.4:${PORTSDIR}/science/libctl \
+ hdf5.0:${PORTSDIR}/science/hdf5 \
+ ltdl.7:${PORTSDIR}/devel/libltdl22
+RUN_DEPENDS+= harminv:${PORTSDIR}/science/harminv
+
+.include <bsd.port.mk>
diff --git a/science/meep/distinfo b/science/meep/distinfo
new file mode 100644
index 000000000000..2e8ee0180c4a
--- /dev/null
+++ b/science/meep/distinfo
@@ -0,0 +1,3 @@
+MD5 (meep-1.1.1.tar.gz) = 415e0cd312b6caa22b5dd612490e1ccf
+SHA256 (meep-1.1.1.tar.gz) = 7a97b5555da1f9ea2ec6eed5c45bd97bcd6ddbd54bdfc181f46c696dffc169f2
+SIZE (meep-1.1.1.tar.gz) = 751244
diff --git a/science/meep/files/patch-configure b/science/meep/files/patch-configure
new file mode 100644
index 000000000000..8fa222f9213e
--- /dev/null
+++ b/science/meep/files/patch-configure
@@ -0,0 +1,17 @@
+--- configure.orig 2009-08-21 23:35:00.000000000 +0700
++++ configure 2009-12-26 13:21:45.000000000 +0600
+@@ -1,4 +1,4 @@
+-#! /bin/sh
++#! /usr/local/bin/bash
+ # Guess values for system-dependent variables and create Makefiles.
+ # Generated by GNU Autoconf 2.63 for meep 1.1.1.
+ #
+@@ -10318,7 +10318,7 @@
+ LIBTOOL_DEPS="$ltmain"
+
+ # Always use our own libtool.
+-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
++LIBTOOL='/usr/local/bin/bash $(top_builddir)/libtool'
+
+
+
diff --git a/science/meep/files/patch-src_mympi.hpp b/science/meep/files/patch-src_mympi.hpp
new file mode 100644
index 000000000000..e634277c5c2a
--- /dev/null
+++ b/science/meep/files/patch-src_mympi.hpp
@@ -0,0 +1,10 @@
+--- src/meep/mympi.hpp.orig 2009-12-26 13:03:30.000000000 +0600
++++ src/meep/mympi.hpp 2009-12-26 13:04:39.000000000 +0600
+@@ -19,6 +19,7 @@
+ #define MEEP_MY_MPI_H
+
+ #include <complex>
++#include <stdio.h>
+ using namespace std;
+
+ namespace meep {
diff --git a/science/meep/pkg-descr b/science/meep/pkg-descr
new file mode 100644
index 000000000000..0de0136ae788
--- /dev/null
+++ b/science/meep/pkg-descr
@@ -0,0 +1,5 @@
+Meep (or MEEP) is a free finite-difference time-domain (FDTD) simulation
+software package developed at MIT to model electromagnetic systems,
+along with our MPB eigenmode package.
+
+WWW: http://ab-initio.mit.edu/wiki/index.php/Meep
diff --git a/science/meep/pkg-plist b/science/meep/pkg-plist
new file mode 100644
index 000000000000..2a0db0cf58a7
--- /dev/null
+++ b/science/meep/pkg-plist
@@ -0,0 +1,13 @@
+bin/meep
+include/meep.hpp
+include/meep/mympi.hpp
+include/meep/vec.hpp
+lib/libmeep.a
+lib/libmeep.la
+lib/pkgconfig/meep.pc
+share/meep/casimir.scm
+share/meep/meep-enums.scm
+share/meep/meep.scm
+@dirrm share/meep
+@dirrmtry lib/pkgconfig
+@dirrm include/meep