aboutsummaryrefslogtreecommitdiff
path: root/science/mopac
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-19 07:49:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-19 07:52:28 +0000
commitdb283c306304a61abbea65249f40fb06c1393232 (patch)
tree5cf93fb1241f0a9e3cca8c792b2a5c360cf455da /science/mopac
parentdf15aefb4ead8b7d4e9e6bc54a8bc6d0a480d8d9 (diff)
downloadports-db283c306304a61abbea65249f40fb06c1393232.tar.gz
ports-db283c306304a61abbea65249f40fb06c1393232.zip
biology/mopac: Move to science/mopac; Add TIMESTAMP to distinfo; Take maintainership
Diffstat (limited to 'science/mopac')
-rw-r--r--science/mopac/Makefile44
-rw-r--r--science/mopac/distinfo3
-rw-r--r--science/mopac/pkg-descr4
-rw-r--r--science/mopac/pkg-plist8
4 files changed, 59 insertions, 0 deletions
diff --git a/science/mopac/Makefile b/science/mopac/Makefile
new file mode 100644
index 000000000000..4e6be1cf82e1
--- /dev/null
+++ b/science/mopac/Makefile
@@ -0,0 +1,44 @@
+# Created by: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
+
+PORTNAME= mopac
+PORTVERSION= 7.${MOPAC_SUBVERSION}
+PORTREVISION= 8
+PORTEPOCH= 1
+CATEGORIES= science # chemistry
+MASTER_SITES= http://bioinformatics.org/ghemical/download/%SUBDIR%/
+MASTER_SITE_SUBDIR= release20111012 current
+DISTNAME= mopac7-${MOPAC_SUBVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Semi-empirical (MNDO, etc.) molecular orbital calculation
+
+LICENSE= GPLv2+
+
+USES= fortran gmake libtool pathfix
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= EXAMPLES
+
+MOPAC_SUBVERSION= 1.15
+
+post-patch:
+ @${REINPLACE_CMD} -e '/usage/s|run_||g' \
+ -e 's|./src/mopac7|${PREFIX}/libexec/mopac7|g' \
+ ${WRKSRC}/run_${PORTNAME}7
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/run_${PORTNAME}7 \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}7
+ ${INSTALL_PROGRAM} ${WRKSRC}/fortran/.libs/${PORTNAME}7 \
+ ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}7
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/test
+ ${INSTALL_DATA} ${WRKSRC}/tests/*.dat ${STAGEDIR}${EXAMPLESDIR}/test
+
+.include <bsd.port.mk>
diff --git a/science/mopac/distinfo b/science/mopac/distinfo
new file mode 100644
index 000000000000..2a8943e72967
--- /dev/null
+++ b/science/mopac/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655625116
+SHA256 (mopac7-1.15.tar.gz) = 6d7ac5d78522db70f7794fd816cea32829cfa9e93774202fe80ba5a54375fbaa
+SIZE (mopac7-1.15.tar.gz) = 764547
diff --git a/science/mopac/pkg-descr b/science/mopac/pkg-descr
new file mode 100644
index 000000000000..ebe8b3e0d5c5
--- /dev/null
+++ b/science/mopac/pkg-descr
@@ -0,0 +1,4 @@
+MOPAC7, semi-empirical (MNDO, AM1, PM3, MINDO/3) quantum-chemical
+calculation written by James J. P. Stewart and co-workers.
+
+WWW: http://bioinformatics.org/ghemical/
diff --git a/science/mopac/pkg-plist b/science/mopac/pkg-plist
new file mode 100644
index 000000000000..662c639fbc56
--- /dev/null
+++ b/science/mopac/pkg-plist
@@ -0,0 +1,8 @@
+bin/mopac7
+include/mopac7/libmopac7.h
+lib/libmopac7.a
+lib/libmopac7.so
+lib/libmopac7.so.1
+lib/libmopac7.so.1.0.13
+libdata/pkgconfig/libmopac7.pc
+libexec/mopac7