aboutsummaryrefslogtreecommitdiff
path: root/science/multiwfn
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-20 21:49:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-20 21:49:52 +0000
commitc7610a5f43088a5ff3bce720ac921cf2cbbc63fe (patch)
treea2c222af3eda1011ee743c280e59634e7741fcc2 /science/multiwfn
parent2651c3e3ba4c0c90deac6aad948f6411551fb371 (diff)
downloadports-c7610a5f43088a5ff3bce720ac921cf2cbbc63fe.tar.gz
ports-c7610a5f43088a5ff3bce720ac921cf2cbbc63fe.zip
science/multiwfn: Small corrections
Diffstat (limited to 'science/multiwfn')
-rw-r--r--science/multiwfn/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/science/multiwfn/Makefile b/science/multiwfn/Makefile
index cbd6cf46e81f..b7ad6fa69f9d 100644
--- a/science/multiwfn/Makefile
+++ b/science/multiwfn/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= science
MASTER_SITES= http://sobereva.com/multiwfn/misc/:main \
https://www.dislin.de/downloads/unix/:dislin
DISTFILES= Multiwfn_${DISTVERSION}_dev_src_Linux.zip:main \
- dislin-11.5.fbsd.64.tar.gz:dislin # (!!!) dislin is a closed-source library distributed as binary, source code is sold for $$
+ dislin-${DISLIN_VERSION}.fbsd.64.tar.gz:dislin # (!!!) dislin is a closed-source library distributed as binary, source code is sold for $$
MAINTAINER= yuri@FreeBSD.org
COMMENT= Multifunctional wavefunction analysis for quantum chemistry
@@ -14,7 +14,7 @@ WWW= http://sobereva.com/multiwfn/index.html
LICENSE= GPLv2
ONLY_FOR_ARCHS= amd64
-ONLY_FOR_ARCHS_REASON= dislin is closed source only available for amd64
+ONLY_FOR_ARCHS_REASON= dislin library is closed source for which binary is only available for amd64
LIB_DEPENDS= libblas.so:math/blas \
liblapack.so:math/lapack \
@@ -36,14 +36,18 @@ LDFLAGS+= -lblas -llapack
ALL_TARGET= default
-BINARY_ALIAS= ifort=gfortran12 \
+DISLIN_VERSION= 11.5
+
+BINARY_ALIAS= ifort=gfortran${GCC_DEFAULT} \
gcc=${CC}
PLIST_FILES= bin/Multiwfn \
bin/Multiwfn_noGUI
post-patch: # replace the dislin.a library with the FreeBSD version
- @${CP} ${WRKDIR}/dislin-11.5/fbsd_64/lib/dislin_d-11.5.a ${WRKSRC}/dislin_d-11.0.a
+ @${CP} \
+ ${WRKDIR}/dislin-${DISLIN_VERSION}/fbsd_64/lib/dislin_d-${DISLIN_VERSION}.a \
+ ${WRKSRC}/dislin_d-11.0.a
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Multiwfn ${STAGEDIR}${PREFIX}/bin