aboutsummaryrefslogtreecommitdiff
path: root/science/nest
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-20 17:31:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-20 17:32:15 +0000
commitcfa85d90c89bbae6c06b2f49a82bbfd92506a1c5 (patch)
tree5b3af942bf0e71fd45af7e26d45339a9282fdff8 /science/nest
parentf13ffd3c91d2be45cbd2544551601430ae6aa6c9 (diff)
downloadports-cfa85d90c89bbae6c06b2f49a82bbfd92506a1c5.tar.gz
ports-cfa85d90c89bbae6c06b2f49a82bbfd92506a1c5.zip
science/nest: Mark the PYTHON option broken; Add the 'test' target
Reported by: Filippo Adamo <filippo.adamo@gmx.de> (broken python module)
Diffstat (limited to 'science/nest')
-rw-r--r--science/nest/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/science/nest/Makefile b/science/nest/Makefile
index ddd6eab25049..51658ab526a7 100644
--- a/science/nest/Makefile
+++ b/science/nest/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nest
DISTVERSIONPREFIX= v
DISTVERSION= 2.20.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science biology # NEST is used in neuroscience
MAINTAINER= yuri@FreeBSD.org
@@ -15,22 +15,26 @@ BROKEN_i386= https://github.com/nest/nest-simulator/issues/1205
LIB_DEPENDS= libgsl.so:math/gsl \
libltdl.so:devel/libltdl
-USES= cmake ncurses pkgconfig readline
+USES= cmake:testing ncurses pkgconfig readline
USE_GITHUB= yes
GH_PROJECT= nest-simulator
USE_LDCONFIG= yes
OPTIONS_DEFINE= PYTHON DOCS
-OPTIONS_DEFAULT= PYTHON
+#OPTIONS_DEFAULT= PYTHON
OPTIONS_SUB= yes
PYTHON_CMAKE_BOOL= BUILD_PYTHON
PYTHON_USES= python
PYTHON_USE= python=cython
PYTHON_CMAKE_ON= -DCYTHON_EXECUTABLE:STRING=${PREFIX}/bin/cython-${PYTHON_VER}
+PYTHON_BROKEN= https://github.com/nest/nest-simulator/issues/2193
PORTDOCS= *
+# 2 tests are known to fail, see https://github.com/nest/nest-simulator/issues/2190
+# tests require the port to be installed with DOCS=ON, see https://github.com/nest/nest-simulator/issues/2191
+
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc