aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-08-07 08:29:49 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-08-07 08:29:49 +0000
commit6546605e6be71bce9cf2f488b5c96e903b6a25ab (patch)
tree05180e03c9f3a7bb0d891302284b8cc771518139 /science/netcdf/Makefile
parentff57c42264d18020660152029484df359e2dc00f (diff)
downloadports-6546605e6be71bce9cf2f488b5c96e903b6a25ab.tar.gz
ports-6546605e6be71bce9cf2f488b5c96e903b6a25ab.zip
- Add experimental WITH_FORTRAN knob and a patch to have it compile.
- It's off by default as it doesn't seem to be required by any port. - No functional change. PR: ports/125915 Submitted by: Pedro F. Giffuni <pfgshield-freebsd@yahoo.com> Approved by: maintainer timeout (>2 Weeks)
Notes
Notes: svn path=/head/; revision=218179
Diffstat (limited to 'science/netcdf/Makefile')
-rw-r--r--science/netcdf/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 45d76cf3c598..9455b3c9fa46 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -17,11 +17,12 @@ COMMENT= Library for machine-independent, array-oriented data access
CONFLICTS= hdf-4.* netcdf-4.*
-CONFIGURE_ARGS= --enable-shared --disable-f77
+CONFIGURE_ARGS= --enable-shared
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -fPIC -DPIC -Df2cFortran"
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV+= ${MAKE_ENV}
MAN1= ncdump.1 ncgen.1
MAN3= netcdf.3
@@ -29,6 +30,15 @@ MAN3= netcdf.3
INFO= netcdf netcdf-c netcdf-cxx netcdf-f77 netcdf-f90 \
netcdf-install netcdf-tutorial
+.ifdef WITH_FORTRAN
+USE_FORTRAN= yes
+MAN3+= netcdf_f77.3 netcdf_f90.3
+PLIST_SUB+= FORTRAN=""
+.else
+CONFIGURE_ARGS+=--disable-f77
+PLIST_SUB+= FORTRAN="@comment "
+.endif
+
post-install:
@${STRIP_CMD} ${PREFIX}/bin/ncdump ${PREFIX}/bin/ncgen
${LN} -fs libnetcdf.so.4 ${PREFIX}/lib/libnetcdf.so
@@ -38,6 +48,8 @@ post-install:
.for file in COPYRIGHT README RELEASE_NOTES
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
+.else
+CONFIGURE_ARGS+= --disable-docs-install
.endif
regression-test: build