aboutsummaryrefslogtreecommitdiff
path: root/science/openmx
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-08 21:56:36 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-03-08 21:56:36 +0000
commite1d56a9db2541dd41f1907a5a19a686a326831cc (patch)
tree6a5120e4890360e5d98bb4a63ff86cfc80e8392f /science/openmx
parent0c69caeef6092fbf32d6330958bbb88f74c02443 (diff)
downloadports-e1d56a9db2541dd41f1907a5a19a686a326831cc.tar.gz
ports-e1d56a9db2541dd41f1907a5a19a686a326831cc.zip
Drop dependency on devel/openmp
- Drop if devel/llvm* was used as a substitute Approved by: yuri, rene (earlier version) Differential Revision: https://reviews.freebsd.org/D23020
Notes
Notes: svn path=/head/; revision=528082
Diffstat (limited to 'science/openmx')
-rw-r--r--science/openmx/Makefile5
-rw-r--r--science/openmx/files/patch-makefile2
2 files changed, 3 insertions, 4 deletions
diff --git a/science/openmx/Makefile b/science/openmx/Makefile
index 713c7a5232c7..612806700547 100644
--- a/science/openmx/Makefile
+++ b/science/openmx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openmx
DISTVERSION= 3.8.5 # the 18June12 patch upgrades 3.8 -> 3.8.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= science
MASTER_SITES= http://www.openmx-square.org/ \
http://www.openmx-square.org/bugfixed/18June12/:patch
@@ -23,8 +23,7 @@ BROKEN_i386= undefined reference to `__atomic_load', see bug#229605 and https://
LIB_DEPENDS= libblas.so:math/blas \
libfftw3.so:math/fftw3 \
liblapack.so:math/lapack \
- libmpich.so:net/mpich \
- libiomp5.so:devel/openmp
+ libmpich.so:net/mpich
USES= dos2unix fortran gmake localbase:ldflags
DOS2UNIX_FILES= openmx_common.h
diff --git a/science/openmx/files/patch-makefile b/science/openmx/files/patch-makefile
index f70af174a079..2a21aa3db1fe 100644
--- a/science/openmx/files/patch-makefile
+++ b/science/openmx/files/patch-makefile
@@ -9,7 +9,7 @@
-LIB= -L/opt/intel/mkl/lib -mkl=parallel -lmkl_intel_lp64 -lmkl_intel_thread -lmkl_core -lpthread -lifcore -lmpi -lmpi_f90 -lmpi_f77
+CC = mpicc $(CFLAGS) -fopenmp
+FC = mpif90 $(FFLAGS) -fopenmp
-+LIB= $(LDFLAGS) -lpthread -llapack -lblas -lgfortran -lfftw3 -liomp5
++LIB= $(LDFLAGS) -lpthread -llapack -lblas -lgfortran -lfftw3 -lomp