aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Algorithm-SVMLight/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-03 07:29:03 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-03 07:29:03 +0000
commit2d27cd587d0094ce6fa4719b0b5552723c137f2e (patch)
treeaec59ee0f2a41510c96c3dd1741f49deca6d464a /science/p5-Algorithm-SVMLight/Makefile
parent4eedc08959aeb191232fb16f0f372bbf97281bc7 (diff)
downloadports-2d27cd587d0094ce6fa4719b0b5552723c137f2e.tar.gz
ports-2d27cd587d0094ce6fa4719b0b5552723c137f2e.zip
Add p5-Algorithm-SVMLight 0.05, perl interface to SVMLight
Machine-Learning Package. PR: ports/101297 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=169535
Diffstat (limited to 'science/p5-Algorithm-SVMLight/Makefile')
-rw-r--r--science/p5-Algorithm-SVMLight/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/science/p5-Algorithm-SVMLight/Makefile b/science/p5-Algorithm-SVMLight/Makefile
new file mode 100644
index 000000000000..3e1246b0ea71
--- /dev/null
+++ b/science/p5-Algorithm-SVMLight/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Algorithm-SVMLight
+# Date created: 2006-07-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-SVMLight
+PORTVERSION= 0.05
+CATEGORIES= science perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interface to SVMLight Machine-Learning Package
+
+BUILD_DEPENDS= svmlight>=6.01_2:${PORTSDIR}/science/svmlight
+LIB_DEPENDS= svmlight:${PORTSDIR}/science/svmlight
+
+PERL_MODBUILD= yes
+
+MAN3= Algorithm::SVMLight.3
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
+ ${WRKSRC}/Build.PL
+
+.include <bsd.port.mk>