aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Chemistry-Bond-Find
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:24:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:24:14 +0000
commit5fd8c153ed529eeafe9b06c4e13cfb4c13cb3f1a (patch)
treef4ea4b0351e0e5269359ee9158ea1dd67edc5cbb /science/p5-Chemistry-Bond-Find
parent8c08caf30263886bd7afbb2a9d86c0b91c703a0a (diff)
downloadports-5fd8c153ed529eeafe9b06c4e13cfb4c13cb3f1a.tar.gz
ports-5fd8c153ed529eeafe9b06c4e13cfb4c13cb3f1a.zip
Perl module which provides functions for detecting the bonds in a molecule from
its 3D coordinates by using simple cutoffs, and for guessing the formal bond orders. WWW: http://search.cpan.org/dist/Chemistry-Bond-Find/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252042
Diffstat (limited to 'science/p5-Chemistry-Bond-Find')
-rw-r--r--science/p5-Chemistry-Bond-Find/Makefile25
-rw-r--r--science/p5-Chemistry-Bond-Find/distinfo3
-rw-r--r--science/p5-Chemistry-Bond-Find/pkg-descr5
-rw-r--r--science/p5-Chemistry-Bond-Find/pkg-plist7
4 files changed, 40 insertions, 0 deletions
diff --git a/science/p5-Chemistry-Bond-Find/Makefile b/science/p5-Chemistry-Bond-Find/Makefile
new file mode 100644
index 000000000000..0c01dcaa5460
--- /dev/null
+++ b/science/p5-Chemistry-Bond-Find/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Chemistry-Bond-Find
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Bond-Find
+PORTVERSION= 0.23
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Detect bonds in a molecule and assign formal bond orders
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+
+MAN3= Chemistry::Bond::Find.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Bond-Find/distinfo b/science/p5-Chemistry-Bond-Find/distinfo
new file mode 100644
index 000000000000..082324cd7f55
--- /dev/null
+++ b/science/p5-Chemistry-Bond-Find/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Bond-Find-0.23.tar.gz) = c8ece363b723cdc1e085bf5cc5ae5cec
+SHA256 (Chemistry-Bond-Find-0.23.tar.gz) = 07ee896bf91cbe94f46dca0bb0d222c0989432a6c8255691bafadcf4cbb3fae6
+SIZE (Chemistry-Bond-Find-0.23.tar.gz) = 9723
diff --git a/science/p5-Chemistry-Bond-Find/pkg-descr b/science/p5-Chemistry-Bond-Find/pkg-descr
new file mode 100644
index 000000000000..a7ecd48b85c5
--- /dev/null
+++ b/science/p5-Chemistry-Bond-Find/pkg-descr
@@ -0,0 +1,5 @@
+Perl module which provides functions for detecting the bonds in a molecule from
+its 3D coordinates by using simple cutoffs, and for guessing the formal bond
+orders.
+
+WWW: http://search.cpan.org/dist/Chemistry-Bond-Find/
diff --git a/science/p5-Chemistry-Bond-Find/pkg-plist b/science/p5-Chemistry-Bond-Find/pkg-plist
new file mode 100644
index 000000000000..74f8f5c0f545
--- /dev/null
+++ b/science/p5-Chemistry-Bond-Find/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Chemistry/Bond/Find.pm
+%%SITE_PERL%%/mach/auto/Chemistry/Bond/Find/.packlist
+@dirrmtry %%SITE_PERL%%/Chemistry
+@dirrmtry %%SITE_PERL%%/Chemistry/Bond
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Bond/Find
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Bond
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry