aboutsummaryrefslogtreecommitdiff
path: root/science/paje/Makefile
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2015-09-19 10:33:34 +0000
committerDavid Chisnall <theraven@FreeBSD.org>2015-09-19 10:33:34 +0000
commit9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a (patch)
treeda5a3eeed8b9041e9805decaee1098282defef37 /science/paje/Makefile
parent1ab0fd4963caeb7cec81a713c3a3af71edef6fec (diff)
downloadports-9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a.tar.gz
ports-9156bf1b9e9b3b62257cf63c3d8ec413c40fc70a.zip
Make all GNUstep ports install into the System domain so that the Local domain is available for stuff built from source.
Some ports were already installing in the System domain, for these just remove the Makefile lines explicitly specifying the install domain. The rest are installed in the Local domain, remove any overrides, update their pkg-plists and any explicit paths in the Makefiles and then bump port revision. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2977
Notes
Notes: svn path=/head/; revision=397315
Diffstat (limited to 'science/paje/Makefile')
-rw-r--r--science/paje/Makefile34
1 files changed, 17 insertions, 17 deletions
diff --git a/science/paje/Makefile b/science/paje/Makefile
index 017456b547b3..40512583d9f9 100644
--- a/science/paje/Makefile
+++ b/science/paje/Makefile
@@ -3,7 +3,7 @@
PORTNAME= paje
PORTVERSION= 1.97
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= science gnustep
MASTER_SITES= SF/${PORTNAME}/Releases
DISTNAME= Paje_${PORTVERSION}
@@ -18,27 +18,27 @@ USES= gnustep
USE_GNUSTEP= back build
WRKSRC= ${WRKDIR}/${DISTNAME}
-MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_LOCAL_ROOT}
+MAKE_ENV+= GNUSTEP_INSTALLATION_DIR=${GNUSTEP_SYSTEM_ROOT}
post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DOMAIN|#GNUSTEP_INSTALLATION_DOMAIN|' \
${WRKSRC}/GNUmakefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Paje.app/Paje \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/AggregatingFilter.bundle/AggregatingFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ContainerFilter.bundle/ContainerFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/EntityTypeFilter.bundle/EntityTypeFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/FieldFilter.bundle/FieldFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/FileReader.bundle/FileReader \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/General.bundle/General \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ImbricationFilter.bundle/ImbricationFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/OrderFilter.bundle/OrderFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/PajeEventDecoder.bundle/PajeEventDecoder \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/PajeSimulator.bundle/PajeSimulator \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ReductionFilter.bundle/ReductionFilter \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/SpaceTimeViewer.bundle/SpaceTimeViewer \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/StatViewer.bundle/StatViewer \
- ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/StorageController.bundle/StorageController
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Paje.app/Paje \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/AggregatingFilter.bundle/AggregatingFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/ContainerFilter.bundle/ContainerFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/EntityTypeFilter.bundle/EntityTypeFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/FieldFilter.bundle/FieldFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/FileReader.bundle/FileReader \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/General.bundle/General \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/ImbricationFilter.bundle/ImbricationFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/OrderFilter.bundle/OrderFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/PajeEventDecoder.bundle/PajeEventDecoder \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/PajeSimulator.bundle/PajeSimulator \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/ReductionFilter.bundle/ReductionFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/SpaceTimeViewer.bundle/SpaceTimeViewer \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/StatViewer.bundle/StatViewer \
+ ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Bundles/Paje/StorageController.bundle/StorageController
.include <bsd.port.mk>