aboutsummaryrefslogtreecommitdiff
path: root/science/pcmsolver
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-19 06:09:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-19 06:09:26 +0000
commit1d61321861e1bc43a54fbe8fbddb9698d070533c (patch)
tree7462275671ca64d9e8a5db9044b85ea10a20ae8c /science/pcmsolver
parentf721b763bff3e35eb95f876bf9d1cbfc748398e5 (diff)
downloadports-1d61321861e1bc43a54fbe8fbddb9698d070533c.tar.gz
ports-1d61321861e1bc43a54fbe8fbddb9698d070533c.zip
science/pcmsolver: Unbreak
It was breaking with both gfortran and clang. As it turned out, full CMAKE_ARGS break gfortan but a simpler version of CMAKE_ARGS doesn't.
Notes
Notes: svn path=/head/; revision=487784
Diffstat (limited to 'science/pcmsolver')
-rw-r--r--science/pcmsolver/Makefile11
-rw-r--r--science/pcmsolver/files/patch-CMakeLists.txt10
2 files changed, 16 insertions, 5 deletions
diff --git a/science/pcmsolver/Makefile b/science/pcmsolver/Makefile
index 9aa832c69169..dea67e536c88 100644
--- a/science/pcmsolver/Makefile
+++ b/science/pcmsolver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pcmsolver
DISTVERSIONPREFIX= v
DISTVERSION= 1.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -12,16 +12,17 @@ COMMENT= API for the Polarizable Continuum Model
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to build
BROKEN_powerpc64= fails to compile: SphericalDiffuse.cpp:182: invalid initialization of non-const reference
-LIB_DEPENDS= libflang.so:devel/flang # USES=fortran:clang breaks in configure: can't find libs directory
-
-USES= cmake:outsource,noninja python
+USES= cmake:outsource,noninja fortran python
USE_GITHUB= yes
GH_ACCOUNT= PCMSolver
USE_LDCONFIG= yes
+do-configure: # full CMAKE_ARGS breaks configure: it can't find fortran's libraries
+ @${MKDIR} ${CONFIGURE_WRKSRC}
+ @cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} -DCMAKE_BUILD_TYPE:STRING="Release" ${CMAKE_SOURCE_PATH}
+
post-patch:
@${REINPLACE_CMD} -e 's|"-O3 |"$${CMAKE_C_FLAGS} |' \
${WRKSRC}/cmake/custom/compilers/*.cmake
diff --git a/science/pcmsolver/files/patch-CMakeLists.txt b/science/pcmsolver/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e49387be7c1c
--- /dev/null
+++ b/science/pcmsolver/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2018-12-19 05:45:58 UTC
++++ CMakeLists.txt
+@@ -80,4 +80,6 @@ include(eigen)
+ include(libtaylor)
+ include(zlib)
+ include(autocmake_src)
+-include(test)
++if (BUILD_TESTING)
++ include(test)
++endif()