aboutsummaryrefslogtreecommitdiff
path: root/science/pnetcdf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-20 18:56:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-20 18:56:03 +0000
commit40fa80b4fe0bf18586d11ff873a4fddf31624717 (patch)
treed4e8bf7fd2644efb19907256d6d3c9ca83f6420c /science/pnetcdf
parent72d85e1980f9b9a6878be5ca4d506c0250a918e9 (diff)
downloadports-40fa80b4fe0bf18586d11ff873a4fddf31624717.tar.gz
ports-40fa80b4fe0bf18586d11ff873a4fddf31624717.zip
Add OPENMPI3 option
- Change default from OPENMPI to OPENMPI3 - Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=470472
Diffstat (limited to 'science/pnetcdf')
-rw-r--r--science/pnetcdf/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index b6401e2f34dc..64e16d246a74 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pnetcdf
PORTVERSION= 1.8.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= science parallel
MASTER_SITES= http://cucis.ece.northwestern.edu/projects/PnetCDF/Release/ \
LOCAL/sunpoet
@@ -14,10 +14,11 @@ COMMENT= Library providing high-performance I/O
OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= MPI
-OPTIONS_SINGLE_MPI= OPENMPI OPENMPI2 MPICH2
-OPTIONS_DEFAULT=OPENMPI
-OPENMPI_DESC= Parallel processing support via Open MPI 1.x
-OPENMPI2_DESC= Parallel processing support via Open MPI 2.x
+OPTIONS_SINGLE_MPI= OPENMPI OPENMPI2 OPENMPI3 MPICH2
+OPTIONS_DEFAULT=OPENMPI3
+OPENMPI_DESC= Parallel processing support via Open MPI 1.x
+OPENMPI2_DESC= Parallel processing support via Open MPI 2.x
+OPENMPI3_DESC= Parallel processing support via Open MPI 3.x
CONFLICTS_INSTALL= hdf-4.*
@@ -36,6 +37,8 @@ OPENMPI_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi
OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
OPENMPI2_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi2
OPENMPI2_LIB_DEPENDS= libmpi.so:net/openmpi2
+OPENMPI3_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi3
+OPENMPI3_LIB_DEPENDS= libmpi.so:net/openmpi3
post-patch:
@${REINPLACE_CMD} -e '/$$(INSTALL.*$$(PREFIX)/ s|$$(PREFIX)|$$(DESTDIR)&|' ${WRKSRC}/Makefile.in