aboutsummaryrefslogtreecommitdiff
path: root/science/py-GPy/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-18 06:24:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-18 06:24:14 +0000
commit4c4a05c73ce8986b621767ee410c3161ea181690 (patch)
tree8bd1b3fb8131fad13c43945498024bb2ea73d189 /science/py-GPy/Makefile
parent6bb36770f52b40b1fbdee711ffbfa1f3aa1cfc3f (diff)
downloadports-4c4a05c73ce8986b621767ee410c3161ea181690.tar.gz
ports-4c4a05c73ce8986b621767ee410c3161ea181690.zip
New port: science/py-GPy: Gaussian process toolbox
Notes
Notes: svn path=/head/; revision=487729
Diffstat (limited to 'science/py-GPy/Makefile')
-rw-r--r--science/py-GPy/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/science/py-GPy/Makefile b/science/py-GPy/Makefile
new file mode 100644
index 000000000000..ca1adc883309
--- /dev/null
+++ b/science/py-GPy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= GPy
+DISTVERSION= 1.9.6
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Gaussian process toolbox
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libomp.so:devel/openmp
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.16:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramz>=0.9.0:science/py-paramz@${PY_FLAVOR}
+
+USES= localbase python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>