aboutsummaryrefslogtreecommitdiff
path: root/science/py-PyNE/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 15:06:54 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 15:13:01 +0000
commit328ae4074233a5b85e0e38efece1af5dcc218160 (patch)
tree982ebbc6507160ebcefcd1d47f6c4bdc458734da /science/py-PyNE/Makefile
parent72fa35d5cb531c78702fc467df019369e3676eff (diff)
downloadports-328ae4074233a5b85e0e38efece1af5dcc218160.tar.gz
ports-328ae4074233a5b85e0e38efece1af5dcc218160.zip
*/*: Replace science/szip with science/libaec
- Bump PORTREVISION of dependent ports for dependency change szip does not allow redistribution in binary form without proper commercial license. Its LICENSE_PERMS should be set to no-auto-accept which blocks building this port, therefore building dependent ports are also blocked. Switch all dependent ports to science/libaec to avoid conflicts and license issue. PR: 228743, 246097, 250165
Diffstat (limited to 'science/py-PyNE/Makefile')
-rw-r--r--science/py-PyNE/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/py-PyNE/Makefile b/science/py-PyNE/Makefile
index d8576edc4521..5cbc40b3dce0 100644
--- a/science/py-PyNE/Makefile
+++ b/science/py-PyNE/Makefile
@@ -1,6 +1,6 @@
PORTNAME= PyNE
DISTVERSION= 0.7.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= http://raw.githubusercontent.com/pyne/data/master/:decay \
http://raw.githubusercontent.com/pyne/data/master/:cram \
@@ -30,7 +30,7 @@ BUILD_DEPENDS= cmake:devel/cmake \
${PY_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libMOAB.so:math/moab \
- libsz.so:science/szip
+ libsz.so:science/libaec
RUN_DEPENDS= ${PY_DEPENDS}
USES= compiler:c++17-lang fortran python:3.7+