aboutsummaryrefslogtreecommitdiff
path: root/science/py-dimod
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-08-14 05:09:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-08-14 05:12:16 +0000
commit29ad935bb800a12512d3b5ad319a543a68429737 (patch)
tree312853fdc6967b1341b4a6a0da98734947b2bdf6 /science/py-dimod
parent9b21b2e65cdfc3335192301f680626d3c7eb502e (diff)
downloadports-29ad935bb800a12512d3b5ad319a543a68429737.tar.gz
ports-29ad935bb800a12512d3b5ad319a543a68429737.zip
science/py-dimod: New port: DWave: Shared API for QUBO/Ising samplers
Diffstat (limited to 'science/py-dimod')
-rw-r--r--science/py-dimod/Makefile26
-rw-r--r--science/py-dimod/distinfo3
-rw-r--r--science/py-dimod/pkg-descr11
3 files changed, 40 insertions, 0 deletions
diff --git a/science/py-dimod/Makefile b/science/py-dimod/Makefile
new file mode 100644
index 000000000000..6aed1b4e64f5
--- /dev/null
+++ b/science/py-dimod/Makefile
@@ -0,0 +1,26 @@
+PORTNAME= dimod
+DISTVERSION= 0.11.4
+CATEGORIES= science graphics
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DWave: Shared API for QUBO/Ising samplers
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+PY_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}reno>0:textproc/py-reno@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python:3.7+
+USE_PYTHON= distutils cython autoplist unittest # tests are broken, see https://github.com/dwavesystems/dimod/issues/1234
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME} -name "*${PYTHON_EXT_SUFFIX}.so" | ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>
diff --git a/science/py-dimod/distinfo b/science/py-dimod/distinfo
new file mode 100644
index 000000000000..73d6a71a1597
--- /dev/null
+++ b/science/py-dimod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660431665
+SHA256 (dimod-0.11.4.tar.gz) = 3b0db8f6cb37d2679658dbaaec8d6291675b35f36d7b1f8ee1a132b57b4dee3e
+SIZE (dimod-0.11.4.tar.gz) = 1858324
diff --git a/science/py-dimod/pkg-descr b/science/py-dimod/pkg-descr
new file mode 100644
index 000000000000..dcaf688769da
--- /dev/null
+++ b/science/py-dimod/pkg-descr
@@ -0,0 +1,11 @@
+dimod is a part of the software stack for accessing quantum computing hardware
+made by D-Wave company.
+
+dimod is a shared API for samplers. It provides:
+* classes for quadratic models - such as the binary quadratic model (BQM) class
+ that contains Ising and QUBO models used by samplers such as the D-Wave system
+ - and higher-order (non-quadratic) models
+* reference examples of samplers and composed samplers
+* abstract base classes for constructing new samplers and composed samplers
+
+WWW: https://github.com/dwavesystems/dimod